Forum Linux.debian/ubuntu apache 2.4.25 sur debian et repertoire de contenus

Posté par . Licence CC by-sa.
Tags : aucun
0
19
mar.
2019

bonjour à tous

il y a quelques années il était possible de choisir une autre partition que la partition système pour stocker des fichiers a servir en http.

exemple:

/etc/apache2/sites-available/000-default.conf

DocumentRoot /media/toto/www
<Directory /media/toto/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

quelque soit la manière de faire j'ai erreur 403 "vous n'avez pas les permissions"
pour le test au moins il suffit que tout le monde puisse executer les dossiers et lire les fichiers
avez vous depuis apache 2.4 connu ce même problème pour du contenu web stocké sur une autre partition que celle du programme apache  ?
parce que là je n'ai plus d'idées
merci

pour le moment j'utilise meiga qui fait le job
https://launchpadlibrarian.net/191629983/meiga_0.4.3-1utopic_amd64.deb

  • # apache 2.4.25 repertoire de contenus

    Posté par . Évalué à 2 (+1/-0).

    Salut Robertix,

    Aucun soucis pour utiliser un autre répertoire que celui de base, si :

    Le contenu est exécutable et accessible à l'utilisateur www-data sur Debian.
    Si toto doit aussi y avoir accès, tu peux jouer avec les groupes (ex : chown -R toto:www-data) ou passer par des ACL.

    Ça répond à ta question ?

    • [^] # Re: apache 2.4.25 repertoire de contenus

      Posté par . Évalué à -10 (+0/-0).

      je n'ai pas réussi cela sur un autre partition que apache2,c'est erreur 403

      • [^] # Re: apache 2.4.25 repertoire de contenus

        Posté par . Évalué à 0 (+0/-1).

        je n'ai pas réussi cela sur un autre partition que apache2,c'est erreur 403

        La je ne te comprends plus..partition apache ?

        Deja de base dans /etc/apache2/apache2.conf, la racine est en Require all denied, donc à adapter.

        Sets the default security model of the Apache2 HTTPD server.
        It does not allow access to the root filesystem outside of /usr/share and /var/www.
        The former is used by web applications packaged in Debian,
        the latter may be used for local directories served by the web server. If
        your system is serving content from a sub-directory in /srv you must allow
        access here, or in any related virtual host.

        Options FollowSymLinks
        AllowOverride None
        Require all denied

        Attention à la sécurité, mais si tu passes de denied à granted pour la partie directory / directement dans /etc/apache2/apache2.conf, tu ne devrais plus avoir de 403.

        • [^] # Re: apache 2.4.25 repertoire de contenus

          Posté par . Évalué à -9 (+1/-0).

          j'ai formaté une clé usb en ext4 pour le test
          /media/robertix/5fe3ebf1-60a7-43a3-bac6-b6c501a161ca/index.html

          j'ai modifié les droits ainsi pour être large en permissions

          media root:root 755
          robertix root:root 755
          5fe3ebf1-60a7-43a3-bac6-b6c501a161ca www-data:www-data 755
          index.html www-data:www-data 444
          
          #/etc/apache2/sites-enabled/000-default.conf
          
          DocumentRoot /media/robertix/5fe3ebf1-60a7-43a3-bac6-b6c501a161ca
          <Directory //media/robertix/5fe3ebf1-60a7-43a3-bac6-b6c501a161ca/>
              Options Indexes FollowSymLinks
              AllowOverride None
              Require all granted
          </Directory>
          

          c'est ok,c'était les permissions insufisantes sur les dossiers parents en execution
          évidement a adapter au plus juste quand on sert à l'extérieur sur le réseau

  • # solution - configurer le vhost

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 19/03/19 à 13:36.

    Testé juste en ajoutant les lignes suivantes dans mon vhost (sans ce paragraphe j'ai la même erreur que toi):

    DocumenRoot /home/vox/test/
    <Directory /home/vox/test/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
    </Directory>
    
    mkdir ~/test
    echo '<?php echo "hello world"; ?>' > ~/test/test.php
    chown www-data -R ~/test ; chmod 774 -R ./test/
    
    └─ $ ▶ wget --no-check-certificate https://www.test.linuxfr.org/test.php
    --2019-03-19 13:26:53--  https://www.test.linuxfr.org/test.php
    Resolving www.test.linuxfr.org (www.test.linuxfr.org)... 42.42.42.42
    Connecting to www.test.linuxfr.org (www.test.linuxfr.org)|42.42.42.42|:443... connected.
    WARNING: cannot verify www.test.linuxfr.org's certificate, issued by ‘CN=myMachine.home’:
      Self-signed certificate encountered.
    WARNING: no certificate subject alternative name matches
        requested host name ‘www.test.linuxfr.org’.
    HTTP request sent, awaiting response... 200 OK
    Length: 11 [text/html]
    Saving to: ‘test.php’
    
    test.php                                100%[==============================================================================>]      11  --.-KB/s    in 0s      
    
    2019-03-19 13:26:53 (2,40 MB/s) - ‘test.php’ saved [11/11]
    └─ $ ▶ cat ./test.php 
    hello world

    🇪🇺

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.