Forum Linux.debian/ubuntu Bloque au boot apres upgrade Duron => Core 2 Duo

Posté par  .
Étiquettes : aucune
0
5
oct.
2006
Bonjour!

Je suis actuellement sur ce forum grace au seul CD de secours qui fonctionne avec ma carte mere Asus P5B-VM: small gentoo. Oui, c'etait un hommage a mes sauveurs!
Je suis sous links et clavier qwerty. :)
Au boot de ma Debian avec mon disque dur principal (/dev/hda3 est ma partition / ), j'obtiens ceci:
Check root= bootarg cat /proc/cmdline
or missing modules, devices: cat /proc/modules ls /dev
ALERT! /dev/hda3 does not exist. Dropping to a shell!
Busybox v1.01 ash
/bin/sh: can't access tty; job control turned off
(initramfs)

Voila, je me retrouve sous une espece de shell avec (initramfs) ecrit a gauche. J'ai essayer de charger des modules (modprobe ide-generic, ide-disk, jmicron) puis EXIT, mais ca n'a rien donne.
A vot' bon coeur m'sieurs dames!
  • # module du controleur ide

    Posté par  . Évalué à 1.

    est-tu certain du module pour ton controleur ide.
    j'ai eu le meme probleme sur une asus p5ld2 et le module employé sous etch pour que ça fonctionne a été le it821x.
    module absent des initrd déposés par l'installation de la plupart des distribs que j'ai testé à l'époque...
    Sinon, depuis ton live-cd, tu repères le module, la version du noyau et tu chroot sur ta partition / pour réparer tout ça .
    • [^] # Re: module du controleur ide

      Posté par  . Évalué à 1.

      Merci pour tes conseils!
      Je suis sous Debian depuis plus d'un an, mais j'avoue que je ne suis pas capable de suivre tes conseils sans plus de precisions.
      Pour l'instant sous mon live-cd j'ai monte mon disque dur et je me suis balade dedans pour essayer de voir les modules IDE, en cherchant un module pour Jmicron, du nom du controleur qui gere mes "vieux" peripheriques IDE ATA, mais je n'ai pas trouve. Peut-etre que je ne cherche pas ou il faut?
    • [^] # Re: module du controleur ide

      Posté par  . Évalué à 1.

      J'ai regarde dans /etc/modules et j'ai ca qui concerne l'IDE:
      ide-cd
      ide-disk
      ide-generic
      J'ai aussi cherche dans google le module de Debian pour Jmicron et je ne l'ai pas trouve. Chez Ubuntu il s'appelle "jmicron". J'ai essaye de faire un "modprobe jmicron" la ou je me retrouve bloque au boot, mais Debian me dit que ce module est inconnu.
      J'ai oublie de preciser que j'ai installe le kernel 2.6.18 et Xorg 7.1, ainsi que discover2. En fait j'ai tout mis a jour lundi: udev, initramfs-tools, grub,...
      Peut-etre mon probleme est-il du a un bug dans un de ces packages?
    • [^] # Re: module du controleur ide

      Posté par  . Évalué à 1.

      J'ai appris a utiliser chroot, et j'ai mis a jour initramfs-tools en passant par aptitude, apres avoir lu chez ubuntu qu'un nouveau initramfs-tools avait permis de regler un probleme avec le controleur jmicron, mais ca n'a rien change.
      Par contre j'ai remarque que si grub boote bien sur mon unique disque dur hda, dans les derniers messages du boot avant le blocage, mes partitions sont nommes hde! D'apres un forum allemand ce serait un conflit entre udev et grub et ils ont solutionne leur probleme, mais ils ne disent pas comment. J'ai essaye de remplacer hda par hde dans grub mais ca ne marche pas: debian refuse de booter. Donc je dois chercher du cote d'udev. Mais ou exactement?
      • [^] # Re: module du controleur ide

        Posté par  . Évalué à 1.

        mettre à jour initramfs ne peut pas régler ton problème directement
        car il faut regénérer l'initrd utilisé lors du boot.
        il faut incorporer le module qui manque dans l'initrd utilisé par ton système pour booter.
        D'où l'utilité du chroot:
        tu bootes sur ta live-cd, tu montes ton disque (+/proc), tu "chroot"(s) dedans, tu paramètre initramfs dans /etc/mkinitramfs/modules en y renseignant le module que tu veux incorporer et tu regénères l'initrd (avec la bonne version de noyau pour qu'il prenne les bons modules) avec la command mkinitramfs (+parametres).
        ensuite le boot devrait fonctionner.
        bien sûr il faut que le module soit présent, si non présent, tu peux aussi prendre le noyau, l'initrd et les modules de ton live-cd et faire ça à la brute en les recopiant sur ton disque, paramétré grub/lilo puis reboot (pas garanti si pas les même lib).
        Ou encore: récupérer le dernier noyau (voire un experimental) et le recompiler dans le chroot avec le support de ton contrôleur dans le noyau et non en module (du coup plus besoin d'initrd)
        Après ça, j'avais aussi essayé de désactivé des trucs dans le bios, il y avait un paramètre SET COMPATIBLE qui permettait de détecter les ide avant les sata pour les "vieux" windows et les disques ide étaient apparus en hda hdb mais j'avais un conflit : le cdrom se mettait ensuite en hda et le noyau désactivait le support ata...
        fin de l'histoire: j'ai gravé la netinstall de etch et depuis ça marche :]
        • [^] # Re: module du controleur ide

          Posté par  . Évalué à 1.

          Merci beaucoup! Tres interessant! Et en meme temps tres complique meme si tes explications sont completes. N'oublions pas qu'il y a 48 heures je ne savais pas conjuguer le verbe chrooter!
          Un probleme important: je ne sais toujours pas quel module pourrait me sauver!
          Copier le kernel de mon live cd small gentoo serait plus simple.
          Je me demande si en chrootant je pourrais graver la netinstall de etch et l'utiliser pour reparer ma etch. He oui, reparer, car je ne peux pas reinstaller avec mes DDs pleins. Et je ne veux surtout pas tout reinstaller.
          Merci encore pour ces nouvelles perspectives avant d'aller dormir! Je vais faire de beaux reves...ou cauchermars? :D
  • # Rien ne marche avec cette carte mère.

    Posté par  . Évalué à 2.

    Apparemment les cartes mere pour core 2 duo sont toutes affublées de ce controleur JMicron qui semble poser de gros problèmes au kernel.
    Hier soir j'étais au téléphone pour dépanner quelqu'un qui venait de s'acheter une config core 2 duo (carte mere MSI cette fois), et impossible d'installer quoi que ce soit, le lecteur CD étant en IDE.

    Avoir un disque IDE signifie de meme qu'il n'est pas visible (du SATA marcherait par contre).

    Ca fait quelques mois que ça dure:
    https://launchpad.net/distros/ubuntu/+source/linux-source-2.(...)

    Je ne sais pas si le tout dernier kernel 2.6.18 du jour a reglé le probleme...
    Essaye de booter en rajoutant l'option "all-generic-ide" , ça semblait passer pour certains kernels...
    • [^] # Re: Rien ne marche avec cette carte mere.

      Posté par  . Évalué à 1.

      Merci a toi de venir au secours des casse-cous dans notre genre!
      Quand je suis bloque dans le shell initramfs et que je tente un modprobe all-generic-ide, Debian me dit que ce module n'existe pas.
      Je vais essayer en le mettant dans le menu.lst de grub.
      Mais je me demande si je ne devrais pas recompiler ce kernel 2.6.18. Je l'ai reinstalle cet apres-midi en passant par un chroot: ca n'a rien change.
      En plus le bios ne reconnait pas toujours mes deux peripheriques PATA: quand ca lui prend il reconnait que le DVD ou le DD.
  • # Problème résolu!

    Posté par  . Évalué à 1.

    Grâce à un membre de debian-user@lists.debian.org, j'ai modifié grub:
    dans la ligne # kopt=root/dev/hda3 ro
    j'ai remplacé hda3 par hde3
    Puis: update-grub
    J'ai remplacé hda, hda2,...dans fstab par hde1, hde2,...
    J'ai rebooté, et je me suis retrouvé sous X!
    Maintenant j'ai un nouveau problème qui mérite un nouveau topic, car
    il n'a rien à voir!
    Merci à tous!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.