Forum Linux.debian/ubuntu Clone et IPv6

Posté par  . Licence CC By‑SA.
1
5
oct.
2020

Bonjour,

J’ai cloné une de mes machines virtuelles en Debian 10 de la manière suivante :
Arrêt de la VM, puis copie du disque.
paramétrage d’une nouvelle VM avec la copie du disque.
Génération d’une nouvelle adresse MAC pour le clone.
Changement du nom de la machine clonée.
Démarrage des deux machines.

Tout fonctionne bien, sauf l’IPv6, le DHCP donne la même adresse IPv6 à ma nouvelle machine qu’à l’ancienne.
J’utilise DHCPv6 sur mon réseau pour attribuer les IPv6 à mes machines virtuelles.

Je pense avoir compris que le DHCPv6 utilise un ID (DUID) pour toujours attribuer la même adresse aux machines.
Et que suite au clone cet ID est identique.

Je n’ai trouvé nulle part comment régénérer cet ID.
Connaissez-vous une solution à ce problème ?

Ai-je oublié une étape pour le clone ?

Merci.

  • # Une piste

    Posté par  . Évalué à 2.

    Hello,

    Dans ce sujet, il s'agit d'ubuntu mais ça peut aider
    https://askubuntu.com/questions/712159/how-can-i-find-out-my-systems-dhcpv6-duid

    J'ai tapé modify DUID ipV6 debian dans mon moteur de recherches préféré, les réponses sont pas nombreuses
    A priori selon le gestionnaire de réseau les réponses diffèrent
    Ton retour d'expérience sera grandement apprécié :-)

    Julien_c'est_bien (y'a pas que Seb)

    • [^] # Re: Une piste

      Posté par  . Évalué à 2.

      Merci pour le lien.

      Je l’avais déjà vu, il m’a permis de vérifier que mes DUID sont identiques.

      J’ai aussi tenté de modifier à la main l'id dans /var/lib/dhcp/dhclient6.enp1s0.leases.
      Sans résultat.

      J’ai aussi essayé de supprimer ce fichier. Ce qui fait planter le DHCP au boot. et attendre 5 minutes avant le timeout.

      j’ai aussi modifié l’id de la machine dans /etc/machine-id.
      Et l’id du disque.

      Mais toujours sans résultat.

  • # Une autre piste

    Posté par  . Évalué à 2.

    • [^] # Re: Une autre piste

      Posté par  . Évalué à 2.

      Je n'avais pas vu ce lien.

      Mais déjà vu les infos qu'il contient sur :
      https://manpages.debian.org/buster/systemd/networkd.conf.5.en.html

      Par défaut Debian n'utilise pas networkd.

      Du coup ce n'est pas la solution.

      Merci.

    • [^] # Re: Une autre piste

      Posté par  . Évalué à 3.

      Mais j'ai essayé quand même.
      Et comme prévu ça ne fonctionne pas.

      • [^] # Re: Une autre piste

        Posté par  . Évalué à 2.

        Surtout tiens nous informé, c'est très intéressant à mes yeux ce problèmes, ça m'arrive souvent de cloner des vm à titre personnel les soirs et le week-end :-)
        A priori comme c'est lié au gestionnaire de réseau, est-ce que tu as envisagé de contacter les développeurs débian pour leur demander directement ?

        Julien_c'est_bien (y'a pas que Seb)

        • [^] # Re: Une autre piste

          Posté par  . Évalué à 3.

          Je vais contacter les développeurs Debian.

          Je ferais un retour dès que j’ai une réponse.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.