Forum Linux.debian/ubuntu Connecter un pc en LAN a internet sous debian

Posté par (page perso) .
Tags : aucun
0
26
oct.
2004
Bonjour a tous,
J'ai recement installé une debian woody sur un des mes PC ( 200mhz, 80mo de ram, 2go ), mais je n'arrive pas à la connecter a internet.
J'y etait parvenu sur mon PC, mais là, je ne sais pas.
NB : il s'agit du kernel 2.2.
Je sais que mon reseau local marche car j'arrive a pinger d'autres PC de mon reseau.
Je me tourne donc vers vous pour m'indiquer les commandes à entrer sachant que mon routeur a l'ip 10.0.0.138.
Je voudrais qu'il ai pour IP 10.0.0.5 et comme masque de sous reseau 255.255.255.0

Ou sinon m'indiquer comment mettre a jour mon noyau ( il paraitrait que ça pourrait m'aider par la suite, pour ce qui touche aux reseau )

Utilisation de ce PC : server mail,http, ftp.

Merci ;)
  • # kernel

    Posté par . Évalué à 1.

    J'ai toujours eu moins de problème en utilisant le noyau 2.4 qu'en utilisant le noyau par défaut de woody. Sur mon CD, il faut faire bf2.4 (ou 24) au démarrage de l'installation.
    Il me semble que c'était un problème de carte réseau mal reconnu.
  • # route est ton ami

    Posté par . Évalué à 3.

    Je pense que tu n'as pas pas configurer correctement ton routage.
    Pour cela, tu dois taper la ligne de commande suivante:

    route add default gw 10.0.0.138

    ensuite, essaie de pinguer une machine sur internet.

    Pour que les changements soient permanent, tu dois éditer un fichier dans /etc/network/ mais je ne sais plus lequel de tête.


    N'oublie pas également de renseigner le serveur DNS. Pour cela, edite le fichier /etc/resolv.conf , tu dois ajouter la ligne
    nameserver 10.0.0.138
    en esperant que ton routeur fasse aussi serveur DNS.
    • [^] # Re: route est ton ami

      Posté par (page perso) . Évalué à 1.

      si je fais ma configuration d'adresse habituelle, que je ping les IP, no probleme.
      si je fais route add ... il me dit : network not reachable.
      si je ping les noms, il me dit unknown host ( pour un domaine online ou local ).
      si j'ajoute nameserver et que je recommence, j'ai le droit a unknown command nameserver ...

      bon ok ça merde, mais peut etre que la partie dns du routeur est mal configurée, meme si pour le moment je pense que ça n'est pas le probleme majeur.
  • # Merci :)

    Posté par (page perso) . Évalué à 2.

    Je vais tester ça .
    ( en esperant qu'il existe une fonction editer ).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.