Forum Linux.debian/ubuntu Debian sid : auto-complétion des options ?

Posté par .
Tags : aucun
0
17
mai
2011

Bonjour,

Je fais un retour non sans émotion sur la distrib de mon coeur, debian.
Tout est parfait dans le meilleur des mondes évidemment, sauf un truc : l'auto-complétion des commandes dans le shell.

Je suis habitué pour un

apt-get dist-upgrade 

à taper

apt-g[tab] dis[tab]

Hors impossible de compléter l'option de cette commande, pas plus que les autres d'ailleurs, ce qui me donne

apt-g[tab] dist-upgrade

Ce qui m'oblige à perdre quelques secondes de ma vie plusieurs fois par semaine, ce qui vous l'avouerez c'est très dur à supporter.

J'ai parcouru la doc mais ça doit être mes yeux.

Des idées ?

Merci !

  • # bash_completion

    Posté par . Évalué à 4.

    Hello

    Avec le shell Bash, voir dans "/etc/bash.bashrc" de ce côté
    # enable bash completion in interactive shells
    #if [ -f /etc/bash_completion ]; then
    # . /etc/bash_completion
    #fi

    A+

    Unk

  • # paquet bash-completion

    Posté par . Évalué à 4.

    Avec Debian il faut installer manuellement le paquet qui contient les règles de completion:

    # aptitude install bash-completion

    • [^] # Re: paquet bash-completion

      Posté par . Évalué à 4.

      Ou installer un vrai shell, zsh ?

      • [^] # Re: paquet bash-completion

        Posté par . Évalué à 2.

        Exact, la completion avec zsh est souvent plus évoluée (completion des url svn, ssh, rsync, …)

        Au minimum dans le zshrc :

        autoload -Uz compinit
        compinit
        

        Sinon la documentation est ici

        Exemple plus long :

        autoload -Uz compinit
        compinit
        
        zstyle ':completion:*' auto-description 'specify: %d'
        zstyle ':completion:*' completer _expand _complete _correct _approximate
        zstyle ':completion:*' format 'Completing %d'
        zstyle ':completion:*' group-name ''
        zstyle ':completion:*' menu select=2
        zstyle ':completion:*:default' list-colors ${(s.:.)LS_COLORS}
        zstyle ':completion:*' list-colors ''
        zstyle ':completion:*' list-prompt %SAt %p: Hit TAB for more, or the character to insert%s
        zstyle ':completion:*' matcher-list '' 'm:{a-z}={A-Z}' 'm:{a-zA-Z}={A-Za-z}' 'r:|[._-]=* r:|=* l:|=*'
        zstyle ':completion:*' menu select=long
        zstyle ':completion:*' select-prompt %SScrolling active: current selection at %p%s
        zstyle ':completion:*' use-compctl false
        zstyle ':completion:*' verbose true
        
        zstyle ':completion:*:*:kill:*:processes' list-colors '=(#b) #([0-9]#)*=0=01;31'
        zstyle ':completion:*:kill:*' command 'ps -u $USER -o pid,%cpu,tty,cputime,cmd'
        

        Stéphane.

    • [^] # Re: paquet bash-completion

      Posté par (page perso) . Évalué à 2.

      C'est étrange: je n'ai jamais de ma vie installé ce paquet. Il l'est par défaut.
      Vous avez besoin de le faire ?

      • [^] # Re: paquet bash-completion

        Posté par (page perso) . Évalué à 2.

        Quand tu fais une installation debian minimal oui.

        • [^] # Re: paquet bash-completion

          Posté par (page perso) . Évalué à 2.

          Je fais toujours des installations minimales.
          Ou alors je crois en faire :-)
          Je lance le net-install et je ne coche aucune case de catégorie de paquets.

          • [^] # Re: paquet bash-completion

            Posté par . Évalué à 2.

            À tous les coups c’est un paquet « recommandé » et du coup son installation n’est pas automatique, bien que le réglage par défaut installe maintenant les recommandés. Pour une vraie installation minimale on aura pris soin de mettre : « APT::Install-Recommends "false"; » dans son apt.conf.

    • [^] # Re: paquet bash-completion

      Posté par . Évalué à 2.

      Merci mais mon problème est l'auto-complétion des options des commandes.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.