Forum Linux.debian/ubuntu Dépannage PC serveur

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
20
mai
2020

Bonjour à tous,

Avant j'étais à une coupure serveur toute les 3 semaines, maintenant c'est tout les 2 jours +/- 1 jours.

Le souci est que même avec une carte graphique et un écran, je me retrouve avec le texte de la commande suivante :

tail -f /var/log/syslog

En essayant de taper une commande, à l'écran, rien ne se passe.

Au niveau réseau, le routeur ne détecte plus mon PC.

Je pense que je vais passer par le programme BIOS pour checker le matériel ASRock, …

Mais avant cela, quel log pourrais-je regarder ?

Actuellement, je regarde le syslog.

Un peu perdu dans tout ceci, … je penche maintenant peut être plus sur un problème matériel.

Mais pourtant, à l'affichage il me reste les traces de la carte graphique, si le PC plante complet, je ne devrais pas avoir encore de trâces si ?

A moins que l'affichage soit persistant même en cas de panne.

Merci pour votre lecture.

  • # des pistes

    Posté par  . Évalué à 3 (+1/-0).

    si ton serveur a planté, tu n'as plus la main dessus, tu le redémarres,

    tail -f /var/log/syslog
    En essayant de taper une commande, à l'écran, rien ne se passe.

    ca ne donne rien car rien ne rentre dans ce fichier au moment et après la commande
    -f étant pour suivre (follow) le remplissage du fichier

    ce que tu cherches, c'est ce qu'il s'est passé AVANT maintenant,
    ce sera donc plutot tail -n X /var/log/syslog
    qui va alors t'afficher les X dernières lignes du fichier

    maintenant si tu veux le voir planter, là en effet ce sera un tail -f /var/log/syslog /var/log/messages

    mais il faut ensuite attendre qu'il plante.

    • [^] # Re: des pistes

      Posté par  . Évalué à 1 (+0/-0). Dernière modification le 20/05/20 à 14:19.

      Je me suis trompé,

      En essayant de taper au clavier (au lieu " d'une commande"), à l'écran, rien ne se passe.

      J'ai mis en oeuvre la commande " tail -f /var/log/syslog", et j'ai eu quelques log du process amavis avec,

      en dernière ligne celle-ci,

      idle_proc, 6: was busy, 83.6 ms, total idle 53696.513 s, busy 1.858 s
      

      Des conflits entre process peut être ? J'essaierai de partager d'avantages de données.

      • [^] # Re: des pistes

        Posté par  . Évalué à 1 (+0/-0).

        Des nouvelles,

        J'ai laissé mon PC sans session terminale ouverte, et voici ce qu'il m'a renvoyé !

        Watchdog -> cpu#1 stuck -> Hard LOCKUP

        Comment je peux savoir d'ou viendrait le problème ?

        • [^] # Re: des pistes

          Posté par  . Évalué à 2 (+0/-0).

          tu as un coeur du CPU qui "colle" et qui prend trop de temps pour faire ce qu'il devrait faire.

          il faut voir si tu peux le désactiver dans le BIOS ou sous linux pour éviter de t'en servir.

          à une époque certains processeurs 3 coeurs étaient en fait des 4 coeurs dont un coeur ne passait pas les tests, avec possibilité pour les bidouiller de réactiver le coeur manquant (à leur risque et "péril")

          • [^] # Re: des pistes

            Posté par  . Évalué à 1 (+0/-0). Dernière modification le 26/05/20 à 14:06.

            Je ne pense pas que le processeur soit ancien.

            J'avais acheté un CPU AMD Ryzen 3, pour moi il ne me semble pas ancien.

            AMD Ryzen 3 Quad-Core Processor

            Plus d'info sur ce lien,

            https://debian-facile.org/paste-14D5EDD6CA


            CPU#1 c'est lequel ?

            Le CPU 1 en partant de 0 ou le CPU 0 ?

            • [^] # Re: des pistes

              Posté par  . Évalué à 2 (+0/-0).

              Le CPU 1 en partant de 0 ou le CPU 0 ?

              en informatique on démarre souvent de 0, donc le CPU1, c'est le 2e physiquement.

              AMD Ryzen 3 Quad-Core Processor

              y a pas eu des bugs avec les risen qui les empêchaient de démarrer ?

              que dit une recherche sur internet à propos de linux ryzen3 cpu stuck

              je trouve par exemple ce workaround qui augmente le délai déclenchement du watchdog (mettre 25 dans ton cas par exemple)

              https://www.suse.com/support/kb/doc/?id=000018705

              mais on voit que tu n'es pas le seul, ici il semblerait qu'il faille jouer de l'ACPI (ou plutot de le désactiver)

              https://askubuntu.com/questions/1087857/cannot-install-ubuntu-on-acer-aspire-3-watchdog-bug-soft-lockup-cpu1-st

              et là tout un thread qui démarre en 2017 sur ce probleme visiblement pas complètement résolu entre le noyau et ses options, le bios (et les C-state) et l'acpi de la carte mère
              https://bugzilla.kernel.org/show_bug.cgi?id=196683

              • [^] # Re: des pistes

                Posté par  . Évalué à 1 (+0/-0).

                Ou bah dit-on, ça va encore être coton pour corriger ça, …

                Jouer de l'ACPI ? Pour arrêter le 2ème coeur du CPU ?

                • [^] # Re: des pistes

                  Posté par  . Évalué à 1 (+0/-0).

                  J'ai effectué une mise à jour bios concernant ma carte mère.

                  Elle concerne une prise en compte de mon type de processeur, ça marchera surement mieux avec celle-ci !

                  • [^] # Re: des pistes

                    Posté par  . Évalué à 1 (+0/-0). Dernière modification le 28/05/20 à 20:46.

                    Une nouvelle erreur "Smack Cached" est apparu ce jour,

                    https://framapic.org/4MEKxvlfhSCw/aF9cUTYzGePX.png

                    Elle est a priori lié à Java donc je pense que c'est lié à jitsi-meet que j'ai installé sur mon serveur avec coturn.

                    J'ai désactivé cela.

                    Autrement, après cela je ne saurais pas quoi faire d'autre mis à part changer de processeur ou arrêter un coeur.

                    Le souci c'est que ça n'est pas le même coeur qui déconne la, c'est le 2 -> 3 en partant de 0.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.