Forum Linux.debian/ubuntu drivers nforce

Posté par  .
Étiquettes : aucune
0
24
jan.
2005
bonjour, je suis equiper d'une carte mere ac le nforce, et j'ai installer les drivers fournis par le site de nvidia, suivit leurs explications, et rien ne marche (usb,reseau,son).Donc d'apres ce que j'ai compris je n'avais pas besoine d'installer ces drivers pour faire marcher tous sa, mais comment les desinstaller???
(je suis sur un debian testing en 2.4.27)

locate nforce
/home/neorom/pages_web/install_nforce.html
/home/neorom/pages_web/install_nforce_files
/usr/bin/nforce-bug-report.sh
/usr/bin/nforce-installer
/usr/share/doc/nforce
/usr/share/doc/nforce/ReleaseNotes.html
/usr/src/kernel-source-2.6.8/drivers/i2c/busses/i2c-nforce2.c
/var/lib/nvidia-nforce
/var/lib/nvidia-nforce/audio100
/var/lib/nvidia-nforce/audio101
/var/lib/nvidia-nforce/audio102
/var/lib/nvidia-nforce/nforce_log_audio
/var/lib/nvidia-nforce/nforce_log_network
/var/log/nvidia-nforce-installer.log

et voila le resulta d'une recherche cocernant les files du nforce
  • # Pour désinstaller

    Posté par  (site Web personnel) . Évalué à 1.

    Le fichier /var/log/nvidia-nforce-installer.log doit contenir ce que l'installeur a fait, et donc t"indiquer comment le défaire. Sinon, /usr/bin/nforce-installer doit être un bête script, qui peut également te renseigner sur ce qui a été installé. Regarde aussi dans tes /etc/modules.* et/ou /etc/modprobe.*, si tu vois des traces des modules nvidia.

    Pour ce qui est de la gestion de nforce par le noyau, il me semble avoir lu dans les changelogs que la série 2.6 a introduit pas mal de nouvelles choses de ce côté-là. Personnellement, j'ai une nforce3 et tout fonctionne (sauf le modem RTC) avec un noyau 2.6.8 (je ne l'ai jamais testé avec un 2.4)

    Khapin
    • [^] # corriger le pb ???

      Posté par  . Évalué à 1.

      bon j'ai mater les logs de l'install des drivers et il disent que les deux modules ont ete install correctement (nvsound.o et nvnet.o) mais j'ai meter dans les repertoires ou ils devraient etre et ya rien dc les modules ne sont pas presents sur la machine, et j'ai bien inscrit les lignes dans /etc/modprobe.conf dc je sais pas comment faire pour qu'il me crée mes modules, et depuis que j'ai mis les drivers de nvidia j'ai plus l'usb qui fonctionne meme si les modules se chargent bien
      dc nforce a soule
      • [^] # Re: corriger le pb ???

        Posté par  (site Web personnel) . Évalué à 1.

        euh... si tes modules se chargent, c'est qu'ils existent (à confirmer en regardant le résultat de lsmod). As-tu bien cherché du côté de /lib/modules/<version de ton noyau>/???

        Si tu ne veux plus qu'ils se chargent, et ainsi récupérer l'USB, tu devrais les retirer de ton modprobe.conf.

        As-tu regardé dans ton /var/log/messages ou dmesg s'il y avait des erreurs lors du chargement des modules et de l'USB?
        Petite pensée en passant: toi ou l'installeur nvidia a peut-être viré les modules USB (ohci_hcd, ehci_hcd ou uhci_hcd, selon ton matériel) du modprobe.conf. Est-ce que tu récupères l'USB en insérant manuellement ces modules?

        Petite question pour finir: pourquoi avoir installé les drivers proprio? Qu'est-ce qui ne marchait pas avec les pilotes du noyau?

        Aller, encore une dernière (mais je crois que je me répète): Pourquoi n'essayes-tu pas de passer au noyau 2.6? Si c'est encore tes problèmes de kernel panic du mois de juin, je pense que du devrais essayer l'outils Debian kivabien pour générer un noyau et l'initrd sous forme de .deb (je crois que ça s'appelle make-kpkg)
  • # Ne surtout pas...

    Posté par  . Évalué à 1.

    ... installer les drivers nforce de nvidia !!! Dans les noyaux 2.6 tout au moins (peut-être déjà dans le 2.4.27) il y a:
    --> un driver pour le réseau qui s'appelle forcedeth
    --> un driver pour le son fourni par alsa qui est snd-intel8x0
    et tout le reste (ide, usb, agp) marche nickel.

    # modprobe forcedeth
    et tu as le réseau
    # modprobe snd-intel8x0
    et tu as du son

    pour l'usb il faut utiliser (noyau 2.6) ohci-hcd (usb 1) et ehci-hcd (usb 2)

    Sur nforce2, tout marche du tonnerre.
    • [^] # Re: Ne surtout pas...

      Posté par  . Évalué à 1.

      j'ai bien compris qu'il ne fallait pas installer les drivers nforces de nvidia c'est pkoi ke souhaite les desinstallés si qqun sais comment faire dite le mois svp , car depuis que je les ai install j'ai plus d'usb que j'aivais avant l'install de ces drivers de merde

      merci d'avance neorom

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.