Forum Linux.debian/ubuntu ipw2200 wifi debian howto

Posté par (page perso) .
Tags : aucun
0
1
déc.
2004
Bonjour,

bon au cas où ca interresserait quelqu'un, voici la marche a suivre pour installer une carte wifi intel prowireless 2200BG sur une debian (sarge/sid) car j'me suis bien fait chier quand meme (enfin la 2eme fois)...

tout d'abord,
apt-get install wireless-tools
ca va vous donner accès aux outils de configuration tels que iwconfig, l'equivalent de ifconfig mais pour le wireless.
ensuite on va télécharger les sources de notre noyau courant (tappez uname -a pour le connaitre)
apt-get install kernel-source-votre-version-a-vous
puis
apt-get install ipw2200-source
puis
rendez vous sur http://ipw2200.sourceforge.net/firmware.php?fid=2(...)
afin de télécharger le microcode (firmware) de la carte.
sauver le tgz dans un coin du disque dur (/usr/src de préférence).

TOUT SE FAIT EN ROOT

pre-requis : allez dans /lib/modules/votre-noyau/ et verifier que les liens build et source pointent vers /usr/src/kernel-source-votre-noyau
(faites un ls -l pour voir ca)
si c'est pas le cas, alors faites ln -s /usr/src/kernel-source-votre-noyau build et ln -s /usr/src/kernel-source-votre-noyau source
1°) placer vous dans /usr/src
Si vous listez le contenu vous verrez normalement le dossier des sources que vous venez d'apt-getiser, ainsi que le tgz des drivers de la carte wifi.
2°) tappez
tar xvzf ipw2200-source.tar.gz
rm ipw2200-source.tar.gz
module-assistant a-i ipw2200
rm -R modules/
virez aussi le .deb généré :
rm ipw2200-modules-2.6.8-1-386_0.12-3+2.6.8-10_i386.deb

3°) pour que la carte fonctionne, il faut en plus des drivers, un firmware.
Allez dans le dossier où vous avez mis le tgz du firmware récupéré plus haut (sur http://ipw2200.sourceforge.net/firmware.php?fid=2(...) ), puis
tar xvzf ipw2200-fw-2.0.tgz
rm ipw2200-fw-2.0.tgz
rm LICENCE
mv *.fw /usr/lib/hotplug/firmware

Voilà, il reste plus qu'a faire un modprobe ipw2200 et normalement après vous avez :

patateland:/home/patate# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

sit0 no wireless extensions.

wlan0 unassociated ESSID:"123456789"
Mode:Managed Channel=0 Access Point: 00:00:00:00:00:00
Bit Rate=0 kb/s Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:1700-0000-00 Security mode:open
Power Management:off


Si ca vous fait une erreur du style FATAL error, je trouve pas le symbol bla bla, faites pas comme moi, ne vous prenez pas la tête, et allez sur kernel.org, récuperez le tbz2 du dernier kernel et recompilez le avec votre .config actuel (ca risque de planter avec l'option drm_gamma, donc si ca plante, vous editez le .config, vous recherchez la ligne drm gamma kk chose, puis vous mettez a N, vous relancez ensuite le make.

Une fois le nouveau kernel en place, refaite l'install d'ipw2200, ca devrait le faire cette fois.

Voilou,
enjoy...

P.S : oui j'explique pas comment on s'en sert ensuite de ce machin, mais j'pense pas que ce soit le plus dur, googlisez un peu.
P.S 2 : any corrections are welcome

cho7 - qui comprend toujours pas pourquoi il a du prendre un nouveau kernel alors qu'il avait déjà réussi a le faire avec l'ancien...
  • # Ptite question

    Posté par (page perso) . Évalué à 1.

    J'inaugure mon topic pour demander :
    comment fait-on pour dire a l'applet de gnome qui m'indique l'etat du réseau wifi, que ma carte existe ?
    car avec ndiswrapper il la detectait tout seul, alors que là il me dit "Aucun périphérique sans fil", que le wifi soit allumé ou non

    Merci.
  • # petite question

    Posté par . Évalué à 2.

    y a-t-il des cartes PCI basées sur ce chipset ?
    on peut trouver ça où ?
  • # help

    Posté par . Évalué à 1.

    J'ai suivi les insructions à la lettre et tout s'est bien passé. A la fin j'obtiens bien apres quelques reglages :

    #iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 unassociated ESSID:"Thomas"
    Mode:Ad-Hoc Channel=0 Cell: 00:00:00:00:00:00
    Bit Rate=0 kb/s Tx-Power=20 dBm
    RTS thr:off Fragment thr:off
    Encryption key:AAAA-BBBB-CC Security mode:restricted
    Power Management:off

    eth1 no wireless extensions.

    sit0 no wireless extensions.

    mais ce qui me tarabuste est l'info donné par ifconfig :

    #ifconfig

    wlan0 Lien encap:Ethernet HWaddr 00:00:00:00:00:00
    adr inet6: fe80::200:ff:fe00:0/64 Scope:Lien
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
    collisions:0 lg file transmission:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interruption:10 Adresse de base:0x3000 Mémoire:d0000000-d0000fff


    Avez vous remarqué l'abscence d'adresse MAC valide??
    Je pense que c'est la cause des echecs de mes requêtes DHCP.

    Quelqu'un peut il m'aider?
    • [^] # Re: help

      Posté par . Évalué à 1.

      bonjour à tous,

      voilà j'ai un pc acer aspire 2012WMLi
      j'aimerais configurer le wifi dessus
      donc dans le fichier /etc/network/interfaces
      j'ai configuré l'interface qu'il fo
      - l'adresse MAC de l'access point
      - le mode infrastructure
      - le canal de fréquence
      - le mode dhcp
      - l'essid de mon réseau wifi

      mais ce que je ne comprend pas c pourquoi je dois absolument faire reconnaitre l'interface wlan0 comme vous indiquez
      alors que moi, il la détecte sur l'interface eth1

      est-ce que ça pose un probleme ???
      comment je peux faire pour que ça soit l'interface wlan0 qui soit configurée et reconnue par mon réseau wifi ???

      merci

      si vous le souhaitez je peux vous envoyer mon fichier de log
      sunfun
  • # attention aux sources du noyau..

    Posté par . Évalué à 1.

    Attention, si comme moi vous venez d installer sarge et que vous n avez pas recompilé le noyau, faites aussi apt-get install kernel-headers-2.6.8-1-386 (si c'est votre noyau).
    Ou sinon, module-assistant aura le regret de vous abandonner...( car il n exitse pas de paquets kernel-source-2.6.8-1-386

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.