Forum Linux.debian/ubuntu J'arrive pas à faire marcher sa souris sans fil ( et le clavier)

Posté par  .
Étiquettes : aucune
0
27
oct.
2007
Impossible de faire fonctionner le périph!!
J'ai beau joué du udevinfo et retoucher le xorg.cong rien n'y fait.

Le périph en question retourne ceci quand je le branche:
Oct 27 17:14:35 The-hatch kernel: usb 2-1: new low speed USB device using ohci_hcd and address 5
Oct 27 17:14:41 The-hatch kernel: usb 2-1: configuration #1 chosen from 1 choice
Oct 27 17:14:41 The-hatch kernel: input: MOSART Semi. Input Device as /devices/pci0000:00/0000:00:0f.0/usb2/2-1/2-1:1.0/input/input17
Oct 27 17:14:41 The-hatch kernel: evbug.c: Connected device: "MOSART Semi. Input Device", usb-0000:00:0f.0-1/input0
Oct 27 17:14:41 The-hatch kernel: input: USB HID v1.10 Keyboard [MOSART Semi. Input Device] on usb-0000:00:0f.0-1
Oct 27 17:14:41 The-hatch kernel: input: MOSART Semi. Input Device as /devices/pci0000:00/0000:00:0f.0/usb2/2-1/2-1:1.1/input/input18
Oct 27 17:14:41 The-hatch kernel: evbug.c: Connected device: "MOSART Semi. Input Device", usb-0000:00:0f.0-1/input0
Oct 27 17:14:43 The-hatch kernel: evbug.c: Event. Dev: isa0060/serio0/input0, Type: 4, Code: 4, Value: 29
Oct 27 17:14:43 The-hatch kernel: evbug.c: Event. Dev: isa0060/serio0/input0, Type: 1, Code: 29, Value: 1
Oct 27 17:14:43 The-hatch kernel: evbug.c: Event. Dev: isa0060/serio0/input0, Type: 0, Code: 0, Value: 0


et
Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Name" "MOSART Semi. Wireless Keyboard & Mouse"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMappiing" "6 7"
EndSection
Section "InputDevice"


toute aide est bienvenue
  • # hum

    Posté par  . Évalué à 1.

    Je me répond à moi même mais j'ai remarqué des nouveaux fichiers dans /dev lors du branchement de la souris:
    usbdev2.8_ep82 usbdev2.8_ep00 usbdev2.8_ep81

    mais aussi dans /dev/input:
    event7 event8 mouse3 ts3

    La souris est reconnu comme une CreativeLabs usb

    J'ai essayé toutes les solutions dans le xorg.conf:
    pour rappel tout ce que j'ai rajouté est en gras
    Dans la section file:
    InputDevices "/dev/ttyS0"
    InputDevices "/dev/ttyS1"
    InputDevices "/dev/ttyS2"
    InputDevices "/dev/ttyS3"
    InputDevices "/dev/ttyS4"
    InputDevices "/dev/ttyS5"
    InputDevices "/dev/ttyS6"
    InputDevices "/dev/ttyS7"
    InputDevices "/dev/ttyS8"
    InputDevices "/dev/psaux"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/mouse"
    InputDevices "/dev/usbmouse"
    InputDevices "/dev/input/mice"
    InputDevices "/dev/input/event0"
    InputDevices "/dev/pointer0"
    InputDevices "/dev/pointer1"
    InputDevices "/dev/pointer2"
    InputDevices "/dev/pointer3"
    InputDevices "/dev/input/event7"
    InputDevices "/dev/input/event8"
    InputDevices "/dev/input/mouse3"
    InputDevices "/dev/input/ts3"
    InputDevices "/dev/input/event7"
    InputDevices "/dev/usbdev2.8_ep82"
    InputDevices "/dev/usbdev2.8_ep00"
    InputDevices "/dev/usbdev2.8_ep81"


    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Name" "MOSART Semi. Wireless Keyboard & Mouse"
    Option "Buttons" "7"
    Option "Device" "/dev/usbdev2.8_ep8"
    #Option "Device" "/dev/input/mice"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMappiing" "6 7"
    EndSection

    • [^] # Re: hum

      Posté par  (site Web personnel) . Évalué à 3.

      Il ne t'est pas venu à l'idée qu'il serait plus utile de poster les log du logiciel n'arrivant pas à acceder à ton périphérique plutôt ?
      [ /var/log/Xorg.0.log ]

      Il serait utile aussi de connaitre la version dudit serveur X aussi,
      et les droits des fichiers devices dont tu as besoin.

      et accessoirement la release de ta debian (sarge/etch/sid/...)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.