Forum Linux.debian/ubuntu Montage automatique NFS / autofs

Posté par (page perso) . Licence CC by-sa.
Tags :
4
18
mai
2019

bonjour!

J'aimerai monter automatiquement des partages NFS. J'ai donc commencé par configurer mon fichier fstab, ça marche, mais petit problème: au boot de l'ordinateur, si le serveur n'est pas accessible, je dois attendre 1m30s avant que le montage NFS soit abandonné et que le reste du démarrage se fasse. Et c'est pareil à l'extinction si le serveur NFS n'est pas joignable. Si le serveur est accessible, tout se monte et se démonte proprement, mais vu que mes clients sont des ordinateurs portables le serveur n'est pas toujours joignable.

J'ai alors trouvé autofs, qui devrait faire ce que je veux: « Les démons d'automount montent automatiquement des systèmes de fichiers quand ils sont employés et les démontent après une période d'inactivité »

J'ai tout configuré comme il faut (je crois…), mais pour monter le partage il faut que je fasse dans le terminal «mount /point_de_montage». Le montage ne se fait pas tout seul au démarrage de l'ordinateur, ou quand le serveur devient accessible. Alors je ne vois pas l'intérêt d'autofs par rapport à fstab. Je ne comprend pas non plus ce que signifie dans la doc « montent automatiquement des systèmes de fichiers quand ils sont employés », car je dois utiliser la commande mount (ce n'est pas automatique)…

Voici ma configuration:
Client et serveur: Linux Mint 19.1 MATE
/etc/fstab : j'ai retiré la ligne concernant nfs

/etc/auto.master :

/nfs /etc/auto.nfs --timeout=30

/etc/auto.nfs :

nfs    -fstype=nfs,ro,rsize=8192    10.10.1.1/nfs

Une solution acceptable serait de limiter le temps de blocage au démarrage et à l'arrêt si le serveur est indisponible. Avez-vous une solution à ce problème?

  • # fstab

    Posté par (page perso) . Évalué à 1.

    J'avais oublié d'enregistrer fstab après retrait de la ligne nfs… J'ai modifié auto.master en ajoutant l'option --ghost, après redémarrage du démon autofs j'ai le répertoire /nfs/nfs qui apparait, mais celui-ci reste vide. Dans mon syslog je vois:

    systemd[1]: Starting Automounts filesystems on demand...
    systemd[1]: Started Automounts filesystems on demand.
    automount[2148]: key ".hidden" not found in map source(s).
    automount[2148]: rmdir_path: lstat of /nfs/.hidden failed
    ```Tel que autofs est configuré, je n'arrive pas à monter le partage NFS.
    

    Un LUG en Lorraine : https://enunclic-cappel.fr

  • # :

    Posté par . Évalué à 5.

    dans ton fichier auto.nfs, il y a une petite erreur, il manque les ":" après l'adresse IP

    nfs -fstype=nfs,ro,rsize=8192 10.10.1.1:/nfs

    de plus, il après l'adresse IP, il faut mettre le chemin complet du partage nfs.
    par exemple: 192.168.0.1:/volume1/video

    • [^] # Re: :

      Posté par (page perso) . Évalué à 2.

      Merci, c'était bien les ":" qui manquaient! Ça marche maintenant, montage auto après activation du réseau.

      Un LUG en Lorraine : https://enunclic-cappel.fr

  • # autre piste

    Posté par . Évalué à 2.

    dans ton fstab, tu peux lui dire que le peripheripherique depend du reseau

    dans les options, là ou il y a souvent 'default', ajoute _netdev
    cela devient _netdev,defaults

    ainsi s'il n'y a pas de reseau, le montage n'est pas essayé

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.