Forum Linux.debian/ubuntu Multi activité dual screen

Posté par  .
Étiquettes : aucune
0
16
oct.
2011

Bonjour.
J'ai un soucis :
KDE ne reconnait pas mon dual screen (nvidia proprio avec twienview). Du coup les activités (workspace) sont communes aux deux écrans. Pas moyen de faire fonctionner ça (d'après la doc de kde, les activités sont bien dissociés si kde détecte deux écrans. Du coup question comment faire.
J'ai testé nouveau, mais je n'ai pas réussi à faire grand chose avec, la doc d'ubuntu est un peu light là dessus. Je pense qu'il faut modifier le xorg.conf mais avec quoi ?

Merci d'avance pour vos réponses

  • # nvidia-setting krandrtray

    Posté par  . Évalué à 0.

    Si tu as la même choses sur les deux écrans c'est que ta configuration est en mode clone.

    Pour le pilote propriétaire à l'aide d'nvidia-setting en plus d'activer le mode twinview as tu, activé le second écran, choisis sa résolution, et son positionnement par rapport a l'écran principal (droite, gauche, dessus, dessous ou clone)

    Avec le pilote libre nouveau, si ta carte est bien repérée il n'y a théoriquement rien a faire. L'outil krandrtray te permet de choisir la position du second écran par rapport en premier ou de passer en mode clone

    • [^] # Re: nvidia-setting krandrtray

      Posté par  . Évalué à 0.

      je me suis mal exprimé : je ne suis pas en mode clone : j'ai bien deux écrans, mais kde le detecte comme un. dans nvidia-setting, j'ai mes deux ecrans, je peux lancer des programmes différents sur chacun. mais dans kde, dans l'outil de configuration => écran j'ai juste un grand écran qui apparait au lieu de deux. Du coup j'ai un grand workspace commun au deux écrans donc quand je change de workspace, ça change sur les deux écrans. Concernant le pilote nouveau je n'avais qu'un seul écran qui apparait.

      Concernant ma config : j'ai un laptop sur une station d'accueil avec deux écrans dessus. Ca me fait deux écrans + celui du laptop qui n'est pas utilisé. Avec le pilote nouveau il n'y a que celui du laptop qui est detecté.

      D'après ma lecture, le problème vient de la façon dont le kde detecte le matos. Comme faire pour lui indiquer qu'il s'agit de deux écrans (ou bien comment faire avec nouveau pour faire fonctionner la station d'accueil) ?

      • [^] # Re: nvidia-setting krandrtray

        Posté par  . Évalué à 1.

        je ne sais pas pour les activités mais je pense avoir eu un problème similaire lors de ma mise à jour avec la dernière mandriva
        Je parlais ici : https://linuxfr.org/news/mandriva-2011#comment-1268107

        Kde 4.6.x ne voyait qu'un seul écran virtuel de 2580x1024 et les applis se maximisaient sans détecter les bords des écrans, ce qui étaient super pénible pour la gestion des fenêtres, alors que cela fonctionnait très bien avecc kde 4.5.x. (même config pour le serveur X).

        Sous LXDE, avec le même xorg.conf, je n'avais pas de problèmes cela venait donc de kde.

        Puis suite à une mise à jour de mandriva, le comportement par "défaut" est revenu.

        Quelle version de kde utilises-tu ?

  • # Moi, ça marche...

    Posté par  . Évalué à 2.

    J'utilise un fichier /etc/X11/xorg.conf, et pas du tout l'auto-détection. Voici les sections correspondantes de mon xorg.conf :

    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GT 440"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "yes"
        Option         "RandRRotation" "yes"
        Option         "TripleBuffer" "yes"
        Option         "UseEvents" "yes"
        Option         "AllowSHMPixmaps" "no"
        Option         "NoLogo" "yes"
        Option         "NvAGP" "3"
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "CRT-0, CRT-1"
        Option         "MetaModes" "CRT-0: 2048x1536 +0+0, CRT-1: 1856x1392 +2048+0"
        Option         "TwinViewXineramaInfoOverride" "2048x1536+0+0, 1856x1392+2048+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    

    Bien sûr, utilises les résolutions de tes écrans...

    Hop,
    Moi.

    • [^] # Re: Moi, ça marche...

      Posté par  . Évalué à 0.

      Bonjour,
      une simple question:
      Dans ton fonctionnement, peut tu changer de bureau/activité independamment selon l'écran ?

      Exemple de situation:
      de:
      Ecran 1 - Bureau 1 : Firefox
      Ecran 2 - Bureau 1 : gedit
      à:
      Ecran 1 - Bureau 1 : Firefox
      Ecran 2 - Bureau 2 : des consoles

      Merci.

      • [^] # Re: Moi, ça marche...

        Posté par  . Évalué à 3.

        Dans ton fonctionnement, peut tu changer de bureau/activité independamment selon l'écran ?

        Heu, déjà, les "activités" j'ai pas très bien saisi à quoi ça sert, franchement... Mais bon... ;-)

        Quand je change de bureau virtuel, ça change sur les deux écrans. Et moi, c'est exactement ce que je veux. Et je ne crois pas que tu puises changer de bureau virtuel sur l'écran 1, sans changer en même temps sur l'écran 2.

        Maintenant, mes fonds d'écrans sont gérés différemment sur les deux écrans : pas la même liste d'images, et pas le même délai de changement dans le diaporama. Et d'après ce que je comprends, c'est géré par l'"activité" Desktop Activity (oui, j'ai tout en anglais chez moi, j'arrive pas à me faire aux traductions...).

        Et j'ai deux quarts de cercle, en haut à droite de chaque écran, qui donnent un menu pop-up. Et si j'ajoute/enlève une "activité" sur un écran, elle n'est pas ajoutée/enlevée sur l'autre écran.

        Mais sinon, changer de bureau virtuel se fait sur tous les écrans à la fois.

        Au fait, kde-4.4.5 ici. Sinon, essaie peut-être ça...

        Hop,
        Moi.

        • [^] # Re: Moi, ça marche...

          Posté par  . Évalué à 1.

          En cherchant bien, j'ai trouvé que ce que je voulais n'était pas possible avec kde. Il y a bien une dissociation entre les écrans des widgets, icons, fond ecran barre etc, mais pas pour les programmes : un workspace pour deux écrans. Donc je suis revenu à la solution première : awesome + kde en perdant kwin : du coup fini les jolies effets. C'est quand même dommage que ça ne soit pas possible de faire ça.

  • # faut passer à kde SC 4.7

    Posté par  . Évalué à 0.

    salut

    le multi-sceen est mieux gérer depuis la version 4.7.

    pour avoir 2 activités par écrans, tu passes tes écrans en "separate x sceen" via nvidia-settings. t'occupe pas du truc de configuration d'affichage de KDE...

    • [^] # Re: faut passer à kde SC 4.7

      Posté par  . Évalué à 1.

      je suis chiant : j'ai besoin de passer une application d'un écran à l'autre. et si on active le mode xinerama, on revient comme en twinview

      • [^] # Re: faut passer à kde SC 4.7

        Posté par  . Évalué à 0.

        oui effectivement, xinerama a le même effet que twinview pour le passage des fenêtre mais tu perds le "composite" et les effets de bureau...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.