Forum Linux.debian/ubuntu Paquet dans un état incohérent - Python-uno

Posté par .
Tags : aucun
0
8
avr.
2007
Bonjour,

Suite à une mise à jour via synaptic de ma Debian Sid (noyau 2.18-3), il semblerait que le paquet Python-uno 2.0.4.dfsg.2-7 ait quelques problèmes... Sauf que visiblement, il est indispensable à Openoffice.

J'ai bien sur essayé toutes les manoeuvres possibles (dpkg -P --force-all etc etc) pour supprimer le paquet récalcitrant (ou installer la version précédente de l'ensemble) et rien n'y fait... j'obtient toujours le même résultat:


(Lecture de la base de données... 168398 fichiers et répertoires déjà installés. )
Préparation du remplacement de python-uno 2.0.4.dfsg.2-6 (en utilisant .../pytho n-uno_2.0.4.dfsg.2-7_i386.deb) ...
Traceback (most recent call last):
File "/usr/bin/pycentral", line 1373, in ?
main()
File "/usr/bin/pycentral", line 1367, in main
rv = action.run(global_options)
File "/usr/bin/pycentral", line 943, in run
runtimes = get_installed_runtimes(with_unsupported=True)
File "/usr/bin/pycentral", line 196, in get_installed_runtimes
supported = pyversions.supported_versions()
File "/usr/share/pycentral-data/pyversions.py", line 98, in supported_versions
value = read_default('supported-versions')
File "/usr/share/pycentral-data/pyversions.py", line 22, in read_default
value = config.get('DEFAULT', name)
UnboundLocalError: local variable 'config' referenced before assignment
dpkg : avertissement - ancien script pre-removal a retourné un code d'erreur de sortie 1
dpkg - tentative d'exécution du script du nouveau paquet à la place ...
Traceback (most recent call last):
File "/usr/bin/pycentral", line 1373, in ?
main()
File "/usr/bin/pycentral", line 1367, in main
rv = action.run(global_options)
File "/usr/bin/pycentral", line 943, in run
runtimes = get_installed_runtimes(with_unsupported=True)
File "/usr/bin/pycentral", line 196, in get_installed_runtimes
supported = pyversions.supported_versions()
File "/usr/share/pycentral-data/pyversions.py", line 98, in supported_versions
value = read_default('supported-versions')
File "/usr/share/pycentral-data/pyversions.py", line 22, in read_default
value = config.get('DEFAULT', name)
UnboundLocalError: local variable 'config' referenced before assignment
dpkg : erreur de traitement de /var/cache/apt/archives/python-uno_2.0.4.dfsg.2-7 _i386.deb (--unpack) :
le sous-processus nouveau script pre-removal a retourné une erreur de sortie d' état 1
Traceback (most recent call last):
File "/usr/bin/pycentral", line 1373, in ?
main()
File "/usr/bin/pycentral", line 1367, in main
rv = action.run(global_options)
File "/usr/bin/pycentral", line 865, in run
runtimes = get_installed_runtimes()
File "/usr/bin/pycentral", line 196, in get_installed_runtimes
supported = pyversions.supported_versions()
File "/usr/share/pycentral-data/pyversions.py", line 98, in supported_versions
value = read_default('supported-versions')
File "/usr/share/pycentral-data/pyversions.py", line 22, in read_default
value = config.get('DEFAULT', name)
UnboundLocalError: local variable 'config' referenced before assignment
dpkg : erreur lors du nettoyage :
le sous-processus post-installation script a retourné une erreur de sortie d'ét at 1
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/python-uno_2.0.4.dfsg.2-7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg : des problèmes de dépendances empêchent la configuration de python-uno :
python-uno dépend de openoffice.org-core (= 2.0.4.dfsg.2-6) ; cependant :
La version de openoffice.org-core sur le système est 2.0.4.dfsg.2-7.
dpkg : erreur de traitement de python-uno (--configure) :
problèmes de dépendances - laissé non configuré
Paramétrage de python2.4-minimal (2.4.4-3) ...
Linking and byte-compiling packages for runtime python2.4...
Traceback (most recent call last):
File "/usr/bin/pycentral", line 1373, in ?
main()
File "/usr/bin/pycentral", line 1363, in main
if action.check_args(global_options):
File "/usr/bin/pycentral", line 971, in check_args
for rt in get_installed_runtimes():
File "/usr/bin/pycentral", line 196, in get_installed_runtimes
supported = pyversions.supported_versions()
File "/usr/share/pycentral-data/pyversions.py", line 98, in supported_versions
value = read_default('supported-versions')
File "/usr/share/pycentral-data/pyversions.py", line 22, in read_default
value = config.get('DEFAULT', name)
UnboundLocalError: local variable 'config' referenced before assignment
dpkg : erreur de traitement de python2.4-minimal (--configure) :
le sous-processus post-installation script a retourné une erreur de sortie d'ét at 1
dpkg : des problèmes de dépendances empêchent la configuration de python2.4 :
python2.4 dépend de python2.4-minimal (= 2.4.4-3) ; cependant :
Le paquet python2.4-minimal n'est pas encore configuré.
dpkg : erreur de traitement de python2.4 (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de hal-device-man ager :
hal-device-manager dépend de python2.4 ; cependant :
Le paquet python2.4 n'est pas encore configuré.
dpkg : erreur de traitement de hal-device-manager (--configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de python2.4-dev  :
python2.4-dev dépend de python2.4 (= 2.4.4-3) ; cependant :
Le paquet python2.4 n'est pas encore configuré.
dpkg : erreur de traitement de python2.4-dev (--configure) :
problèmes de dépendances - laissé non configuré


Donc là j'avoue que je suis un peu bloqué... Mon seul moyen de me servir d'OOo est d'installer la version 2.2 depuis le site, mais visiblement, ça ne plaît pas à Apt-get/Synaptic qui tiennent absolument à installer la version 2.0x

J'en viens donc à solliciter votre aide, si jamais quelqu'un a des éléments de réponse?

Merci d'avance
  • # Paquet dans un état incohérent - Python-uno (complément)

    Posté par . Évalué à 1.

    Je viens de me rendre compte que j'ai donné le log de ce que j'obtenais quand j'essayais de mettre à jour le paquet...

    Histoire de faire un peu de flood involontaire, je transmets aussi le log de ce que j'obtiens quand j'essaye de supprimer le paquet (tout de suite, ça donne envie)


    dpkg : erreur de traitement de python-uno (--purge) :
    Le paquet est dans un état incohérent - vous devriez
    le réinstaller avant d'essayer de le supprimer.
    Des erreurs ont été rencontrées pendant l'exécution :
    python-uno
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    Paramétrage de python2.4-minimal (2.4.4-3) ...
    Linking and byte-compiling packages for runtime python2.4...
    Traceback (most recent call last):
    File "/usr/bin/pycentral", line 1373, in ?
    main()
    File "/usr/bin/pycentral", line 1363, in main
    if action.check_args(global_options):
    File "/usr/bin/pycentral", line 971, in check_args
    for rt in get_installed_runtimes():
    File "/usr/bin/pycentral", line 196, in get_installed_runtimes
    supported = pyversions.supported_versions()
    File "/usr/share/pycentral-data/pyversions.py", line 98, in supported_versions
    value = read_default('supported-versions')
    File "/usr/share/pycentral-data/pyversions.py", line 22, in read_default
    value = config.get('DEFAULT', name)
    UnboundLocalError: local variable 'config' referenced before assignment
    dpkg : erreur de traitement de python2.4-minimal (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'ét at 1
    dpkg : des problèmes de dépendances empêchent la configuration de python2.4 :
    python2.4 dépend de python2.4-minimal (= 2.4.4-3) ; cependant :
    Le paquet python2.4-minimal n'est pas encore configuré.
    dpkg : erreur de traitement de python2.4 (--configure) :
    problèmes de dépendances - laissé non configuré
    dpkg : des problèmes de dépendances empêchent la configuration de hal-device-man ager :
    hal-device-manager dépend de python2.4 ; cependant :
    Le paquet python2.4 n'est pas encore configuré.
    dpkg : erreur de traitement de hal-device-manager (--configure) :
    problèmes de dépendances - laissé non configuré
    dpkg : des problèmes de dépendances empêchent la configuration de python2.4-dev  :
    python2.4-dev dépend de python2.4 (= 2.4.4-3) ; cependant :
    Le paquet python2.4 n'est pas encore configuré.
    dpkg : erreur de traitement de python2.4-dev (--configure) :
    problèmes de dépendances - laissé non configuré


    Bon, ça reste quand meme similaire au log précédent...
  • # Reflexe: bugs.debian.org

    Posté par (page perso) . Évalué à 1.

    Un peu long ton post :)

    Sinon le bug est décrit chez debian et la solution s'y trouve aussi.
    Je ne poste ici que le lien pour te laisser le plaisir de lire.

    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=418108
    • [^] # Re: Reflexe: bugs.debian.org

      Posté par . Évalué à 1.

      Et c'est pas faute d'avoir passé une partie de la journée à chercher :)

      Merci, j'ai effectivement pu régler mon problème.
      C'est fou ce que la vie peut devenir compliquée quand il ne manque d'une seule ligne ^^

      (et je suis persuadé que la mise à jour du paquet python-central que je viens juste de voir aurait aussi pu régler mon problème... soupirs...)

      Merci encore, et bonne fin de week end! :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.