Forum Linux.debian/ubuntu Performance d'apache/squirrelmail sous Debian Sarge

Posté par  .
Étiquettes : aucune
0
11
oct.
2004
Bonjour,

j'ai monté récemment une debian Sarge avec Apache 2 et squirrelmail 1.4.3, sur un serveur IBM x345 bi-pro. Je trouve les performances déplorables. Dès que j'atteints une trentaine de connectés, les performances sont catastrophiques, ce qui me parait peu vu la config de la bête.
Comment optimiser les performances? Quelqu'un sait-il combien en moyenne prend en RAM une connexion à squirrelmail? Enfin, je suis obligé d'utiliser le MPM prefork d'apache, à cause de PHP, alors que le MPM worker semble plus rapide est moins gourmand. Quelqu'un a-t-il fait tourner le MPM worker avec php4?

Merci d'avance.
  • # Apache 1.3

    Posté par  . Évalué à 1.

    Il semble qu'il soit conseillé d'utiliser Apache 1.3 encore pour le PHP j'ai moi meme trouvé des différences de charge entre Apache 1.3 et Apache 2 au profit de Apache 1.3 ... (mais je n'ai qu'une connexion sur ma machine)

    D'autre part est tu certain que d'autre chose ne tourne pas sur ta machine ?

    Dam
    • [^] # Re: Apache 1.3

      Posté par  . Évalué à 1.

      j'ai un peu avancé dans mes recherches, et apparemment, c'est la mémoire qui est en cause. L'occupation mémoire augment très vite, mais ne se libère pas! Sur le Go de RAM du serveur, presque tout est utilisé, très rapidement, et rien ne semble se libérer? Est-ce dû à des sessions qui ne se terminent pas correctement? Comment "cartographier" la RAM pour voir quels process on pris de la RAM et ne l'ont pas libérée?
      • [^] # Re: Apache 1.3

        Posté par  . Évalué à 2.

        Solution simple :

        top, puis "M" pour trier par taille mémoire occupée par le process
        • [^] # Re: Apache 1.3

          Posté par  . Évalué à 1.

          merci pour la commande.
          J'ai en fait une vingtaine de process apache qui tournent, avec 10-13Mo chacun. Plus quelques autres process bien sûr. De toute façon, 20*13=260Mo maxi. Or, j'ai 1Go utilisé!
          • [^] # Re: Apache 1.3

            Posté par  (site Web personnel) . Évalué à 1.

            toi y en a avoir oublier que linux utilise toute la memoire disponible pour ses caches ?

            Pour etre certain qu'il y a un pb memoire => regarde le swap.
            S'il est non vide (plus de 5-10Mo) et qu'il grimpe alors oui il y a peut etre un pb memoire, sinon y a peu de chance.

            utililse 'free' pour voire le partage de la memoire en utilise/cache/cache io/...
            • [^] # Re: Apache 1.3

              Posté par  . Évalué à 2.

              apt-get install htop
              pour connaitre la memoire vraiment utilisé, pas celle bufferisé comme pour top...
            • [^] # Re: Apache 1.3

              Posté par  . Évalué à 1.

              Oups, moi y en avait vraiment oublié. Sorry.
              C'est vrai que tout est dans le cache.
              Bon, le problème ne semble donc pas venir de la mem, alors il va falloir que j'attende qu'il s'écroule de nouveau pour voir ce qu'il se passe.
              En tout cas merci beaucoup pour ton aide très précieuse.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.