Forum Linux.debian/ubuntu Plus de résolution de nom de domaine

Posté par .
Tags : aucun
0
12
fév.
2011
Bonjour à tous,

Un petit pb avec mon dédié, et google ne m'a pas été d'une grande aide.

Je suis en squeeze et suite (certainement) à une manip que j'ai du faire (mais alors sans savoir laquelle), je n'ai plus de résolution de nom de domaine.
Aptitude, wget, etc ... plante lamentablement avec par exemple

wget : impossible de résoudre l'adresse de l'hôte «www.free.fr»


Par contre le ping sur un domaine marche nickel :grattelatete: ...

Ca doit se situer du coté de resolv.conf :

nameserver 127.0.0.1
nameserver 213.186.33.99


ou nsswitch.conf :

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis


Si ca parle à quelqu'un, parce je suis un peu embêté je dois dire.
  • # que dit "dig" ?

    Posté par (page perso) . Évalué à 3.

    Tout est dans le titre

    Système - Réseau - Sécurité Open Source

    • [^] # Re: que dit "dig" ?

      Posté par . Évalué à 1.

      Ca :


      ks3094078:~# dig www.free.fr

      ; <<>> DiG 9.7.2-P3 <<>> www.free.fr
      ;; global options: +cmd
      ;; Got answer:
      ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 64607
      ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
      ;; WARNING: recursion requested but not available

      ;; QUESTION SECTION:
      ;www.free.fr. IN A

      ;; Query time: 1 msec
      ;; SERVER: 127.0.0.1#53(127.0.0.1)
      ;; WHEN: Sat Feb 12 13:42:56 2011
      ;; MSG SIZE rcvd: 29
      • [^] # Re: que dit "dig" ?

        Posté par . Évalué à 6.

        - Tu fais tourner bind sur ton serveur
        - Tu fais des requetes dns dessus nameserver 127.0.0.1
        - T'as un "WARNING: recursion requested but not available"

        C'est clair: soit tu corriges ta config named pour autoriser la récursion à partir de l'addresse locale, soit tu vires nameserver 127.0.0.1.
    • [^] # Re: que dit "dig" ?

      Posté par . Évalué à 1.

      En fait je viens de tester en inversant les DNS dans le resol.conf et ca refonctionne.
      Si je comprends bien, pas de service DNS en local (ou pas demarré).

      Donc je replonge dans la config du serveur.

      Merci !
  • # mes 2 centimes.

    Posté par . Évalué à 0.

    * solution de dépannage :

    tu peux configurer ton système pour qu'il interroge un serveur dns ouvert de google.

    Dans le fichier resolv.conf ajoute au tout début la ligne :
    nameserver 8.8.8.8


    * Comment est configuré ton système ? Vu ton fichier resolv.conf , ton ordinateur semble lancer un serveur dns comme bind ou dnsmasq au boot.

    De plus quel est ton FAI ? Curieusement, ses dns n'apparaissent pas dans ce fichier

    Bon courage
    • [^] # Re: mes 2 centimes.

      Posté par . Évalué à 1.

      C'est un Kimsufi chez OVH.
      Donc le serveur lui-meme et apres le DNS de OVH.

      Mais je me fais vraiment l'effet d'être une buse de ne pas avoir pensé avant aux serveurs interrogés.

      Faut que je regarde pourquoi bind ne demarre plus.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.