Forum Linux.debian/ubuntu Problème avec Apache2, (migration etch-lenny)

Posté par  (site Web personnel) .
Étiquettes : aucune
0
10
mar.
2009
Bonjour,

J'ai fait recement ma mise à jour de mon serveur dédié (kimsufi-OVH) debian, etch, vers lenny.
(J'ai utilisé un aptitude install apt aptitude, dist-upgrade, upgrade, et co ...)

Tout c'est à priori bien passé SAUF, apache, qui lors de la relance, m'affiche une erreur du style :

# /etc/init.d/apache2 start
Starting web server: apache2[Tue Mar 10 16:24:02 2009] [warn] The Alias directive in /etc/apache2/apache2.conf at line 301 will probably never match because it overlaps an earlier Alias.
.


Evidement, je vais a la ligne 301 :
(301     Alias /icons/ "/usr/share/apache2/icons/")
, et je la commente.

Cependant, après avoir fait ca :

# /etc/init.d/apache2 start
Starting web server: apache2.


Et plus rien :
# ps aux | grep "http"   
root 6321 0.0 0.0 3608 688 pts/3 R+ 16:30 0:00 grep http
# ps aux | grep "apache"
root 6323 0.0 0.0 3608 688 pts/3 R+ 16:30 0:00 grep apache


# apache2ctl status

Recherche localhost
Connexion HTTP à localhost
Alerte! : Impossible d'établir une connexion à l'hôte distant

lynx : accès impossible au fichier de départ http://localhost/server-status

(Règle iptables vide)

/var/log/apache2/error.log (existait deja AVANT la migration, mais necessite quand meme de l'aide :D) :

[Tue Mar 10 15:24:59 2009] [info] Init: Seeding PRNG with 648 bytes of entropy
[Tue Mar 10 15:24:59 2009] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Tue Mar 10 15:24:59 2009] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Tue Mar 10 15:24:59 2009] [info] Init: Initializing (virtual) servers for SSL
[Tue Mar 10 15:24:59 2009] [info] mod_ssl/2.2.9 compiled against Server: Apache/2.2.9, Library: OpenSSL/0.9.8g
[Tue Mar 10 15:24:59 2009] [info] mod_unique_id: using ip addr 91.121.166.128
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromJpeg in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromJpeg in Unknown on line 0
icecpp: can't open `/home/mumble/murmur/murmur.ice' for reading
PHP Fatal error: Unable to start ice module in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromJpeg in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromJpeg in Unknown on line 0
icecpp: can't open `/home/mumble/murmur/murmur.ice' for reading
PHP Fatal error: Unable to start ice module in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromJpeg in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: undefined symbol: gdImageCreateFromJpeg in Unknown on line 0
icecpp: can't open `/home/mumble/murmur/murmur.ice' for reading
PHP Fatal error: Unable to start ice module in Unknown on line 0


(depuis, murmur/mumble à été supprimé, et n'est plus utilisé, idem pour "icecpp")


Quelqu'un pourrait m'aider ?

Merci d'avance !
  • # resolu en réinstall

    Posté par  (site Web personnel) . Évalué à 1.

    Je suis curieux de savoir ce qu'il s'est réellement passé, mais dans l'attente, j'ai préféré ré-installer au complet, ce qui a résolu le problème ..
    • [^] # Re: resolu en réinstall

      Posté par  (site Web personnel) . Évalué à 2.

      euh, t'es pas sous windows hein, les problèmes ne se résolvent pas qu'en réinstallant...
      • [^] # Re: resolu en réinstall

        Posté par  (site Web personnel) . Évalué à 0.

        Très bien UId, ta science m'intéresse ...

        J'écoute ta solution, je suis près a migrer une machine d'etch a lenny pour retenter l'expérience ....



        Histoire de pas faire des trolls complètement idiot, pensent peut être aux éventuelles obligations de service, que certains doivent tenir, avant de dire des choses inutiles ...
    • [^] # Re: resolu en réinstall

      Posté par  (site Web personnel) . Évalué à 2.

      Difficile de trouver ce qui s'est passé sans installation pour analyser.

      Toujours est-il que ton premier message était un warn donc ça ne venait pas de là.

      Ensuite, ton problème venait probablement d'une erreur d'installation de la lib gd php5-gd un reinstall sur ce paquet aurait peut-etre suffi.
  • # php-gd ?

    Posté par  . Évalué à 4.

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so
    ça serait pas php-gd (ou php5-gd) qui serait passé à la trappe lors de la migration ?
    • [^] # Re: php-gd ?

      Posté par  (site Web personnel) . Évalué à 1.

      J'avais réinstall le php5-gd, mais pas le php-gd ... (inconnu au bataillon ???)

      Je pense que c'était les différents fichiers de config dans le reps "mods-enable", et dont certaines choses étaient restées dans le apache2.conf ...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.