Forum Linux.debian/ubuntu Probléme récent de lecture DVD saccadée

Posté par  .
Étiquettes : aucune
0
12
nov.
2006
Bonsoir .
C'est aprés un upgrade vers etch depuis Knoppix 5.0 (noyau 2.6.17) que j'ai eu ce probléme , auparavant (KNOPPIX 3.8 noyau 2.6.11) tout se passait bien aprés avoir teléléchargé les paquets libdvdcss et libdvdcss2 pour accéder aux DVD plus récents ..
Donc mes dvd et divx sont saccadés en lecture avec VLC .
En fait avec tous les logiciels ...

Un peu moins de saccades aprés : hdparm -d1 /dev/hdc....
Ce n'est pas un probléme Hardware puisque VLC lit parfaitement les DVD sous windows .
Sous linux,
Le Dma n est pas activé par défaut sur le lecteur DVD
Test de vitesse :
hdparm -tT /dev/hdc :
/dev/hdc:
Timing cached reads: 348 MB in 2.01 seconds = 172.74 MB/sec
BLKFLSBUF failed: Function not implemented
Timing buffered disk reads: 14 MB in 3.02 seconds = 4.63 MB/sec
BLKFLSBUF failed: Function not implemented

ctivation DMA:
hdparm -d1 /dev/hdc
hdparm -d /dev/hdc : dma 1

nouveau Test:
/dev/hdc:
Timing cached reads: 384 MB in 2.02 seconds = 190.52 MB/sec
BLKFLSBUF failed: Function not implemented
Timing buffered disk reads: 24 MB in 3.06 seconds = 7.83 MB/sec
BLKFLSBUF failed: Function not implemented

C'est bien ce que j' avais remarqué : il y a aprés activation une légére amélioration mais toujours un rendu saccadé .
le fichier etc/hdparm/hdconf est totalement commenté sauf le mot : quiet !!
Je suppose que quelque part dans les configurations quelque chose ne va pas mais ou???
Je pense qu une réponse devrait intéresser pas mal de monde car j ai aperçu plusieurs posts à ce sujet ...
  • # système chimère

    Posté par  . Évalué à 1.

    Évite les mélanges de paquets entre distributions, une Knoppix n'est pas une Debian, tu risques donc te te trimballer des configurations mal adaptées, certains paquets pas à jour etc.

    Je te conseille vivement d'installer directement une Etch, tes éventuels problèmes seront bien plus simples à diagnostiquer, et tu éviteras sans doute pas mal de pbs à l'avenir.
    • [^] # Re: système chimère

      Posté par  . Évalué à 1.

      Oui d'accord mais c'est bien pratique quand même .
      D' ailleurs ma précédente tentative (knoppix 3.8) était ok sauf que j' avais trop tardé à faire les mises a jour de paquets.
      En fait j'espére avoir une debian etch quasiment pure aprés les upgrade successifs ..mais pour le moment étre obligé de switcher sur windows pour la vidéo ,c' est pas ce que j' espérais .
      Je crois avoir changé avec cette version de serveur graphique (xorg au lieu de xfree ?) .
      Il y a peut étre des paramétres à configurer ?
      Autres pistes ?
  • # avec mplayer ?

    Posté par  . Évalué à 0.

    Avec mplayer, j'avais un souci similaire tant que je n'utilisais pas l'option cache, dans mon cas mplayer -cache 10000 dvd://1
    • [^] # Re: avec mplayer ?

      Posté par  . Évalué à 1.

      Merci mais non la configuration du cache ne suffit pas à annuler la saccade .
      J'ai rétabli le dma en automatique et donc il ya moins de saccades mais ce n'est pas encore bon ...
      J'ai aussi vérifié que la lecture de dvd était impeccable avec ma debian/knoppix de noyau 2.6.11 ....
      Est il possible que le chagement de noyau induise ce genre de régression ?
      Je vais sans doute essayer d'installer un pilote nvidia non free pour voir ....

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.