Forum Linux.debian/ubuntu probleme avec su -

Posté par .
Tags : aucun
0
13
mai
2005
Bonjour,

j'ai une debian custom maison, ou le login root n'est pas root mais autre chose :) Posons que c'est pwet. root est donc pwet, pas la peine de chercher à se connecter en root, l'utilisateur est disable.

Petit probleme que je rencontre. Lorsque, depuis la console, je me connecte en tant que pwet, ok ca marche.

Si j'utilise un compte utilisateur présent, par exemple toto, je me connecte sur la machine en tant que toto (toujours via la console) et quand je fais un su - pwet (pour passer root donc), ca ne marche pas.

su : authentication failure.
sorry.

Désolé, mais celui qui est encore plus désolé c'est moi ... Mes fichier /etc/passwd, /etc/shadow sont corrects (enfin je vois pas ce qui peut clocher dedans).

N'arrivant pas bien a comprendre le pourquoi du comment, mes recherches et mes essais reste pour le moment infrustueux ...

Quelqu'un aurait-il une idée a me soumettre ? Une piste ? Une astuce ?

Merci d'avance.
  • # Allez voir

    Posté par . Évalué à 0.

    dans l es fichiers logs (/var/log) tu trouveras une piste
    • [^] # Re: Allez voir

      Posté par . Évalué à 2.

      Hum,

      oui merci je connais les fichiers logs :) Mais mise a part un "authentication failure" je n'ai rien d'autre ...

      Je tiens a préciser que toto est bien dans le group root ... mais de toute facon le wheel n'est pas activé !
  • # kuikui

    Posté par . Évalué à 1.

    moi j'aimerais bien voir ton /etc/passwd et ton /etc/shadow .
    • [^] # Re: kuikui

      Posté par . Évalué à 2.

      /etc/passwd


      pwet:x:0:0:root:/root:/bin/bash
      daemon:x:1:1:daemon:/usr/sbin:/bin/sh
      bin:x:2:2:bin:/bin:/bin/sh
      sys:x:3:3:sys:/dev:/bin/sh
      sync:x:4:65534:sync:/bin:/bin/sync
      games:x:5:60:games:/usr/games:/bin/sh
      man:x:6:12:man:/var/cache/man:/bin/sh
      lp:x:7:7:lp:/var/spool/lpd:/bin/sh
      mail:x:8:8:mail:/var/mail:/bin/sh
      news:x:9:9:news:/var/spool/news:/bin/sh
      uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
      proxy:x:13:13:proxy:/bin:/bin/sh
      postgres:x:31:32:postgres:/var/lib/postgres:/bin/sh
      www-data:x:33:33:www-data:/var/www:/bin/sh
      backup:x:34:34:backup:/var/backups:/bin/sh
      operator:x:37:37:Operator:/var:/bin/sh
      list:x:38:38:Mailing List Manager:/var/list:/bin/sh
      irc:x:39:39:ircd:/var/run/ircd:/bin/sh
      gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
      nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
      sshd:x:100:65534::/var/run/sshd:/bin/false
      toto:x:1000:100::/home/toto:/bin/bash


      /etc/shadow
      bah la meme chose :) avec une ligne pwet pour pwet ...
      • [^] # Re: kuikui

        Posté par . Évalué à 1.

        c'est dommage parceque chez moi ca marche...
        j'ai juste remplace root dans /etc/passwd et /etc/shadow .
        je fais un su et hop... je me retrouve en pwet avec les droits root.
        debian sarge.
  • # problème su

    Posté par . Évalué à 1.

    Tiens, j'ai le même problème, la seule différence c'est que chez moi root s'appelle toujours root... j'ai aussi une debian sarge, et vu la date du premier post, je me dis que c'est peut-être une mise à jour récente qui foire...
    Comme pour le réseau (est-ce propre au noyau 2.6?) au démarrage je n'avais plus qu'une interface inconue avec une adresse mac (xx:xx:xx:xx...) trop longue pour être honnête (parrait que c firewire over ethernet) et donc plus d'internet. Mais ça, c'est rentré dans l'ordre après avoir enlevé et remis la carte réseau dans le noyau par modconf.

    Donc je compatis, dans l'espoir de reviendre bientôt lire ou donner des idées aidantes ;)

    Amike,
    Christian

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.