Forum Linux.debian/ubuntu probleme de clavier qwerty

Posté par  (site Web personnel) .
Étiquettes : aucune
0
23
août
2004
Bonjour.

Je viens d'installer une distribution Debian en lieu et place de ma bonne vielle Mandrake (je n'avais rien a lui reprocher, je veux simplement essayer d'autres distributions). Et j'avoue avoir ete agreablement surpris car je m'attendais a une installation difficile, ce qui n'a pas ete le cas.

Par contre, je butte sur la configuration du clavier en francais sous X. Impossible d'avoir un azerty dans la session gnome (l'interface est bien en francais et GDM est en azerty). Le fichier /etc/XF86Config-4 est correct. Bref, je ne sais plus trop ce que je peux faire.
  • # Menu language de gdm

    Posté par  . Évalué à 1.

    Selectionne français dans le menu language de GDM au moment de la connection.
  • # XFREE

    Posté par  . Évalué à 1.

    dans ton fichier /etc/X11/XF86config

    Options Layout "en"

    la tu met "fr"

    voir "fr_FR"


    voila tu relance X et c'estbon
  • # c'est pas une solution mais ça peut dépanner

    Posté par  . Évalué à 1.

    Exporte un fichier modmap azerty avec xkeycaps puis fais xmodmap fichier.
  • # La solution

    Posté par  (site Web personnel) . Évalué à 2.

    La solution est en fait assez simple.

    Avec gconf, il faut editer la valeur:
    desktop > peripherals > keyboard > xkb > layouts : fr au lieu de us

    Donc, a priori, Gnome reconfigure cela à chaque session et j'ai du faire une bêtise au départ (première installation).

    Merci à tous pour vos réponses.
  • # dpk-reconfigure

    Posté par  (site Web personnel) . Évalué à 2.

    Et tu passés par dpkg-reconfigure xserver-xfree86 ?


    Une commande bien utilie lorsqu'on installe ou configure X

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.