Forum Linux.debian/ubuntu probleme de clavier sous debian

Posté par  .
Étiquettes : aucune
0
12
oct.
2005
bonjour a tous,

apres 3h de recherche je me decide a vous demander, mon souci de clavier est bizarre, je suis configurer en clavier francais sur un portable,
toute les lettre sont au bonne endroit par contre mon "shift "marche pas, imaginer comme c'est pratique pour la config, surtout sans le "." ni le"/", bref je peu pas faire grand chose. vous allez me dire "sert toi de cap_lock", j'y ai pensé, mais j ai les majuscule, mais pas les chiffres et la ponctuation, alors je doute que ca vien du bouton.

au depart j ai eu des petit souci avec xserver, il avait un peu de mal, mais tout est rentré dans l'ordre, j 'avais fait ca vite et mis le clavier anglais, je l'ai ensuite changé et la la catastrophe.

Quelqu'un aurai une idée?
  • # oubli

    Posté par  . Évalué à 2.

    oui, pardon je suis sous enlightenment
  • # quelle version d'xorg?

    Posté par  . Évalué à 3.

    J'ai eu exactement le même problème il y a quelque jours. Mais apparement ç'est venu aprés le passage à une version cvs de xorg. La gestion du clavier a du être légérement modifiée...

    avant dans mon /etc/X11/xorg.conf j'avais ça:

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105euro"
    Option "XkbLayout" "fr-latin9"
    EndSection

    que j'ai du changer en:

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105euro"
    Option "XkbLayout" "fr"
    Option "XkbVariant" "latin9"
    EndSection

    C'est fou ce qu'elle peut manquer cette touche [Shift] quand elle disparait pas vrai ;). J'espère que ça pourrat t'aider
    • [^] # merci pour tout

      Posté par  . Évalué à 1.

      mais je peu pas allez dans /etc/x11/xorg.conf , j ai pas acces a la touche "/" , sniff...
      • [^] # Re: merci pour tout

        Posté par  . Évalué à 2.

        Je m'en suis sorti avec le pavé numérique. Sinon, il reste la solution de démarrer avec un CD live (vif pour les anglophobes :p), de monter la partition racine quelque part puis d'aller éditer ce fameux fichier...
        • [^] # g un gros souci alors

          Posté par  . Évalué à 1.

          g pas de répertoire X11 chez moi, donc c pas terrible,

          merci pour le pavé numérique, c sur un portable c un peu galère, par contre g pas mon point, il me met une virgule, mais je me débrouillerai avec ca.
  • # xkeycaps

    Posté par  . Évalué à 0.

    une fois, j'avais eu le même problème après l'installation d'une debian, et j'ai jamais compris pourquoi ça a fait ça, mais j'ai résolu le problème en installant xkeycaps (c'est un paquet)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.