Forum Linux.debian/ubuntu Proxmox et esmtp

Posté par  .
Étiquettes : aucune
0
2
nov.
2009
Bonjour,

je suis en train de tester Proxmox. Ca a l'air pas mal mais il y a une tonne de bugs.

Un des bugs qui me gène est que je ne peux pas installer correctement esmtp.

# aptitude install esmtp esmtp-run
[snip snip]
Supprimer les paquets suivants :
proxmox-ve
pve-manager
[snip snip]


Si je demande esmtp seulement, pas de problème. Mais il me faut également esmtp-run. Lorsque je demande esmtp-run, c'est là que ça m'indique qu'il faut supprimer proxmox. Pas d'accord :)

Je n'y connais rien question entrailles de gestionnaire de paquets. Comment puis-je visualiser les dépendances afin de comprendre en quoi proxmox et esmtp-run sont liés ?
Je pense que Proxmox est lié à Postfix, au lieu d'être lié à "mail::transport-agent".

Et surtout, comment puis-je convaincre le système d'installer esmtp-run sans enlever le reste ? Et que ça ne me dise pas à chaque fois qu'un paquet a des dépendances non satisfaites.
  • # use the FORCE luke

    Posté par  . Évalué à 2.

    il y a surement une option dans aptitude pour forcer l'installation d'un paquet

    sauf que l'option force ne semble pas exister

    il reste alors l'option de telecharger le paquet
    puis de l'installer avec dpkg qui lui peut utiliser la force

    man aptitude pour le telechargement sans installation du paquet
    man dpkg pour l'option --force-xxxxx ou -no-force-xxxxx selon que tu veux forcer ou ignorer certaines alertes
  • # Redemander l'installation de proxmox

    Posté par  . Évalué à 3.

    Chez moi (avec apt-get), lorsque je tente d'installer un paquet qui est déjà installé et qui est une dépendance d'un autre paquet, le paquet est alors marqué comme installé manuellement.
    Comme ça, si par la suite je supprime le paquet dont il dépend, le paquet ne sera pas supprimé.

    Exemple : tentative d'installation du paquet libjson-glib, qui est une dépendance de pidgin-facebookchat


    apt-get install libjson-glib-1.0-0

    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    libjson-glib-1.0-0 est déjà la plus récente version disponible.
    libjson-glib-1.0-0 passé en « installé manuellement ».

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.