Forum Linux.debian/ubuntu quotacheck ne marche pas

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
22
mar.
2017

j'ai entamé les démarches suivantes :

dpkg -s quota | grep status
sudo apt-get install quota
sudo nano /etc/fstab   
# j ai edité la ligne :   /home      ext3    defaults,usrquota,grpquota    0    2

sudo touch /home/aquota.group
sudo touch /home/aquota.user
sudo chmod 600 /home/aquota.*
sudo mount -o remount /home

jusque là rien ne se passe, c bon ,,

mais dèes que je tape :

sudo quotacheck -vgum /home

ou :

sudo quotacheck -vgum

voila ce que je recoit :

quotacheck: Impossible de deviner le format d'après le nom de fichier sur /dev/sda10. Veuillez préciser le format sur la ligne de commande.
quotacheck: Impossible de trouver un système de fichier à vérifier, ou le système de fichier n'est pas monté avec l'option de quota.

Donc impossible d'initialiser le système de quota via la commande quotacheck.
Alors que faire ?
merci

  • # .

    Posté par  . Évalué à 1.

    Bonjour,

    Essayez ceci : effacez les deux fichiers et demandez au programme de les créer en ajoutant l'option -c à la commande.

    • [^] # Re: .

      Posté par  . Évalué à 1.

      merci chastai

      ca marche. est ce que je pourrais savoir ce qui s'est passé exactement ?

      pourquoi est ce que lorsqu on efface et on laisse quotachek les créer ca marche ? quoique sur les tuto (tous presque) indique qu il faut les creer avec un touch !!??
      merci

      • [^] # Re: .

        Posté par  . Évalué à 4.

        Le programme échoue car il n'arrive pas à déterminer si les fichiers aquota.{user,group} sont au format vfsv0 ou vfsv1 en analysant les en-têtes, ce qui est normal puisque ces fichiers sont vides.
        Quand vfsv1 n'était pas encore implémenté, le nom du fichier seul suffisait à en determiner le format (quota.* = vfsold, aquota.* = vfsv0).

  • # remerciements pour chastai

    Posté par  . Évalué à 1.

    merci chastai,
    c'est nouveau pour moi .. et cela me donne l'envie d'aller piocher d'avantage ..
    merci beaucoup.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.