Forum Linux.debian/ubuntu RAID 1 Logiciel, Lenny et XFS

Posté par  (site Web personnel) .
Étiquettes : aucune
0
29
fév.
2008
Salut,

J'essaie de formater mon raid 1 (avec une seule partition, la seconde en missing) avec XFS (aussi essayé en ext3, pas de soucis), au mount je reçois des messages d'erreurs bizarres alors que je trouve des quantités de docs expliquant la compatibilité de XFS avec le raid et sa prise en compte, .... :
seharian:~# mount /dev/md0 /media/test/
mount: wrong fs type, bad option, bad superblock on /dev/md0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

et syslog me montre :
seharian:~# dmesg |tail
XFS: bad version
XFS: SB validate failed

xfs_check, xfs_repair, ... tout vas bien ! et mount, ... en ext3 aussi !

fdisk:
/dev/sda2 6080 12305 50010345 fd Linux raid autodetect

/proc/mdstat:
md0 : active raid1 sda2[0]
50010240 blocks [2/1] [U_]

Si des personnes ont des infos ;-)
  • # Dans l'ordre

    Posté par  . Évalué à 2.

    As-tu essayé de le faire sans RAID ?

    Tu effaces ton volume RAID, tu le remplaces par une partition normale et tu tentes de monter ça avec XFS. Si tu as le même genre d'erreur, c'est un problème d'option, tel qu'indiqué dans le message d'erreur que tu obtiens déjà.
    Dans le cas contraire, tu es tombé sur un bug. Malheur à toi :-)

    Il n'y a, en principe, pas de raison pour qu'un système de fichiers ne soit pas compatible avec un RAID puisque c'est vu comme un périphérique ordinaire en mode bloc. Comme n'importe quel partition et n'importe quel disque.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.