Forum Linux.debian/ubuntu Résolu [HP Elitedesk 820 G2 - gestion du son]

Posté par . Licence CC by-sa.
Tags : aucun
0
12
juin
2015

Bonjour,

c'est Vendredi, je me lâche.

3ème (et dernier) souci avec mon nouveau PC HP Elitedesk 820 G2 : le son

Lorsque je démarre mon PC, le son ne sort pas sur le haut-parleur intégré. Toute action "logicielle", activer/désactiver le son, modifier le volume… n'a aucun effet.
Dès que je branche un mâle jack dans la prise idoine, le son fonctionne sur cette sortie (casque, haut-parleur externe…) et dès que je le débranche, ça active le haut-parleur intégré (donc tout rentre dans l'ordre).

C'est vrai, je chipote, c'est un tout petit souci. Mais si quelqu'un avait une idée pour que je fasse cette opération de manière logicielle, ça serait bien pratique.

Quelques infos sur le contrôleur audio :

# lspci 
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)

# lsmod |grep snd
snd_hda_codec_hdmi     45118  1 
snd_hda_codec_realtek    67127  1 
snd_hda_codec_generic    63142  1 snd_hda_codec_realtek
snd_hda_intel          26327  5 
snd_hda_controller     26646  1 snd_hda_intel
snd_hda_codec         104463  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13148  1 snd_hda_codec
snd_pcm                88662  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              26614  1 snd_pcm
snd                    65244  18 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              13026  2 snd,snd_hda_codec
  • # on est vendredi, c'est permis

    Posté par . Évalué à 2.

    je penses qu'arriver à ce stade, il faut changer de PC :p

    tu as regardé les reglages audio avant/apres le truc de la prise jack ?
    si ca se trouve ca change une valeur quelque part, et ca reactive le speaker.

    par exemple : sortie par defaut sur HDMI => pas de son,
    tu branches le jack => sortie par defaut analogique => du son

    sinon j'ai souvenir, mais c'est vieux, qu'on pouvait passer des options au module noyau pour changer certains reglages de sorties de certaines cartes, par exemple changer l'entrée jack/micro en sortie jack/ligne.

    • [^] # Re: on est vendredi, c'est permis

      Posté par . Évalué à 1.

      Et puisqu'on est vendredi, autant y aller franco: apt purge pulseaudio est ton ami.

      Plus sérieusement, vérifie que ce n'est pas une merde de ce côté, si c'est installé. Si tu n'as que ALSA, comme moi, va donc voir du côté de alsamixer (avant que tu ne fasses la moindre manip bien entendu). Tu y verras diverses jauges de volumes et périphériques.
      Tu pourras également accéder à une liste des cartes son, le tout pourrait te donner un indice sur le problème réel et donc un début de solution ou au moins une piste. Parce que là… on à rien, on ne connais même pas le nom de ta distro.

      • [^] # Re: on est vendredi, c'est permis

        Posté par . Évalué à 1. Dernière modification le 23/06/15 à 16:31.

        Désolé,
        je partais du principe (stupide) que tout le monde a lu mes précédents posts…
        C'est une Jessie 64bits.
        J'ai du Pulseaudio d'installé :

        $ dpkg -l |grep pulse
        ii  libpulse-mainloop-glib0:amd64         5.0-13                              amd64        PulseAudio client libraries (glib support)
        ii  libpulse0:amd64                       5.0-13                              amd64        PulseAudio client libraries
        ii  libpulsedsp:amd64                     5.0-13                              amd64        PulseAudio OSS pre-load library
        ii  pulseaudio                            5.0-13                              amd64        PulseAudio sound server
        ii  pulseaudio-module-x11                 5.0-13                              amd64        X11 module for PulseAudio sound server
        ii  pulseaudio-utils                      5.0-13                              amd64        Command line tools for the PulseAudio sound server

        Du coup, dans Alsamixer, ma carte "par défaut", c'est PulseAudio.
        Du coup, je cherche du côté de Pulseaudio.

  • # pavucontrol

    Posté par . Évalué à 1.

    Installes l'outil graphique pour configurer pulseaudio: pavucontrol
    et essaye de changer la sortie par défaut.

    • [^] # Re: pavucontrol

      Posté par . Évalué à 1.

      Bonjour Koopa,

      Super, c'était ça.

      Dans "Périphérique de sortie, j'ai en premier "Audio interne Digital Stereo (HDMI)"
      Puis "Audio interne Stéréo analogique" dont le port par défaut est "Sortie analogique".
      Je le mets en "Speaker" et c'est bon.

      Reste a vérifier après un reboot si ça reste. Ou si je trouve une commande Pulse Audio pour ça.

      Merci

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.