Forum Linux.debian/ubuntu Revenir sur le choix d'un backport

Posté par  . Licence CC By‑SA.
Étiquettes :
1
5
fév.
2018

Salut,

À un moment, j’ai choisi d’utiliser le noyau « backport » sur debian stretch… je ne me souviens plus de pourquoi ce choix.
Néanmoins, aujourd’hui ce choix me pose un problème de compatibilité avec le driver propriétaire nvivia.

Je vois deux solutions :

  • Passer le driver nvidia sur les backport sans doute la solution la plus simple.
  • Revenir sur le noyaux standard.

Ma question, est pour la deuxième solution, comment une fois qu’on a installer un paquet en provenance des backports (apt-get -t …) peut-on revenir sur la ligne standard ? J’ai bien essayé un apt-get -t stable|stretch linux-image ça n’a pas fonctionné :'(

  • # réinstaller une version antérieur

    Posté par  (site Web personnel) . Évalué à 3.

    Salut,

    Si tu es en 64 bits, pour voir quelles versions tu as du noyau, et lesquelles sont disponibles :
    apt list -a linux-image-amd64

    Sur mon ordinateur j'ai :
    linux-image-amd64/stretch-backports,now 4.14+89~bpo9+1 amd64 [installé]
    linux-image-amd64/stable 4.9+80+deb9u3 amd64
    linux-image-amd64/stable 4.9+80+deb9u2 amd64

    Et pour revenir à une version antérieure :
    apt install linux-image-amd64=4.9+80+deb9u3

  • # 2 solutions

    Posté par  . Évalué à 2.

    1. désinstaller le backport, et la ça va dépendre de ce que tu préfères. Perso, je préfère l'interface interactive d'aptitude à apt, mais c'est un choix. Dans ce cas, ne pas oublier de vérifier que le noyau stable est bel et bien installé, sinon ton système risque de ne plus démarrer du tout.

    2. configurer le boot loader pour qu'il change de kernel par défaut. Si tu n'utilises pas grub, c'est assez simple à faire, il suffit de modifier un fichier unique de conf dans /etc et d'actualiser le boot. Sauf que la plupart des distributions modernes utilisent grub par défaut, et je trouve la configuration plus complexe à comprendre et modifier, mais normalement, c'est largement faisable.

  • # Merci

    Posté par  . Évalué à 2.

    Merci à vous deux.

    Avec le apt list j’ai pu vérifier que le driver nvidia était bien sur la version standard. Il ne compilait plus dû à un changement d’interface dans un .h au passage du 4.13 -> 4.14.
    En passant le driver en backport tout roule.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.