Forum Linux.debian/ubuntu sites inaccessibles

Posté par  .
Étiquettes : aucune
0
8
juil.
2006
Bonjour.

Ayant changé de carte-mère, processeur etc., j'en ai profité pour faire
un ordi à mon fils.
Celui-ci s'étant mis à la basse, je lui ai installé une distrib Agnula
(http://www.agnula.org/) il ne s'agit pas d'une distrib basée sur Debian
mais d'une Debian adaptée à une utilisation musicale.

J'ai remplacé mon modem USB par un modem router ethernet 4 ports (D-Link dsl-524t) afin que cette deuxième machine ait accès à internet.

Je rencontre un problème étrange : certains sites sont accessibles
directement (debian.org p. ex. d'autres uniquement si on tape leur
adresse sous forme http:// adresse ip. Par exemple si je tape dans la
barre d'adresse http://www.google.fr la recherche boucle indéfiniment
mais si je tape http://66.249.85.104 j'accède à google.

Quelqu'un aurait-il un début d'indice ?

Merci d'avance
  • # serveur DNS

    Posté par  . Évalué à 2.

    Ca c'est typiquement un problème de DNS. Vérifie tes paramètres réseaux (vérifie que le serveur DNS est spécifié et si ce n'est pas le cas entre l'IP de ton modem ethernet comme serveur DNS).

    AM
    Morigane
    • [^] # Re: serveur DNS

      Posté par  . Évalué à 1.

      Vérifie tes paramètres réseaux (vérifie que le serveur DNS est spécifié et si ce n'est pas le cas entre l'IP de ton modem ethernet comme serveur DNS).


      Bien tenté :) ce parametrage est correct je l'ai vérifié et re-vérifié.

      En tâtonnant depuis hier je me suis même aperçu que je ne pouvais accéder à yahoo en tapant l'adresse IP dans le navigateur en revanche un ping sur cette adresse fonctionne !

      Le brouillard s'épaissit :(

      Merci d'avoir répondu.

      Il se prend pour Napoléon, son état empire.

      • [^] # Re: serveur DNS

        Posté par  (site Web personnel) . Évalué à 2.

        Revérifie, genre tu as 2 serveurs dns dans ton resolv.con et un seul des 2 repond.
        Pingue les, essaie avec les commandes host et dig (en spécifiant le serveur dns interrogé) essaie avec getent hosts pour voir ce que ca donne.

        Et enfin regarde si tu n'as pas un serveur dhcp qui donne des infos variables à propos des serveurs dns à utiliser.
        • [^] # Re: serveur DNS

          Posté par  . Évalué à 1.


          Revérifie, genre tu as 2 serveurs dns dans ton resolv.con et un seul des 2 repond.
          Pingue les, essaie avec les commandes host et dig (en spécifiant le serveur dns interrogé) essaie avec getent hosts pour voir ce que ca donne.

          Et enfin regarde si tu n'as pas un serveur dhcp qui donne des infos variables à propos des serveurs dns à utiliser.


          En fait, l'installation était fraîche, j'ai tout réinstallé (bourrin, parfaitement !)

          Au lieu de donner l'adresse du router comme DNS j'ai carrément donné l'adresse (enfin une des) du serveur de DNS de mon fournisseur d'accès à savoir Cegetel.

          Tout a fonctionné à merveille... Pendant une heure puis plus de connexion. Vérification faite l'adresse DNS était redevenue celle du routeur. Je n'ai touché à rien, je n'ai pas quitté la bécane des yeux !

          Pour finir une mise à jour à définitivement bousillé mon système :(
          (Il semble y avoir un problème avec les adresses des dépôts)

          Le bourrin devient chêvre ! (on dirait du la Fontaine :)))

          Je reinstalle et je vous tiens au courant.

          Mes machines sont en adressage fixe (enfin à priori, je ne suis plus sûr de rien)

          Merci
          Dom.

          Il se prend pour Napoléon, son état empire.

          • [^] # Re: serveur DNS

            Posté par  (site Web personnel) . Évalué à 2.

            Il est probable si ca change sans t'avertir que le changement viennent du renouvellemnt dhcp. Vérifie la configuration du serveur dhcp sur ton routeur.

            Sous linux, trouver le probleme est en général plus enrichissant que de tout réinstaller.
            • [^] # Re: serveur DNS

              Posté par  . Évalué à 1.

              Il est probable si ca change sans t'avertir que le changement viennent du renouvellemnt dhcp. Vérifie la configuration du serveur dhcp sur ton routeur.

              Bien vu ! le DHCP était activé sur le router. C'est corrigé, merci.
              Ca ne me dit toujours pas porquoi l'une des machines fonctionne parfaitement avec l'adresse du router en DNS et pourquoi l'autre nécessite l'adresse de mon FAI.

              Sous linux, trouver le probleme est en général plus enrichissant que de tout réinstaller.


              Dans une optique purement informaticienne j'en conviens. Cependant dans l'optique de me servir de la machine (autrement dit pour faire autre chose que d'installer / entretenir / réparer le système), il m'arrive de choisir la solution qui m'apparaît comme étant la plus rapide ou la plus rationnelle.

              @+
              Dom.

              Il se prend pour Napoléon, son état empire.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.