Forum Linux.debian/ubuntu Texte non visible dans les animations flashs (Debian sid)

Posté par  .
Étiquettes : aucune
0
7
mai
2006
Salut à tous,
Un peu comme http://linuxfr.org/forums/15/13935.html , je ne peux voir certains textes dans les animations flashs qu'importe le navigateur.

Je suis en Debian Unstable, j'ai gsfonts-x11 d'installé et dans ma configuration Xorg, les FontPath suivants :
Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Avec au démarrage d'X, les erreurs suivantes :
Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType, removing from list!
Could not init font path element /usr/share/fonts/X11/TTF/, removing from list!
Could not init font path element /usr/share/fonts/X11/OTF, removing from list!
Could not init font path element /usr/share/fonts/X11/CID/, removing from list!

D'ailleurs, "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" existe bien et contient plusieurs .ttf...

Si quelqu'un a une idée de l'origine de ce problème, je suis preneur !

J'ai déjà vu l'astuce sur la faq de flash, et la méthode d'ajouter un lien symbolique ou des FontPath tiré de bugzilla.redhat.com, mais rien n'y fait.

J'ai désinstallé xfs qui n'était plus dans le xorg.conf déjà.

Merci d'avance ;)
  • # msttcorefonts

    Posté par  . Évalué à 2.

    Bonjour,

    Je ne suis pas sûr mais tu peux essayer d'installer le paquet msttcorefonts
  • # Problème de police

    Posté par  . Évalué à 3.

    D'ailleurs, "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" existe bien et contient plusieurs .ttf...

    Il doit manquer le fichier d'index dans le répertoire. X va lire ce fichier pour charger la liste des polices présentes. Tu peux le recréer avec "mkfontdir".
  • # update-fonts-dir ?

    Posté par  . Évalué à 2.

    Au hasard, update-fonts-dir et update-fonts-alias ? Ça date, mais ça marche toujours :
    http://www.paulandlesley.org/linux/xfree4_tt.html

    Malgré tous les témoignages que j'ai pu trouver sur la prise en charge automatique des fontes TrueType sous Debian, pour l'instant, je ne l'ai jamais vu marcher.
  • # Ca marche !

    Posté par  . Évalué à 1.

    Alors j'ai mkfontdir et update-fonts-dir et update-fonts-alias les dossiers en FontPath dans mon xorg.conf, et ça marche !

    Merci beaucoup à vous :)
    • [^] # Re: Ca marche !

      Posté par  . Évalué à 1.

      Á priori, update-fonts-dir suffisait.

      De ce que je comprends, on ne devrait utiliser cette commande qu'avec des répertoires en relatifs (ce que fait le postinst de msttcorefonts), le chemin complet étant reconstruit (à partir de /etc/fonts/fonts.conf ?).

      Et je soupçonne que le répertoire d'installation de msttcorefonts n'est pas déclaré dans le fonts.conf des Debian. J'ai le même problème sur une debian installée il y a 3 ans et mise à jour régulièrement (sur laquelle je rencontre de temps en temps des petits soucis parce que les mises à jour ne valent pas une réinstallation complète), ainsi que sur une debian toute neuve. Et visiblement, je ne suis pas le seul.

      Je creuse, je crois que je vais me fendre d'un rapport chez Debian. C'est quand même un bug horripilant, et qui renforce l'idée que Debian n'est pas prête pour le Desktop.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.