Forum Linux.débutant Boot impossible sur un disque dur emmc

Posté par  . Licence CC By‑SA.
Étiquettes :
1
28
fév.
2018

Bonjour,

J'ai acheté un pc avec une mémoire emmc 32Go et un processeur atom z8350
J'essaye d'installer mint dessus mais une fois terminer après redémarrage le pc ne boot pas sur l'os mais arrive directement sur le bios !?

J'ai désactivé le secure boot, fastboot et le mode uefi.
J'utilise une clé usb formater en fat32 avec l'utilitaire "multisystem" pour booter sur mint mate 18.3.

J'ai au préalable formater la disque dur emmc avec gparted pour virer windows qui était préinstallé.
L'installation se passe sans problème apparent. Il m'est juste demandé si je souhaite démonter la partition sda (qui correspond à ma clé usb), je dis "non", un autre message apparait qui me demande si je souhaite forcer le mode uefi car il détecte d'autres os qui sont en "mode bios", alors que la partition est vierge, j'indique "revenir en arrière", l'installation continue normalement.

Le pc supporte la version 64bits

Quelqu'un saurait-il si il y a une manipulation à faire avec des disques emmc ?

  • # UEFI

    Posté par  . Évalué à 3.

    Bonsoir,

    Il faut installer avec UEFI il n'y a plus de bios mais un setup UEFI avec les nouvelle carte mère, j'ai une tablette PC avec un Z8350 iWork1X 11,6" avec la chakra Linux mais toujours pas de son sauf en hdmi, fonctionne avec un carte audio USB
    Voir:
    Linuxium iso de la Ubuntu pour les Atom type Z37xx Z8xxx

  • # bios ou uefi

    Posté par  (site Web personnel) . Évalué à 3.

    Vu que tu as viré Windows, tu peux installer dans le mode que tu veux, si ta carte mère le permet. Par contre, l'UEFI nécessite une table de partition GPT, ainsi qu'une partition spéciale EFI en début du disque: c'est logiquement ainsi que ton disque est partitionné.

    Si tu veux passer en mode bios, il faut que tu crées une table de partition MBR sur ton disque, car GPT n'est pas compatible.

    Un LUG en Lorraine : https://enunclic-cappel.fr

  • # Asus E200HA ?

    Posté par  (site Web personnel) . Évalué à 2.

    Si c'est bien celui là, pas besoin de désactivé l'uefi. On vient de m'en filer un, alors je lui ai collé une Ubuntu 17.10, sans aucune difficulté.

    Juste y a pas de son…

  • # schneider SCL141CTP 14"

    Posté par  . Évalué à 1.

    merci pour vos réponse, le pc est pour ma copine

    j'ai donc testé une installation en mode uefi. Pour cela j'ai activé le mode uefi dans le bios et j'ai transformé ma mbr en gpt.
    Ensuite je lance l'installation, je force le mode uefi, puis j'ai testé plusieurs possibilité :

    • mode auto : l'installateur gère lui-même ce qu'il y a faire pour les partitions etc…
    • mode manuel opt 1 : j'ai créer une partition efi proposé dans les options de la taille de 1Go + swap + /
    • mode manuel opt 2 : j'ai créer une partition /boot/efi moi-même ainsi que les autres comme précédemment

    et à chaque fois j'ai le même message qui apparait avant la fin de l'installation :

    "Echec de l'installation de GRUB: Le paquet grub-efi-amd64-signed n'a pas pu être installé dans /target/"."En l'absence du programme de démarrage GRUB, le système installé ne pourra pas démarrer."

    Flyounet, j'ai aussi testé la dernière version d'ubuntu version 64bits et idem.

    Pour la version Linuxium, je vais la tester maintenant pour voir.

    merci ted pour l'indication mais j'ai installé mon pc en uefi donc je sais à peu près les manips à faire bien que j'aurai pu oublier quelque chose. d'autant qu'en mode legacy il n'y a pas de problème, le pc redémarre sans erreur, il est juste incapable de trouver grub.

    • [^] # Re: schneider SCL141CTP 14"

      Posté par  . Évalué à 3.

      "Echec de l'installation de GRUB: Le paquet grub-efi-amd64-signed n'a pas pu être installé dans /target/"."En l'absence du programme de démarrage GRUB, le système installé ne pourra pas démarrer."

      il faut faire attention juste avant de valider le partitionnement, de bien choisir la partition pour ton grub, dans ton cas /dev/mmcxxxxxxx qui correspond au disque dur de la machine,

      par defaut il est probable que l'installeur essaie /dev/sdXY, et ne trouve que /dev/sda qui est la clef USB d'installation, et donc echoue.

  • # boot repair disk

    Posté par  . Évalué à 1.

    J'ai testé de modifié l'emplacement du boot dans l'installateur en précisant bien la partition nommé emmcblk0p1 correspondant au boot mais ça n'a rien changé, j'ai la même erreur.

    J'ai essayé Linuxium et cette fois-ci cela a fonctionné par contre il y a un bruit étrange, il se produit un claquement par moment ??? comme si on tapait avec son ongle sur le chassis, en conséquence je l'ai désinstallé par sécurité, en plus elle consommait trop de ressource pour ce pc. Mais j'ai quand même pu installer une distribution linux sur ce pc, c'est déjà une bonne chose.

    J'ai testé l'utilitaire boot-repair-disk et en tentant une réparation du grub, il m'indique que le grub est en mode efi alors qu'iil ne devrait pas l'être, c'est étrange, quelqu'un saurait pourquoi ?
    (l'installation a été effectué en mode legacy et uefi désactivé avec une version 64bits)

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.