Forum Linux.débutant deux versions de GTK installées-comment supprimer l'ancienne?

Posté par .
Tags : aucun
0
7
juin
2005
bonjour,

un problème de versions de logiciels
j'ai deux versions de gtk installées sur mon ordinateur. la première, GTK 2.4 a été installée à partir d'un binaire RPM, la deuxième, plus récente (GTK 2.6) a été installée après a partir des sources.
lorsque je souhaite installer gimp, lors du configure, ce dernier me dit que je dois installer la version GTK 2.4.4 au moins. apparemment, il pointe sur l'ancienne version, celle basée sur le RPM...
pourriez vous me dire comment faire pour supprimer l'ancienne version de GTK: 2.4.0 tout en gardant la récente 2.6.0?

merci!!!
  • # Avec rpm

    Posté par (page perso) . Évalué à 2.

    La commande rpm -e nom efface le paquet sélectionné. Là ton problème ressemble un peu à autre chose, gtk 2.6 a du s'installer dans /usr/local, et pkgconfig (le logiciel qui s'occupe des versions) ne prend peut être pas en compte ce dossier.
    Essaye avant de lancer avant configure la commande export PKG_CONFIG_PATH=le dossier où se trouve GTK 2.6
    • [^] # Re: Avec rpm

      Posté par . Évalué à 3.

      La commande rpm -e nom efface le paquet sélectionné.

      Cela ne fonctionnera pas à cause des dépendances. S'il force la suppression du paquet, tous les programmes utilisant GTK ne fonctionneront plus ( ils chercheront la lib dans /usr/lib et non dans /usr/local/lib )
      Personnellement, je réfléchirais à deux fois avant d'upgrader une lib aussi importante.

      Là ton problème ressemble un peu à autre chose, gtk 2.6 a du s'installer dans /usr/local, et pkgconfig (le logiciel qui s'occupe des versions) ne prend peut être pas en compte ce dossier.
      Essaye avant de lancer avant configure la commande export PKG_CONFIG_PATH=le dossier où se trouve GTK 2.6

      C'est ça en effet. En revanche, la commande est incorrecte :
      $ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
  • # Re: deux versions de GTK installées-comment supprimer l'ancienne?

    Posté par . Évalué à 2.

    Tu t'emmerdes pour pas grand chose. Aujourd'hui la plupart des distributions te fournissent une pléiade de logiciels déjà packagés et leurs installations se résument à la saisie d'une seule et unique commande.
    Il est fort probable qu'un logiciel aussi populaire que The Gimp se trouve sur un de tes cédéroms d'installation. As-tu vérifié ?
    Quelle distribution utilises-tu ? Red-hat, Fedora, Mandrake/Mandriva, Suse ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.