Forum Linux.débutant Écran HDMI

Posté par . Licence CC by-sa.
Tags : aucun
1
19
oct.
2018

Besoin d'aide pour un écran HDMI

Bonjour chers lecteurs des forums linux,
J'écris aujourd'hui pour savoir comment connecter un écran HDMI (Un 7 Inch que j'ai récupéré) car mon écran VGA fonctionne mais lorsque je branche le HDMI il me met : "No signal". J'ai un Beelink BT3 PRO mini PC sur ubuntu. Merci d'avance pour votre aide.

  • # hmm

    Posté par . Évalué à 3 (+1/-0).

    tu as donc 2 ecrans, un ecran VGA, et un ecran HDMI

    et bien quand branches l'ecran HDMI, il faut soit redemarrer la machine, soit la forcer à detecter qu'il y a un ecran

    pour forcer la detection, il faut aller dans les reglages systemes -> affichage/ecrans
    tu dois alors pouvoir activer le 2e ecran.

    sinon, il nous faudra connaitre quel linux tu utilises, ca peut aider à savoir si le HDMI est fonctionnel sur cette machine avec CE linux

    • [^] # Re: hmm

      Posté par . Évalué à 1 (+0/-0).

      Bonjour,

      Tu as bien compris, j'ai deux écrans et je veux que le HDMI soit le principal.

      Je tourne sous ubuntu 18.04.1 LTS.

      Dans mes paramètres d'affichages, quand j'ai les deux écran branchés, (le VGA et le 7 inch HDMI Display B) il me marque que l'écran VGA.

      J'en conclu qu'il ne détecte pas le 7 inch.

      • [^] # Re: hmm

        Posté par . Évalué à 3 (+1/-0).

        que renvoie la commande suivante ?

        xrandr  --listmonitors
        • [^] # Re: hmm

          Posté par . Évalué à 1 (+0/-0).

          1 Monitor (mon VGA)

          • [^] # Re: hmm

            Posté par . Évalué à 2 (+0/-0). Dernière modification le 20/10/18 à 13:28.

            et la commande ?

            xrandr --query |grep connect

            ça serait étonnant le périphérique HDM apparaisse, mais autant vérifier. Sur ma machine, je n'arrive vraiment pas à voir dans quel fichier de log je peux tracer la connection/déconnection d'un cable HDMI.

            Il y a quelques mois, j'avais des soucis lié à la détection des display (c'était un peu embêtant parce que c'était l'affichage principale de l'ordi portable qui n'était pas bien géré). J'ai du revenir sur une version antérieure du noyau (genre 4.15) pendant quelques mois et attendre la 4.18 pour que ça retombe en marche.

            Vu que tu dis dans un autre message que ça a marché la semaine dernière. Est-ce que tu as fait une mise à jour du noyau depuis ?

  • # Matériel?

    Posté par (page perso) . Évalué à 1 (+0/-0).

    Est ce que tu est sûr que le matériel fonctionne? Tu as testé l'écran et le câble sur une autre machine, ou sur un lecteur bluray, ou démodulateur TNT, etc.

    As-tu testé l'ordinateur avec un autre écran en HDMI, ou avec un autre câble?

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: Matériel?

      Posté par . Évalué à 1 (+0/-0). Dernière modification le 20/10/18 à 10:53.

      J'ai testé le cable avec ma télé et ça ne fonctionne pas…

      Je vais essayer avec un autre.

      Sinon tu parlais de forcer la detection d'un écran non ?

      • [^] # Re: Matériel?

        Posté par . Évalué à 1 (+0/-0).

        Je me souviens que le double screen avait fonctionné il y à une semaine… mais je n'ai pas fait de réglages.

        J'avais aussi reçu un CD driver avec le 7 inch il me semble…

  • # Réglage de l'écran

    Posté par (page perso) . Évalué à 2 (+0/-0).

    As-tu bien sélectionné la source HDMI sur l'écran ? Est-ce que l'écran marche sur une autre machine ?

  • # Récapitulons

    Posté par (page perso) . Évalué à 6 (+4/-0). Dernière modification le 21/10/18 à 11:30.

    Si je comprend bien, on a en situation initiale :

    • un PC Beelink BT3 PRO sous Ubuntu (la dernière je suppose) ;
    • relié en temps normal à un écran en VGA (que j'appelle écran 1 par la suite) ;
    • et tout cela fonctionne.

    Ensuite, si je comprend toujours bien, un second écran (que j'appelle écran 2 par la suite), relié en HDMI, est ajouté à la configuration existante, et celui-ci ne fonctionne pas. Plusieurs cas de figure sont possibles :

    • problème logiciel ;
    • problème matériel sur l'écran 2 ;
    • problème matériel sur le câble de l'écran 2 ;
    • problème matériel sur le PC.

    Afin de mieux isoler le problème, je propose les tests matériels suivants :

    1. brancher sur le PC uniquement l'écran 2 en HDMI (éteindre d'abord le PC, puis le démarrer avec cet écran afin de forcer sa détection)
    2. comme le test 1, mais utiliser un système live-USB ;
    3. changer le câble HDMI, refaire le test 1 ;
    4. j'ai cru comprendre qu'il y a une télévision (disposant d'un port HDMI), refaire les tests 1, 2 et 3 mais avec la télévision au lieu de l'écran 2 ;
    5. si la télévision le permet, refaire le test 4 mais en VGA ;
    6. si possible, brancher l'écran 2 en VGA sur le PC Beelink BT3 PRO.
    7. si possible, brancher l'écran 2 sur un autre PC HDMI voire VGA si possible ;

    Je propose aussi un petit tour dans le BIOS/UEFI si jamais aucun branchement HDMI sur le PC Beelink BT3 PRO ne fonctionne, peut-être que cet affichage est tout simplement désactivé.

    En me renseignant sur le web à propos de cette machine, il semble que quelques clients se plaignent de la qualité de la machine (température élevée, machine lente, voire même quelqu'un qui a acheté une quantité conséquente a eu des machines HS). Bien qu'il me semble prématuré de tirer de telles conclusions, on peut aussi se demander si la machine est réellement faite pour fonctionner en double écran, du fait de sa puce graphique intégrée d'entrée de gamme.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.