Forum Linux.débutant error while getting interface flags : no such device

Posté par  .
Étiquettes : aucune
0
29
sept.
2005
Bonjour,

Je viens d'installer un second noyau (le 2.4.26) sur ma Debian, mon noyau d'origine est le 2.2.20. Lors de mon installation du nouveau noyau, j'ai recopier le fichier de configuration de l'ancien noyau et je l'ai mis dans celui du nouveau, comme indiqué dans la plupart des tutoriels du net.

Mon problème est que je n'arrive pas à activer ma carte réseau. Je me retrouve avec ce message d'erreur :

error while getting interface flags : no such device

Je pense que cela provient du fait que je n'ai pas le driver de la carte réseau. Ma carte est une Realtek SemiConductor 8029. Je suppose que son driver est le ne2k-pci. Comment faire pour régler ce problème?

Bien évidemment je suis débutant en Linux et ma question peut vous paraître évidente mais elle ne l'est pas pour moi :(

Alors amis du monde libre, merci pour vos réponses:)
  • # oula

    Posté par  . Évalué à 2.

    Essais de mettre "alias ne2k-pci eth0" dans /etc/modules.conf
    • [^] # Re: oula

      Posté par  . Évalué à 1.

      rebonjour,

      merci pour ta réponse, mais en fait j'avais déjà fait cet alias dans le fichier modules.conf mais ça ne marche toujours pas...

      si je fait un lsmod, je me retrouve avec ça:

      Module Size Used by Not tainted

      En gros ya pas de modules! je ne sais pas comment faire. J'ai du faire une erreur lors de ma configuration du noyau et du coup je me demande s'il ne vaut pas mieux que je le recompile du début! A moins que tu n'ai encore d'autres idées?
      • [^] # Re: oula

        Posté par  . Évalué à 2.

        Vi erreur de compile, en même temps reprendre la config d'un 2.2.20 pour un 2.4.26..

        Blaste tout et reprend une machine neuve, pourquoi un noyau 2.4.26 en 2005 ?
        • [^] # Re: oula

          Posté par  . Évalué à 1.

          je reprend un noyau 2.4.26 pour faire des tests par rapport à une distribution Pebble que j'installe sur un boitier Soekris.

          Vi erreur de compile,...

          je ne comprend pas ce que tu veux dire par là, je n'ai pas d'erreur à la compilation. Mon problème réside dans le fait que je n'ai pas le module de la carte réseau et que je ne sais pas comment faire pour l'activer...
          • [^] # Re: oula

            Posté par  . Évalué à 2.

            C'est ce que je sous-entendais : il semble que tu n'as pas compilé le driver ne2k-pci ou une dépendance de celui-ci .. par ailleurs il semble que tu as tout mis en dur dans le noyau (pas de module), mais j'imagine que c'est fait exprès ?!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.