Forum Linux.débutant Problèmes microphone intégré

Posté par  . Licence CC By‑SA.
Étiquettes :
1
26
mar.
2021

Bonjour,

J'ai eu des problèmes de sons (grésillement, volume ne changeant pas) mais j'ai réussi à les contourner !

Maintenant j'en ai un autre : mon microphone intégré n'est pas détecté…

Le microphone interne de mon Asus Zenbook UX430U ne marche pas…
En fait, ma sortie audio est sur mon entrée audio… (voir https://drive.google.com/file/d/1S4Lb7bEStHt9pZI6-UUKew93KeSI4Vp8/view?usp=sharing)
Ma sortie audio : https://drive.google.com/file/d/1u9YHiZFARK7NkDydqmdFqdAnaWbA0d3T/view?usp=sharing

J'ai 2 Ports sur mon entrée "Audio interne Stéréo analogique" :
- Microphone (plugged in)
- Microphone interne (unplugged)

Je pensais que le problème venait de là : Microphone interne (unplugged).
Je me suis donc documenté mais rien à faire…
Voilà ma documentation :
https://ubuntuforums.org/showthread.php?t=2203280
https://askubuntu.com/questions/1218136/internal-microphone-doesnt-work-when-using-headphones

Je suis à 2 doigts désinstaller Ubuntu pour repasser sous Windows…

Merci de votre aide :)

PS: voilà ce que me retourne hdajackretask : https://drive.google.com/file/d/10UmtMf24SfX68kzLQGBz6Qb0bzWWXLhS/view?usp=sharing

  • # interrupteur physique sur le clavier

    Posté par  . Évalué à 3.

    l'ordinateur de ma femme a des boutons spécifiques Fn+F3 ou Fn+F5 pour (des)activer physiquement le micro (ou la webcam)

    peu importe les réglages logiciels, si ce bouton est sur OFF, il n'y a pas de micro (ou de camera) dans le logiciel, ou s'il y a camera, il n'y a pas d'image/de son.

  • # voir avec alsamixer pour commencer

    Posté par  . Évalué à 1.

    Pour voir si ça fonctionne sur une couche plus basse, essaye ceci:

    • désactiver pulseaudio (pulseaudio -k, systemctl stop pulseaudio, selon comment il est lancé).
    • désactiver jack s'il est actif (sans doute source de conflit avec pulseaudio d'ailleurs)
    • regarder les niveaux et les mutes avec alsamixer (F6 pour changer de carte, parfois il y a plusieurs "cartes"). Il se peut que le micro soit en sourdine dans alsa et que pulseaudio ne sache pas le désourdiner.
    • [^] # Re: voir avec alsamixer pour commencer

      Posté par  . Évalué à 1.

      J'ai désactivé pulseaudio en tapant pulseaudio -k et sur Discord, je n'ai que "Default" en périphérique d'entrée et de sortie..

      Je ne sais pas comment désactiver jack (je ne vois pas ce que c'est non plus)

      Dans alsamixer j'ai mis 100 à mon Internal Mic Boost mais rien à faire… le problème n'est pas résolu

      • [^] # Re: voir avec alsamixer pour commencer

        Posté par  . Évalué à 1.

        En fait, quand j'ai vu hdajackretask je me suis dit que ça faisait partie de JACK, qui est pour simplifier un serveur audio prévu pour le travail en faible latence. Mais rien à voir :).

        Si le volume est à fond et que le micro n'est pas en sourdine, comme ça je vois pas, désolé.

  • # Peut-être la correction du problème précédent

    Posté par  . Évalué à 2.

    Est-ce que le micro fonctionnait avant que tu ne corriges les problèmes de son précédents ?
    As-tu testé avec une session live ?

    Sur mon Asus Zenbook UX310UA le son a toujours fonctionné sans problème.

    • [^] # Re: Peut-être la correction du problème précédent

      Posté par  . Évalué à 1.

      Oui mon micro fonctionnait avant que je corrige mon problème de grésillement !

      Pour corriger ce problème, j'ai rajouter la ligne suivante au fichier /etc/modprobe.d/alsa-base.conf : options snd-hda-intel model=asus-zenbook

      J'ai également supprimé le fichier ~/.config/pulse quand j'ai eu mon problème pour régler mon volume une fois que j'ai résolu mes problèmes de grésillement.

      En y repensant, c'est peut-être ce fichier qui fait que mon microphone interne n'est pas détecté…

      • [^] # Re: Peut-être la correction du problème précédent

        Posté par  . Évalué à 2.

        Il peut être intéressant d'installer et utiliser l'outil pavucontrol qui offre plus de flexibilité que par exemple les réglages audio de gnome/kde. Dans le dernier onglet "configuration" tu peux changer les profiles pour chaque interface audio. Il est possible que tu n'utilises pas un profile multiplex qui autorise l'entrée micro standard quand un appareil est branché sur la prise jack.

  • # des pistes

    Posté par  . Évalué à 2.

    un utilisateur de Mint (qui est un dérivé ubuntu) a eu le meme probleme que toi,
    apparemment un probleme avec la version du noyau.

    en mettant à jour son noyau (mais peut-être chez toi directement la distribution) cela s'est résolu.

    https://forums.linuxmint.com/viewtopic.php?f=49&t=315515&sid=78982f5560097bf02b7e97460fdb8279&start=20

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.