Forum Linux.débutant [RESOLU] Fichiers copiés deviennent nobody nogroup

Posté par  . Licence CC By‑SA.
Étiquettes :
1
27
jan.
2019

Bonjour,

Disposant de 2 ordinateurs, je suis amenée à copier des fichiers de l'un vers l'autre.
Un est sous Mint 18.3 et l'autre Mint 19.1
Ils sont reliés à la box en wifi et l'un à l'autre en filaire.
J'utilise le partage réseau via samba, mais je rencontre plusieurs problèmes :

Après leur copie, les fichiers perdent leur propriétaire.
Je dois les reprendre à chaque fois avec chown.
Je suis allée voir dans /etc/samba/smb.conf mais mon anglais is bad et je suis bien incapable de savoir quoi y ajouter ou modifier.

Ensuite pour le second pc, si avec nemo je vais sur Réseau/Réseau Windows/ c'est vide, je dois entrer dans la barre d'adresse smb://lea-monPremierPC pour y accéder.
Tandis qu'avec le premier j'arrive sur WORKGROUP avec le nom des 2 pc et je peux accéder à n'importe lequel, ce qui est plus pratique.

Et puis pour finir, le second pc (celui qui rencontre tous les problèmes en fin de compte) apparaît en double dans la partie gauche de l'explorateur de fichier, une fois sous le nom "leamonsecondpc sur lea-monsecondpc" et juste en dessous le même nom mais avec .local à la fin.
Je peux les démonter indépendamment.

Quand j'effectue des copies en utilisant .local, c'est beaucoup plus lent.
J'imagine que dans ce cas au lieu de passer par la connexion filaire, la liaison passe par le wifi ?
Dans ce cas, pourquoi sur le premier pc n'y a-t-il que leamonpremierpc et pas le doublon .local ?

Merci d'avance pour vos lumières :)

  • # des pistes

    Posté par  . Évalué à 3.

    • dans ton voisinnage reseau, tu vois donc 2 fois la meme machine car elle s'annonce avec un nom avec samba, avec un autre avec mDns

    • le nom de machine en .local c'est parce que la machine est configurée avec mDNS/zeroconf, elle prend donc un nom DNS du style tamachine .local

    si l'autre n'a pas zeronconf/avahi/mDns, elle ne se cree pas un nom de ce style.

    si tu ne vois pas le meme " voisinnage" dans les deux navigateurs de fichiers de tes machines,
    c'est que le groupe SAMBA n'est pas le meme (WORKGROUP par defaut)

    et pour tes droits,
    c'est en effet dans la config de samba que tu as du faire un partage ou les droits sont ecrasés et remplacés par nobody/nogroup (compte invité "guest" dans la config)

    si tu ne veux pas cela tu peux :
    - utilisé un compte de la machine destination lors du transfert vers cette machine
    --> plusieurs utilisateurs peuvent avoir des comptes differents et des acces à des dossiers differents => differents propriétaires
    - configurer samba pour écraser le propritétaire vers un utilisateur particulier (si tu as le meme utilisateur sur les 2 machines, et que tu es la seule personne à gérer les machines.

    comme pour les propritétaires, tu peux aussi forcer les droits d'un dossier/fichier avec la gestion des DIR MASK et FILE MASK
    les fichiers restent alors à nobody/nogroup mais peuvent etre directement 775 voir 777 donc lisiblent par tous, effacables par tous

    • [^] # Re: des pistes

      Posté par  . Évalué à 2.

      Merci NeoX

      Pourquoi s'est-elle configurée avec mDNS/zeroconf et pas l'autre ?

      Pour mon partage, j'ai procédé de la même façon pour les 2 pc :
      Dans Connexions réseau, j'ai crée une connexion de type Ethernet, dans les paramètres IPv4 j'ai utilisé la méthode manuelle, et j'ai partagé les 2 home.
      Puis j'ai cliqué dans la fenêtre qui s'est ouverte pour que Nemo ajoute les permissions automatiquement, c'est tout.

      Je ne vois pas trop où j'ai pu écraser les droits dans ce partage tout simple, et je serais bien incapable d'être allée modifier le fichier de configuration.

      si tu ne veux pas cela tu peux :
      - utilisé un compte de la machine destination lors du transfert vers cette machine
      --> plusieurs utilisateurs peuvent avoir des comptes differents et des acces à des dossiers differents => differents propriétaires

      Je ne comprends pas très bien ce que ça veut dire…

      • configurer samba pour écraser le propritétaire vers un utilisateur particulier (si tu as le meme utilisateur sur les 2 machines, et que tu es la seule personne à gérer les machines.

      J'ai le même nom d'utilisateur sur les 2 pc (pas le même mot de passe) et suis la seule à gérer les machines, cette solution me conviendrait.
      Si tu pouvais me dire comment on fait stp :)

      Quant à ton dernier conseil, si je comprends bien car je n'ai jamais utiliser DIR MASK et FILE MASK, mes dossiers partagés, c'est-à-dire mes 2 homes, auraient les droits maximum pour tout le monde ?
      Niveau sécurité ça ira ?

      • [^] # Re: des pistes

        Posté par  . Évalué à 2. Dernière modification le 28/01/19 à 10:15.

        Pourquoi s'est-elle configurée avec mDNS/zeroconf et pas l'autre ?

        parce que tu as 2 versions differentes de mint (18 et 19)
        que l'une vient peut-etre avec avahi/mdns/dnsmasq preinstallé et pas l'autre

        ou que sur la plus ancienne tu as supprimé un truc, mais y a tellement longtemps que tu ne t'en souviens plus

        Pour mon partage, j'ai procédé de la même façon pour les 2 pc :
        Dans Connexions réseau, j'ai crée une connexion de type Ethernet, dans les paramètres IPv4 j'ai utilisé la méthode manuelle, et j'ai partagé les 2 home.
        Puis j'ai cliqué dans la fenêtre qui s'est ouverte pour que Nemo ajoute les permissions automatiquement, c'est tout.

        c'est le probleme de faire les trucs en mode graphique,
        ca va mettre des options à droite, à gauche, mais on ne sait pas lesquelles.

        tu peux ouvrir le fichier /etc/smb.conf ou /etc/samba/smb.conf sur chaque machine pour savoir ce qu'il y a de differents.

        Il n'est peut-etre pas prevu de partager le home dans l'usage habituel mais plutot un dossier "partage" dans le home de l'utilisateur par exemple.

        Je ne vois pas trop où j'ai pu écraser les droits dans ce partage tout simple, et je serais bien incapable d'être allée modifier le fichier de configuration.

        si tu ne veux pas cela tu peux :
        - utilisé un compte de la machine destination lors du transfert vers cette machine
        --> plusieurs utilisateurs peuvent avoir des comptes differents et des acces à des dossiers differents => differents propriétaires

        Je ne comprends pas très bien ce que ça veut dire…

        quand tu configures le partage, tu dois pouvoir lui dire si c'est ouvert à tous, ou limité aux utilisateurs avec un login/pass.

        puis depuis le poste client, quand tu viens sur le partage, il te demande le login/pass, et selon ce login, il va autoriser ou non la personne à se connecter et à lire/ecrire dans le dossier partagé

        c'est utile quand on est plusieurs à la maison, qu'on veut partager des trucs sans que l'autre efface le document, la video, ou quand on ne veut pas que les gamins accedent aux feuilles de comptes et details bancaires des parents, etc

        configurer samba pour écraser le propritétaire vers un utilisateur particulier (si tu as le meme utilisateur sur les 2 machines, et que tu es la seule personne à gérer les machines.
        J'ai le même nom d'utilisateur sur les 2 pc (pas le même mot de passe) et suis la seule à gérer les machines, cette solution me conviendrait.
        Si tu pouvais me dire comment on fait stp :)

        au meme endroit que tu actives la connexion avec login/pass, tu dois avoir au moins 2 voire 3 niveaux
        - guest (invité) avec map des droits vers nobody/nogroup (peut-etre modifiable en droits X/Y)
        - avec avec login/pass avec map des droits sur X/Y
        - acces avec login/pass avec map des droits sur le login

        Quant à ton dernier conseil, si je comprends bien car je n'ai jamais utiliser DIR MASK et FILE MASK, mes dossiers partagés, c'est-à-dire mes 2 homes, auraient les droits maximum pour tout le monde ?
        Niveau sécurité ça ira ?

        niveau secu c'est moche de faire un 777 sur un dossier/fichier
        mais si tu es seul.e chez toi, c'est moins grave ton partage n'etant accessible que depuis tes machines.

        • [^] # Re: des pistes

          Posté par  . Évalué à 1.

          parce que tu as 2 versions differentes de mint (18 et 19)

          Mais oui, ça ne m'avait même pas traversé l'esprit !
          Par contre, je n'ai rien supprimé sur la plus ancienne et que j'aurais oublié, pour la bonne raison que je ne suis pas très douée et que je ne modifie quasiment jamais rien :)

          tu peux ouvrir le fichier /etc/smb.conf ou /etc/samba/smb.conf sur chaque machine pour savoir ce qu'il y a de differents.

          Bonne idée ;)

          quand tu configures le partage, tu dois pouvoir lui dire si c'est ouvert à tous, ou limité aux utilisateurs avec un login/pass.

          Comme toujours, j'ai fait au plus simple, je me connecte en Anonyme, sans mot de passe.
          D'après la suite de tes explications, je suis donc en guest avec map(?) des droits vers nobody-nogroup.
          Tu dis peut-être modifiable en droits X/Y mais je ne sais pas comment.
          X/Y c'est les fichiers et les répertoires ?
          Je vais déjà essayer avec un mot de passe voir ce que ça donne.

          En Anonyme, l'endroit où j'active la connexion se présente comme ça :

          Image

          mais si tu es seul.e chez toi, c'est moins grave ton partage n'etant accessible que depuis tes machines.

          On est plusieurs mais je fais confiance, je pensais plutôt un accès extérieur, mais si le partage n'est accessible que depuis mes machines, pas de soucis.

          Je te remercie de m'avoir répondu point par point, ça me fait progresser bien plus sûrement que quand je me plonge dans de la doc sur Linux qui est tellement touffue que je m'y noie, ou le man en anglais que je dois copier/coller dans un traducteur…

          • [^] # Re: des pistes

            Posté par  . Évalué à 2.

            alors essaye deja de te connecter avec ton compte de la machine "distante" plutot qu'en anonyme/guest/invité

            tu devrais alors avoir les droits de cet utilisateur
            et donc acces normalement à ses dossiers

            • [^] # Re: des pistes

              Posté par  . Évalué à 2. Dernière modification le 28/01/19 à 14:42.

              C'est tout bon, de cette façon j'ai les droits et je suis bien propriétaire des fichiers copiés :)

              Encore merci de m'avoir trouvé la solution, je passe le sujet en résolu ;)

              • [^] # Re: des pistes

                Posté par  . Évalué à 2. Dernière modification le 28/01/19 à 18:11.

                tres bonne nouvelle que cette derniere

                et si tu veux etre plus "propre" il faut desactiver l'acces "invité"
                pour eviter qu'il se ballade dans les dossiers de tout le monde.

                ainsi seul un utilisateur qui a un compte pourra acceder aux partages, voire à son partage uniquement.

                • [^] # Re: des pistes

                  Posté par  . Évalué à 1.

                  Ok, je viens de décocher les cases "Permettre à d'autres de créer et supprimer des fichiers dans ce dossier" et "Accès d'évaluation (pour les personnes sans compte utilisateur)" dans la fenêtre "Partage de dossier".
                  Merci du conseil ;)

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.