Forum Linux.embarqué Problème utilisation Qemu

Posté par .
Tags : aucun
0
26
mar.
2007
Bonjour,

Je viens d'installer Qemu, afin de pouvoir simuler des programmes compilé pour fonctionner sur un processeur PowerPC. Mais lorsque je lance qemu-ppc, il me dit qu'il ne trouve pas la bibliothèque libm.so.6. Pourtant, après vérification, j'ai bien cette bibliothèque dans le répertoire /lib.

Je vous remercie d'avance pour votre aide.
  • # Problème utilisation Qemu

    Posté par . Évalué à 1.

    Copie ici le message complet que te donne qemu, ainsi que le nom exacte (avec son chemin) de la bibliothèque libm que tu as trouvé. On pourra t'aider un peu plus facilement.
    • [^] # Re: Problème utilisation Qemu

      Posté par . Évalué à 1.

      Excuse moi, je n'y ai pas pensé,

      En fait j'ai deux cas qui se présentent, avec la commande "qemu-ppc -L / /bin/ls"
      - Sans rien modifier dans l'arborescence des fichiers, j'obtiens le message d'erreur
      "qemu-ppc: error while loading shared libraries: libm.so.6: cannot open shared object file: No such file or directory"
      - Si je place la librairie libm.so.6 ,que j'ai dans le repertoire de la toolchain, dans /usr/lib/, j'obtiens le message suivant
      "qemu-ppc: error while loading shared libraries: /usr/lib/libm.so.6: ELF file data encoding not little-endian"

      Je suppose qu'il veut la bibliothèque qui concerne le simulateur que je désire faire fonctionner, mais apparement elle ne sont pas dans le bon format (big endian au lieu de little endian). Donc je ne vois pas quoi faire, soit essayer de convertir la bibliothèque, soit essayer d'indiquer au simulateur que c'est du big endian. Mais lorsque je demande l'aide, il me renvoie le même message d'erreur.

      Merci de votre aide.
  • # [résolu]

    Posté par . Évalué à 1.

    En fait j'ai résolu mon problème.

    Le problème venait apparement du package fournit par ma distribution (mandriva 2007.0). En utilisant la version binaire sur le site officiel, Qemu fonctionne correctement.

    Donc je conseille d'éviter le package fournit par Mandriva 2007.0. Et je déconseille ausi d'utiliser la version source à compiler, car il y a un message d'erreur indiquant que SDL n'est pas installé, alors qu'il y est (sur ma distrib).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.