Forum Linux.embarqué exécuter un script bash local sur une machine distante via le ssh

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
11
nov.
2021

Hello à toutes et à tous.

Depuis quelques jours, j'essaie via le ssh d'exécuter sur une machine distante,
un script bash que j'ai en local.

Si je me connecte en SSH sur la machine distante,
et que j'exécute la commande directement, ça fonctionne.

Cependant, lorsque j'essaie à partir de mon script local j'ai cette erreur :

execl(); errno 2
Couldn't save environment -1#

Voici la commande que j'aimerais exécuter :

/opt/lantiq/bin/sfp_i2c -i11 -s XXXXXXXXXX

Voici les (…)

Forum Linux.embarqué Phylink et sfp

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
15
oct.
2021

Bonjour à toutes et à tous.

Pour un projet, j'utilise la sbc clearfog base ainsi que deux modules sfp gpon ONU ( Ubiquiti uf instant et l'autre de marque fs).

Ces deux modules ont des accès telnet et/ou ssh, dont j'ai besoin d'exploiter via ma clearfog.

L'os utilisé est basé sur Linux et les interfaces sont gérés par le fichier /etc/network/interfaces.

Ma clearfog possède trois interfaces ethernet : 0 et 1 pour les RJ45 et le 2 pour la cage (…)

Forum Linux.embarqué [HDD] : Passage de l'OS Raspian vers Raspi Debian

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
28
sept.
2021

Bonjour,

J'ai installé le projet Raspi Debian pour ma rpi 4 model B (2018) 2Go de RAM.

https://raspi.debian.net/tested-images/

Le boot USB au démarrage est activé pour booter directement sur mon HDD Toshiba 2To.

Le HDD est relié en USB à la rpi via un connecteur qui prend Alim+Sata du HDD. (log dmesg en dessous).

scsi 0:0:0:0: Direct-Access  ASMT  2115   0  PQ: 0 ANSI: 6 

J'ai une alimentation externe qui vient alimenter le HDD.

Problème : le HDD grate souvent, donc (…)

Forum Linux.embarqué Comment faire du CI/CD et automatiser les tests sur de l'embarqué ?

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
18
juil.
2021

Hello.

Depuis un moment déjà, je m' "amuse" à programmer la micro:bit en bare-metal et en assembleur. Je ne tiens pas à développer un truc hyper complet mais juste à comprendre d'un peu plus près les processeurs ARM et leur mode de fonctionnement. Je dois dire que de ce côté c'est assez réussi : l'architecture ARM Cortex M0 qui est utilisée sur le SOC de cette carte est suffisamment simple pour appréhender le monde ARM (jeu d'instruction restreint THUMB, pas (…)

Forum Linux.embarqué Firefly station P2: la carte ARM qui ne sera pas

Posté par  . Licence CC By‑SA.
Étiquettes :
1
9
juil.
2021

Je poste l'information sur le forum car ce n'est pas digne d'un journal.

Il y a eu en début d'année une campagne de financement participatif pour une carte ARM à base du SoC RockChip RK3568: https://www.indiegogo.com/projects/station-p2-powerful-open-source-geek-computer#/
Ce SoC a moins de coeurs que le RK3399 mais plus de connectique: le projet prévoyait deux ports ethernet gigabit, deux antennes wifi, un port sata et un port pcie m2. Je trouve ça idéal car ça fusionnerait une box, un nas et un (…)

Forum Linux.embarqué Détection de branchement USB avec Udev qui ne fonctionne pas

Posté par  . Licence CC By‑SA.
1
19
avr.
2021

Bonjour à tous,

J'ai parcouru de nombreuses pages webs afin de trouver une solution à mon problème, en vain.

Je cherche à lancer un script que j'ai fait quand je branche un périphérique audio USB sur ma cible (embarquée, imx6, etc.). In fine j'aimerais lancer mon script lorsque n'importe quel périphérique usb de type audio (qui utilise snd-usb-audio comme driver) est branché.
Cependant, mon script n'est jamais lancé.
J'ai essayé de remonter le problème sous différents angles : détection par (…)

Forum Linux.embarqué problème avec dma_map_single

Posté par  . Licence CC By‑SA.
Étiquettes :
0
5
avr.
2021

Bonjour,
Je travaille sur un imx7d de NxP. Je travaille sur 2 cartes l'eval board de Nxp (la carte sabre) et une board personnelle. J'ai développé un driver memcpy qui utilise le sdma de l'imx7d. Le but étant de copier les données reçu du pci express dans une mémoire vers une autre mémoire. ​
Ce driver fonctionne de la façon suivante l'utilisateur alloue de la mémoire via un ioctl cette mémoire étant la zone de réception. Puis quand il souhaite (…)

Forum Linux.embarqué [WEBCAM] Asus Transformer Book T100HAN

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
7
fév.
2021

Bonsoir à tous,

J'ai fait l'achat d'un Asus Tablette PC.

J'ai enlevé Windows 10 pour y mettre debian buster.

Toutes les fonctionnalités sont validés sauf la vidéo avant et celui de selfie.

Je suis retourné sous windows et j'ai pris les infos suivantes.

    Intel AVStream Camera - Intel ISP Camera Device
    VIDEO\VEN_8086&DEV_22B0&SUBSYS_1BDD1043&REV_20&INT22B8

    Camera sensor ov5670
    ov5670 - OmniVision OV5670 sensor 
    https://linuxtv.org/downloads/v4l-dvb-apis/admin-guide/i2c-cardlist.html
    ACPI\VEN_OVTI&DEV_5670&SUBSYS_1BDD1043
    ACPI\OVTI5670

    Camera sensor unicam hm2051
    ACPI\VEN_HIMX&DEV_2051&SUBSYS_1BDD1043
    ACPI\HIMX2051

Deux liens utiles pour ce type d'appareil ASUS.

Ce post concerne (…)

Forum Linux.embarqué probleme module sfp et i2c pxa

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
31
jan.
2021

Hello.
Pour un projet, j'essaie d'intégrer un module sfp à ma carte.

si j'ai bien compris , le module sfp utilise l'i2c pour communiquer avec la carte.

voici les erreurs rencontrées quand je fais un ethtool -m

    # ethtool -m eth1
    [   49.140673] i2c i2c-0: i2c_pxa_set_slave: wait timedout
    [   50.100702] i2c i2c-0: i2c_pxa: timeout waiting for bus free
    [   51.060606] i2c i2c-0: i2c_pxa: timeout waiting for bus free
    [   52.020664] i2c i2c-0:
(…)

Forum Linux.embarqué Problème wifi et reboot

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
18
jan.
2021

Hello.
Tout d'abord bonne année à toutes et à tous.
J'ai un petit soucis avec ma petite carte embarquée.
J'ai une carte wifi en pcie.
Elle fonctionne très bien.

Cependant, j'ai remarqué que si je fais un reboot via une commande en ligne, la carte wifi ne remonte pas.

Par contre, si je débranche et rebranche la carte électriquement, la carte remonte.

Ça fait une semaine que je cherche et j'en deviens fou ^

Merci d'avance pour votre aide.

Forum Linux.embarqué Quel environnement pour compiler du Yocto en CI ?

Posté par  . Licence CC By‑SA.
Étiquettes :
3
31
août
2020

Bonjour,

Yocto c'est bien, c'est très bien. Mais pour pas être emmerdé, il faut une distribution assez précise parmi celles qui sont supportées officiellement, par exemple Ubuntu 18.04 LTS.

Je voudrais monter une CI (Sous Jenkins vraisemblablement) qui entre autre compilera l'image Yocto. Pour être indépendant de la CI elle-même, je me doute que un système dédié à la compilation Yocto est plus simple à maintenir. De plus ça peut servir en développement système d'avoir sa propre image de compilation.

(…)

Forum Linux.embarqué Diaspora* pour Raspberry PI

Posté par  . Licence CC By‑SA.
Étiquettes :
1
15
déc.
2019

Bonjour à tous,

Pour aider le développement du fédiverse et la dégooglisation, j'ai monté une image docker de Diaspora*.
Pour vous monter un pod sur une PI, suivez le guide. La partie SSL est gérée par "Let's Encrypt" automagiquement.
Soyons clair, le 1er démarrage de Diaspora* prends plus de 10mn. Mais les suivants, moins d'une minute. Une fois monté en charge (donnez encore quelques minutes au pod) le pod pourras facilement porter 10-50 utilisateurs.

PS: j'ai aussi une image (…)

Forum Linux.embarqué [Smartphone] : SailFishOS marque Jolla

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
29
juil.
2019

Bonjour à tous,

J'ai eu vent d'une nouvelle marque Jolla pour téléphone portable il y a maintenant 3 ans.

Après de nouvelles recherches, je vois qu'il est possible d'adapter l'OS SailFish à son smartphone.

Est-ce que quelqu'un s'y connait quelque peu en la matière ?

J'ai suivi le tuto suivant : https://sailfishos.org/content/uploads/2018/12/SailfishOS-HardwareAdaptationDevelopmentKit-3.0.0.0.pdf

Forum Linux.embarqué Problème encodage et ls

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
1
29
juil.
2019

Bonjour,

J'ai un léger problème avec mon mini-NAS. J'essaye d'en créer un à partir d'un Odroid-HC1.
Ça marche très bien.

Bon par-contre, j'ai un problème assez perturbant lié à ls et à ranger (mon gestionnaire de fichiers).
La commande ls m'affiche bizarrement tous les caractères unicode.
Le reste du système gère correctement l'ensemble des caractères. echo Éh ! fonctionne correctement.

Le pire dans cette histoire, c'est que même les émojis fonctionnent.
Par exemple, j'ai un fichier sur le disque interne (…)

Forum Linux.embarqué priorité kernel thread vs user thread

Posté par  . Licence CC By‑SA.
Étiquettes :
0
23
juil.
2019

Bonjour,
Première question Quand on créé un kernel thread avec kthread_create est il par défaut en mode SCHED_OTHER.
Deuxième question un kernel thread créer par kthread_create est il toujours plus prioritaire qu'un user thread créé par pthread_creat quelque soit le mode de chacun des threads (SCHED_OTHER,SCHED_RR,SCHED_FIFO,..)?

Troisième question si kernel thread a une priorité 10 en mode SCHED_FIFO et un user Thread a une priorité 20 en mode SCHED_FIFO est ce que le thread user est plus prioritaire que le (…)

Forum Linux.embarqué Cloner pass Vigik ?

Posté par  . Licence CC By‑SA.
Étiquettes :
4
1
mai
2019

Bonjour,

En total néophyte, j'aimerais savoir s'il est possible de cloner mon pass Vigik pour moins cher que les ~50€ que demande le syndic.

L'immeuble nécessite un pass Vigik pour passer les deux portes d'entrée au rez-de-chaussée. Le pass est donc commun à tous les habitants.

A priori, il suffit donc d'avoir un appareil + logiciel pour lire les données de mon pass et les copier sur une clé vierge.

Pour information, je possède un second pass physiquement identique mais (…)

Forum Linux.embarqué Quelques problèmes avec systemd...

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
12
avr.
2019

Bonsoir à tous, je suis débutant dans le monde de Linux, et j'ai quelques petits soucis avec systemd et ma RaspberryPi 3 (Raspbian). Je vous explique :

Je voudrais lancer un programme (lin_guider) au démarrage de ma Raspberry avec un service dans systemd mais le service (que j'ai appelé DEMARRAGE) plante quand il est lancé. En effet, j'obtiens ce message d'erreur sur l'écran de la Pi :
job DEMARRAGE.service/start deleted to break ordering cycle starting with multi-user.target/start
Je cherche depuis (…)

Forum Linux.embarqué ESP32 / problème de flash et reboot

Posté par  . Licence CC By‑SA.
Étiquettes :
0
5
avr.
2019

bonjour,

j'ai placé ce message sur Linux/embarqué, mais c'est pas tout à fait adapté, mais il s'agit bien d'environnement embarqué, mais sans Linux, sur PF ESP32-wroom.

j'ai eu un soucis avec l'un des petits modules. A la console (Arduino, 115.200 bauds), j'ai ce message qui apparaît cycliquement. Je n'ai plus accès à la fonction de programmation via l'IDE.

rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:928
ho 0 tail 12 room 4
load:0x40078000,len:9280
load:0x40080400,len:5848
csum err:0xca!=0x2e
(…)

Forum Linux.embarqué Type de Raspberry Pi "non lisible" ?

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
3
27
mar.
2019

Bonjour à tous,

J'ai bricolé pour un fablab un truc tout bête sur un Raspberry Pi qui affiche des infos sur un écran. Rien de secret, rien de compliqué.

Il y a des personnes qui l'ont volé, qui l'ont dupliqué, et mis en route dans d'autres espaces en prétendant que c'est eux qui en sont à l'origine, et ensuite ont posé problème en nous accusant de copie lorsque j'en ai remis un en route.

Je voudrais utiliser un truc comme (…)

Forum Linux.embarqué installation linux sur interface pro-face PFXGP4401

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
18
fév.
2019

bonjour

Ayant hérité d'une interface pro-face, j'aurai souhaité installer une distribution linux sur cet équipement qui comporte
1 port usb, 2 ports com, 1 support de carte sd, 1 port usb2, 1 port ethernet.
Peut-être que ce n'est pas possible, peut-être que ça l'est.
Je pensai installer puppy linux sur la carte sd et booter sur cette carte.
Après divers essais infructueux je fais appel à l'aide.

merci

Pro-face GP4401-T
model PFXGP4401TAD FID1102

Forum Linux.embarqué [Raspberry pi 3] Accéder à une clé USB via un code python

Posté par  . Licence CC By‑SA.
Étiquettes :
1
21
déc.
2018

Bonjour à tous,
je développe actuellement un application embarqué sur Raspberry pi (Raspbian Jessie)en python.

En gros ma pi doit écrire des valeurs sur un fichier excel dans une clé usb nommé "DATA"

Problème
mon app doit être un minimum robuste : c'est à dire pouvoir être utilisé avec n'importe quelle clé usb nommée "DATA" et résister à un mauvais démontage.

Actuellement, j'ai écris le chemin de montage en dur sur mon code (du genre : )

try os.mkdir('/media/pi/DATA3/NouveauDossier')
Pourquoi (…)

Forum Linux.embarqué Réutilisation d'un DVR

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
16
juil.
2018

Bonjour à tous, je me permets de venir ici afin de vous poser une question à laquelle je n'ai trouvé aucune réponse et/ou explication. Je suis tout nouveau dans le monde Linux… Je possède plusieurs DVR/NVR de marques Dahua et HIKVision et j'aimerais savoir s'il était possible de les réutiliser afin de réinstaller un OS linux et pourvoir l'utiliser dans d'autres but que l'enregistrement de caméras?
D'avance je vous remercie de vos réponses et explications.

Cordialement

Forum Linux.embarqué probleme disque dur issu d'un systeme de videosurveillance embarqué

Posté par  . Licence CC By‑SA.
0
30
juin
2018

Bonjour ! Après une recherche sur le forum (j'y ai pas passé 2 heures non plus) je n'ai pas trouvé d'information pour mon souci.

Je m'explique :

Un client a installé de la vidéo surveillance dans son établissement. Suivant la doc. le système semble être
Linux Embarqué et le stockage un HDD 3To.

Le problème donc :

J'ai tenté de récupérer les données effacées car la période enregistrée couvre uniquement 10 jours ( il lui en faudrait 30)

Après exploration (…)

Forum Linux.embarqué Problème de transfert tftp par port série sur un routeur tp-link Archer C7 v4 briqué (resolu)

Posté par  . Licence CC By‑SA.
0
21
juin
2018

Bonjour
La situation:
Mon routeur tp-link archerC7-v4 openwrt/lede est (glorieusement) briqué par mes soins à la suite d'un flashage pour revenir au firmware d'usine.
Symptôme: aucune led s'allume, sauf celle du power qui s'éteint après 3 secondes.
J'ai essayé tous les reset possibles et imaginables glanés sur le net genre https://wiki.dd-wrt.com/wiki/index.php/Hard_reset_or_30/30/30
rien à faire. Il existe un espoir puisque le chargeur de boot ne semble pas mort.
Après identification des contacts, j'ai soudé sur le routeur 3 picots, tx rx (…)