Forum Linux.général Agencement clavier et Gnome3 / Gnome-shell

Posté par .
Tags :
0
4
déc.
2012

Bonjour à tous !

Je suis à la recherche d'un moyen rapide et simple pour modifier l'agencement du clavier sous Gnome3 (3.6), je n'ai pas trouvé d'extension qui permette de faire ça :/.

Je me met au BÉPO et comme je ne maîtrise absolument pas, j'ai toujours besoin de remettre en Azerty quand je dois taper rapidement. En ce moment le mieux serait que Klavaro soit automatiquement configuré en BÉPO et les autres logiciels en Azerty.
Dans les paramètres d'agencement il est possible d'autoriser des "agencements séparés pour certaines fenêtres" : est-ce que c'est l'application qui doit spécifier l'agencement, ou est-ce qu'il est possible de le spécifier manuellement ?

Avant il y avait une bête icône dans la bar du haut, maintenant… Je viens aussi de constater qu'on ne pouvait pas changer l'agencement au moment du login, ce qui peut poser problème aussi. J'aime bien gnome-shell mais faut avouer que certains changements sont surprenant. (HS : j'ai mis du temps à trouver qu'il fallait appuyer sur ECHAP pour pouvoir déverrouiller la session sans la souris sous 3.6)

Et avant que je me lance vraiment dans cet apprentissage, vous utilisez plutôt l'agencement BÉPO ou DVORAK-FR, mes recherches me disaient que c'était BÉPO qui était le plus ergonomique.

Voilà, si quelqu'un avait connaissance d'une solution pour mon "problème" il sera la bienvenue !! :)

Merci.

Calvin01.

  • # bépo

    Posté par (page perso) . Évalué à 3.

    Gros problème que j'ai souvent aussi (en fait c'est juste quand je prête mon clavier je dois faire un setxkbmap -layout fr mais il traîne toujours dans mon historique donc ça va vite)

    option 1 : un script qui fait ça : "setxkbmap -layout fr -variant bepo" ou sans la variant.

    option 2 : utiliser un raccourci clavier j'avais mis double shift dans gnome 2 à une époque, je sais pas si c'est encore possible pour gnome 3

  • # chezmoiçamarche

    Posté par (page perso) . Évalué à 3.

    gnome 3.6 sous archlinux:
    2 layout de clavier et une petite icône de clavier en haut à droite pour passer de l'un a l'autre (je crois que j'ai simplement ajouté un layout de clavier depuis gnome (y a plus clavier alors ça doit être dans localisation)

    sinon pour le choix du layout, j'ai pris bépo qui est plus polyvalent français/coding que dvorak-fr qui se prete plus au français pur

    malheureusement je suis au boulot donc je peu pas être plus précis

    enfin pour terminer par le concours de celui qui à la plus grosse: la mienne est toute petite: 16 MPM en bépo.

    • [^] # Re: chezmoiçamarche

      Posté par . Évalué à 1.

      Sur le lien de liberforce j'ai pu voir de quoi tu parlais. Je viens de repasser à Ubuntu avec Ubuntu Gnome..[…], et le problème vient de là, parce que j'ai toujours "clavier", et pas "langues et localisation".

      Sous LMDE ça marche tout pareil.

    • [^] # Re: chezmoiçamarche-Partiellement

      Posté par (page perso) . Évalué à 1.

      Je suis dans une démarche similaire.
      Globalement ça marche avec les deux bémols suivants :
      Lors de la connexion, c’est toujours la disposition AZERTY qui est prise en compte. Une fois le profile utilisateur chargé, c’est bon, mais avant, rien à faire c’est de l’AZERTY
      J’ai voulu mettre un raccourci pour le basculement entre les deux dispositions. MAJ+MAJ, mais ça ne marche pas. Comme je ne change pas souvent, je continue de cliquer sur l’icône

  • # Après 2 minutes sur un moteur de recherches...

    Posté par (page perso) . Évalué à 3.

    • [^] # Re: Après 2 minutes sur un moteur de recherches...

      Posté par . Évalué à 2.

      Ah ben c'est exactement ce que j'ai fait suite à mes recherches mais je n'étais pas tombé sur un screenshot, autrement j'aurais vu qu'une icône était censé apparaître.

      Je viens de passer à Ubuntu Gnome et ça vient de là le problème apparemment. J'ai testé sous LMDE (Linux Mint Debian Edition) et ça fonctionne.

      Merci

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.