Forum Linux.général Boot pxe qui ne fonctione pas

Posté par . Licence CC by-sa.
0
18
jan.
2016

Bonjour à tous,
Afin de réaliser des install de postes linux entièrement automatisé j'ai installé un serveur Debian que j'ai configuré en TFTP + PXE et j'ai configuré mon DHCP sous windows car tous mes vlan DHCP sont gérés avec windows.

Mon DHCP semble bien fonctionner puisque j'obtiens une adresse IP (voir screenshot ci dessous).
Cependant aucun poste ne boot sur pxe et je n'arrive pas à comprendre pourquoi.

voici ma config:

sur le serveur debian:

root@WBX-LINUX-DEPLOY:~# /etc/init.d/tftpd-hpa status
tftpd-hpa.service - LSB: HPA's tftp server
   Loaded: loaded (/etc/init.d/tftpd-hpa)
   Active: active (running) since lun. 2016-01-18 14:14:15 CET; 53min ago
   CGroup: /system.slice/tftpd-hpa.service
           └─489 /usr/sbin/in.tftpd --listen --user tftp --address 10.33.36.1:69 --secure /srv/tftp

janv. 18 14:14:15 WBX-LINUX-DEPLOY tftpd-hpa[472]: Starting HPA's tftpd: in.tftpd.
janv. 18 14:33:26 WBX-LINUX-DEPLOY in.tftpd[1498]: tftp: client does not accept options
#----------- /etc/default/tftpd-hpa -------------------
    TFTP_USERNAME="tftp"
    TFTP_DIRECTORY="/srv/tftp"
    TFTP_ADDRESS="10.33.36.1:69"
    TFTP_OPTIONS="--secure"
#----------/etc/pxe.conf-------------------------------

    # which interface to use
    interface=eth0
    default_address=10.33.36.1

    # the multicast ip address to listen on
    multicast_address=224.0.1.2

    # mtftp info
    mtftp_address=224.1.5.1
    mtftp_client_port=1758
    mtftp_server_port=1759

    # the port to listen on
    listen_port=4011

    # enable multicast?
    use_multicast=1

    # enable broadcast?
    use_broadcast=0

    # user prompt
    prompt=Press F8 to view menu ...
    prompt_timeout=10

    # what services to provide, priority in ordering
    # CSA = Client System Architecture
    # service=<CSA>,<min layer>,<max layer>,<basename>,<menu entry>
    service=X86PC,0,0,local,Local boot
    service=X86PC,0,0,pxelinux,PXELinux

    # tftpd base dir
    tftpdbase=/srv/tftp

et sur mon serveur Windows:

option 66: 10.33.36.1
option 67: pxelinux.0

et les postes indiquent:

Starting pxe over IPV4
Station IP ADDRESS 10.33.36.10
Server  IP ADDRESS 10.33.36.1
NBP filename pxelinux.0
NBP filesize 42988 Bytes
Downloading NBP file ...
 Succeed TO download NBP file.
Downloading NBP file ...

Pouvez vous m'aider svp?

  • # Boot PXE en UEFI au lieu de legacy

    Posté par (page perso) . Évalué à 2.

    Bonjour,

    Les postes indiquent un boot PXE en UEFI et votre la configuration PXE de votre serveur est en Legacy . Il faut aller dans le bios (uefi) des machines et forcé le demarrage en "legacy".

    En legacy, le boot doit demarrer par " Intel boot PXE etc … " generalement.

  • # divers ?

    Posté par . Évalué à 3. Dernière modification le 18/01/16 à 18:22.

    l'arborescence /srv/tftpd contient-elle de quoi travailler ?

    en effet au dela du simple pxelinux.0 et du dossier pxelinux.cfg/ qui contient le fichier default

    il te faut ensuite quelques bricoles dedans.

    perso ca fait un moment que j'en ai pas configuré mais je crois que j'ai jamais reussi à faire fonctionner tftp-hpa.

    J'avais utilisé un autre serveur tftp (tftpd je crois).

    et au bureau le dernier que j'ai fais, sur debian8, j'ai tout fais avec :
    - dnsmasq en DHCP/TFTP
    - NFS pour le montage des arborescences contenant les ISOs decompressées et eventuellement patchées (debian, centos, clonezilla)

    • [^] # Re: divers ?

      Posté par (page perso) . Évalué à 3.

      et les permissions des répertoires et fichiers

      Système - Réseau - Sécurité Open Source

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.