Forum Linux.général monter fichier partager avec smbfs

Posté par .
Tags : aucun
0
13
fév.
2006
Hello je veux monter un dossier distant, et que le groupe partage_samba puisse modifier les fichiers monter.

voila ce que j'ai fait :
mount -t smbfs \\\\clochard\\public /mnt/samba -o user,umask=002,uid=0,gid=500

C'est monter, mais seulement le root peut écrire dans /mnt/samba pourtant il appartient bien au groupe partage_samba mais il n'a pas le droit pour modifier.

Le dossier à monter ce trouve sur la machine "clochard", il est partager avec samba et tous le monde peux y écrire sans mot de passe. Quand j'y accéder avec smb:/clochard/public pas de problème je peux écrire.
umask==002 devrait donne les droit d'écriture au groupe partage_samba ( gid=500) je comprend pas...

merci pour l'aide
  • # umask -> fmask et dmask

    Posté par . Évalué à 1.

    Perso, j'utilise fmask=664,dmask=775 à la place de umask et ça marche.
    Peut être qu'il faut aussi mettre la valeur des sticky bits dans ton umask (umask=0002) pour que ça fasse ce que tu attends ...
    • [^] # Re: umask -> fmask et dmask

      Posté par . Évalué à 2.

      Bonsoir,

      Effectivement, comme le fait remarquer Bastien, l'option umask n'existe pas pour smbfs. Il faut utiliser fmask pour les fichiers et dmask pour les répertoires. D'ailleurs, ces options ne correspondent pas à des masques (comme le umask unix) mais à des droits accordés (comme pour le chmod).

      JJD
  • # good

    Posté par . Évalué à 2.

    vraiment merci les gars ça fonctionne impeccable.
    je vais me renceigner sur fmask et dmask parce que ça fonctionne c'est bien mais autant savoir c'est exactement ;)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.