Forum Linux.général [OpenMediaVault] Remote access LAN

Posté par . Licence CC by-sa.
0
23
déc.
2012

Bonsoir,

Je me lance.

J'ai installé Oneswarm sur un serveur OpenMediaVault (debian squeeze).

Il fonctionne. ça ne s'est pas fait du premier coup mais c'est bon.

Cependant, je n'arrive pas accéder à la console en remote depuis mon poste fixe.
ça fonctionne bien en local (et oui, j'ai craqué, j'ai installé xfce sur le serveur - de toute manière, c'est le seul moyen que j'ai trouvé pour piloter Oneswarm)

NB : Dans le menu de oneswarm, lorsque j'active le remote access, il me propose seulement l'url en https…. pas de http. Un rapport ? (Il faut noter que depuis l'extérieur, l'url en https, ne fonctionne pas non plus…)

Je sèche….. vraiment.
J'aimerai vraiment avoir un accès en http sur la console depuis mon réseau local !!!!!!!

Si de bonnes âmes pouvaient m'aider :-)

J'ai fait commencé a scanner les ports…. faire du tcpdump mais pas facile d'interpréter…

  • # bind localhost vs bind adresse IP

    Posté par . Évalué à 2.

    ton histoire ressemble au fait que oneswarn ecoute sur localhost (127.0.0.1)
    au lieu d'ecouter sur l'ip de ta machine.

    du coup tu ne peux y acceder que depuis le serveur lui meme.

    regarde si y a pas une option pour lui dire d'ecouter sur l'adresse IP

    sinon pour te depanner, montes un tunnel ssh entre ton poste LAN et ton serveur pour acceder au serveur.

    ex :

    ssh -L8080:localhost:XXX USER@TONSERVEUR
    
    

    en remplacant XXX par le port de oneswarn (80 pour du http, 443 pour du https)

    ensuite avec ton navigateur sur ton poste LAN, demandes la connexion sur http://localhost:8080 ou https://localhost:8080

    • [^] # Re: bind localhost vs bind adresse IP

      Posté par . Évalué à 1.

      Merci pour ton aide.

      L'interface web de oneswarm écoute sur un port 29615.

      Du coup, j'ai exécuté ta commande avec ce port.

      Cependant, le serveur coupe la connexion :-(

      channel 3: open failed: administratively prohibited: open failed

      • [^] # Re: bind localhost vs bind adresse IP

        Posté par . Évalué à 2. Dernière modification le 23/12/12 à 21:54.

        L'interface web de oneswarm écoute sur un port 29615.

        ca veut dire que tu demandes à ton navigateur d'aller sur http://localhost:29615 quand tu es sur le serveur avec XFCE ?

        • [^] # Re: bind localhost vs bind adresse IP

          Posté par . Évalué à 0.

          Je viens d'avancer un peu.
          En autorisant le tunneling ssh, ça va mieux :-)
          Mais bon au final, j'ai le même résultat. ça mouline et je me fais jetter par oneswarm. Enfin, je crois que c'est ça….

          Je sens que je vais tout dégager et refaire ma config mais peut-être après Noel :-)

          Merci

  • # D'autres outils

    Posté par . Évalué à 1. Dernière modification le 23/12/12 à 23:30.

    J'analyse souvent les problèmes de ce genre avec "netstat -auntp" et "tcpdump | grep".

    Ça remonte pas mal d'infos qui, parfois, sont plus claires à mes yeux que la doc des fichiers de conf.

    Edit : la commande "telnet", elle est cool aussi.

    • [^] # Re: D'autres outils

      Posté par . Évalué à 1.

      Effectivement, j'ai utilisé tcpdump, une commande du style :

      tcpdump -i eth0 port [port]

      Je vois passer mes appels depuis l'extérieur.

      Je pense que c'est Oneswarm qui a un problème et que je vais refaire la configuration.
      J'espère juste que ce n'est pas apache2 qui est en https qui fiche le bazard (apache2 est utilisé par OpenMediaVault)

      Merci pour les conseils.

      Je vous tiendrais au courant.

  • # Oneswarm réinitialisé

    Posté par . Évalué à 0.

    Bonjour,

    J'ai refait ma config oneswarm (suppression du répertoire .oneswarm) et il me propose toujours l'adresse en https pour l'accès a distance …..

    ça pourrait venir de la configuration d'apache qui est en https ? Si oui, je ne comprends pas bien le rapport et surtout comment régler le problème…

    Du toutes manières, l'https ne fonctionne qu'en local sur le serveur…. :-(

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.