Forum Linux.général problème pilote Raspberry pi 2

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
10
sept.
2016

Bonjour je viens ici afin de vous demander de l'aide, je bloque complétement :/

j'ai une Raspberry pi 2 sur raspbian jessie.

je voudrais pouvoir utiliser dessus une carte wifi blueway n9200.

j'ai aussi une clef d'acquisition vidéo EasyCAP DC60-2021

mais après sa encore beaucoup de travail j'ai encore Motion a installer et a configuré pour qu'il stream la vidéo de la clef d'acquisition au démarrage

démarré automatiquement un (jeu) fait sur unity3D (mode nographique)

et pour terminer relier un arduino au Raspberry (donc trouver le port utiliser par l'arduino en espérant qu'il ne change pas après chaque rebot)

quelqu'un peut il m'aider avant que mon cerveau n'entre en phase de fusion svp ?

  • # Qu'as-tu déjà fait, et que te reste-t-il à faire ?

    Posté par  . Évalué à 3.

    si j'en crois http://www.priceminister.com/offer/buy/170785584/blueway-n9200-2w-rt3070-adaptateur-wifi-longue-portee-usb-802-11b-g.html ton adaptateur usb utilise le chipset rt3070, donc tu devrais pouvoir le faire fonctionner avec ça : https://wiki.debian.org/fr/rt2870sta.

    Pour la clé d'acquisition je ne sais pas trop, je vais regarder un peu.

    Enfin por l'arduino, que veux tu faire exactement ? Parce que normalement, si tu utilises ton arduino sur le port USB de ton raspberry, il devrait configurer un port série ttysXX, qui ne devrait pas bouger si tu ne branches pas d'autres périphériques USB/série. Celà dit, tu peux créer une règle udev pour que la liaison série de l'arduino soit nommée autrement. J'essaierai si j'ai 2 mn demain.

  • # légère avancer

    Posté par  . Évalué à 1.

    bon voila j'ai trouver quelque truc après environ 14h de recherche et d’essais

    pour la carte wifi j'ai ceci https://wiki.debian.org/rt2800usb très similaire au tiens mais quelque problème se pose :/

    j'arrive pas a la faire se connecter automatiquement en wifi (3 wifi ouvert cher moi)et quant je la connecte en manuel je trouve pas son ip en scannant le réseau:/

    du coup vue que sa fonctionnait pas j'ai pas chercher a passer en ip fixe

    ensuite c'est une 2000mw et je voudrais la débrider car pour le moment elle est bloquer a 20dbm (je sait en France c'est pas très légal mais j'habite en pleine campagne et pour mon projet je suit obliger d'avoir de la porter en omni) :(

    sinon pour la clef d’acquisition j'ai quelque info de plus :
    DI 1b71:3002 Fushicai USBTV007 Video Grabber [EasyCAP]

    du coup j'ai pue tomber sur se site http://raspberry-at-home.com/video-grabber-for-raspberry-pi/
    j'ai pas pue tester car je commence a fatiguer et que j'ai déactiver (enfin je pense) le port Ethernet (les voyant son toujours allumer)par erreur (enfin sa a bug après un reboot)

    pour l’Arduino il me faudrait effectivement la règle udev sa serait plus pratique mais bon c'est pas vital je compte pas trop toucher au périf usb

    et il me reste toujours a installer et lancer motion (ou autre prog de stream vidéo) au démarrage ainsi que mon (jeu)

    si sa peut aider pour le (jeu) pour un serveur unity sous Debian on m'avais crée se bout de code pour le lancer

    n=`ps auxwf | grep avpserveur | grep -v grep | wc -l`
    if test $n -gt 0 ; then
        echo "Deja lancé !"
    fi
    
    screen -dmS tsw sudo -u games MONO_DISABLE_SHM=1 xvfb-run --auto-servernum --server-args='-screen 0 640x480x24:32' ./avpserveur.x86_64 -batchmode
    end

    voila c'est a peut près tout
    vraiment je te remercie pour ton aide je vais enfin pouvoir avancer sur se projet

    • [^] # ...

      Posté par  . Évalué à 1.

      bon après recherche c'est quant j'éssaie de me conecter (et apres un reboot) que sa bug

      apres avoir instaler les pilote

      j'ai modifier le fichier /etc/wpa_supplicant/wpa_supplicant.conf

      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
      update_config=1
      
      network={
      ssid="default"
      psk=""
      }
      end

      puis fait ses commande

      # ip a
      # iwconfig
      # ip link set wlan0 up
      end

      mais comme sa changeait rien j'ai fait un reboot et la c'est le drame

      sinon voila le résultat de certaine commande

      root@raspberrypi:/home/pi# iwconfig
      wlan0     IEEE 802.11bgn  ESSID:off/any
                Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
                Retry short limit:7   RTS thr:off   Fragment thr:off
                Encryption key:off
                Power Management:off
      
      lo        no wireless extensions.
      
      eth0      no wireless extensions.
      end
      root@raspberrypi:/home/pi# iwlist scan
      wlan0     Scan completed :
                Cell 01 - Address: 00:19:5B:0A:84:B3
                          Channel:1
                          Frequency:2.412 GHz (Channel 1)
                          Quality=70/70  Signal level=-13 dBm
                          Encryption key:off
                          ESSID:"default"
                          Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                    9 Mb/s; 12 Mb/s; 18 Mb/s
                          Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                          Mode:Master
                          Extra:tsf=000000a0a07b73bc
                          Extra: Last beacon: 50ms ago
                          IE: Unknown: 000764656661756C74
                          IE: Unknown: 010882848B960C121824
                          IE: Unknown: 030101
                          IE: Unknown: 2A0100
                          IE: Unknown: 32043048606C
      
      lo        Interface doesn't support scanning.
      
      eth0      Interface doesn't support scanning.
      end
      root@raspberrypi:/home/pi# ifconfig
      eth0      Link encap:Ethernet  HWaddr b8:27:eb:2d:cd:6a
                inet adr:192.168.1.37  Bcast:192.168.1.255  Masque:255.255.255.0
                adr inet6: fe80::ba27:ebff:fe2d:cd6a/64 Scope:Lien
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:142 errors:0 dropped:3 overruns:0 frame:0
                TX packets:131 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 lg file transmission:1000
                RX bytes:14615 (14.2 KiB)  TX bytes:18804 (18.3 KiB)
      
      lo        Link encap:Boucle locale
                inet adr:127.0.0.1  Masque:255.0.0.0
                adr inet6: ::1/128 Scope:Hôte
                UP LOOPBACK RUNNING  MTU:65536  Metric:1
                RX packets:136 errors:0 dropped:0 overruns:0 frame:0
                TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 lg file transmission:0
                RX bytes:11792 (11.5 KiB)  TX bytes:11792 (11.5 KiB)
      
      wlan0     Link encap:Ethernet  HWaddr 00:0d:b0:00:83:07
                adr inet6: fe80::6700:de40:ebb0:380f/64 Scope:Lien
                UP BROADCAST MULTICAST  MTU:1500  Metric:1
                RX packets:0 errors:0 dropped:0 overruns:0 frame:0
                TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 lg file transmission:1000
                RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      end
      • [^] # Re: ...

        Posté par  . Évalué à 1.

        ton adaptateur usb utilise le chipset rt3070, donc tu devrais pouvoir le faire fonctionner avec ça : https://wiki.debian.org/fr/ rt2870sta.

        pour la carte wifi j'ai ceci https://wiki.debian.org/ rt2800usb très similaire au tiens mais quelque problème se pose :/

        similaire ne veut pas dire que ca fonctionne pareil

        j'ai modifier le fichier /etc/wpa_supplicant/wpa_supplicant.conf
        […]
        mais comme sa changeait rien j'ai fait un reboot et la c'est le drame

        parce qu'il faut peut-etre comprendre avant de modifier,

        par exemple en mettant TON SSID (le nom de ton wifi)
        et TON PSK (la clef de ton WIFI)

        sinon comment esperes-tu que, si la carte wifi est bien detectée (la premiere etape avec le rt2800usb), le reseau soit detecté

        • [^] # Re: ...

          Posté par  . Évalué à 1. Dernière modification le 12/09/16 à 01:14.

          similaire ne veut pas dire que ca fonctionne pareil

          bas au final sa fonctionne avec et après recherche le lien que j'ai trouver est un sous lien du sien
          en fessant sa j'ai pue me connecter manuellement

          sudo iwconfig wlan0 essid default
          sudo dhclient -v wlan0

          après je sait pas comment le faire automatiquement ni comment attribuer une ip statique :/

          parce qu'il faut peut-etre comprendre avant de modifier,

          par exemple en mettant TON SSID (le nom de ton wifi)
          et TON PSK (la clef de ton WIFI)

          bas après multiple recherche et grace a la commande

          wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -W -iwlan0

          j'ai pue trouver que c’était le psk="" (le réseau est ouvert )qui posait problème fallait tout simplement l'enlever

          maintenant il me renvoie sa

          wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -W -iwlan0
          Successfully initialized wpa_supplicant

          mais il ne se connecte toujours pas seul :/

          • [^] # Re: ...

            Posté par  . Évalué à 1.

            bon j'ai enfin réussie a faire se connecter le wifi automatiquement et a attribuer une ip static sa fonctionne après reboot

            maintenant go sur la clef d’acquisition

            et si quelqu'un a un bon prog de stream vidéo qui peut se lancer au démarrage je prend

            • [^] # Re: ...

              Posté par  . Évalué à 1.

              hummm la je bloque

              j'ai bien trouver sa mais je suis dans le flou

              https://linuxtv.org/wiki/index.php/Easycap#USBTV007_EasyCAP

              • [^] # Re: ...

                Posté par  . Évalué à 1.

                bon pour finir ma clef est en fait détecter d'origine mais la j'arrive pas a stream la caméra :/

                • [^] # Re: ...

                  Posté par  . Évalué à 1.

                  avant de streamer la camera, faut deja arriver à faire detecter la camera,
                  puis a afficher ce qui passe dessus,

                  • [^] # Re: ...

                    Posté par  . Évalué à 1.

                    bas sa c'est bon justement je passe par vlc pour voir sinon imposible de stream

                    cvlc v4l2:///dev/video0 :v4l2-standard= :size=640x480:live-caching=300 :sout= #transcode{vcodec=h264,acodec=mpga,ab=128,channels=2,samplerate=44100} :http{mux=ffmpeg{mux=flv},dst=:8080/test}:sout-all :sout-keep

                    sa m'affiche juste un foutoirs pas possible dans la consolle

                    • [^] # Re: ...

                      Posté par  . Évalué à 3.

                      sa m'affiche juste un foutoirs pas possible dans la consolle

                      parce que tu stream sur le terminal,
                      faut streamer sur le reseau et ouvrir le flux avec une autre machine

                      • [^] # Re: ...

                        Posté par  . Évalué à 1.

                        ok et du coup comment on fait ? :/ (surtout pour démaré le stream au demarage)

                        • [^] # Re: ...

                          Posté par  . Évalué à 3.

                          du coup comment on fait ? :/

                          on lit le manuel de VLC
                          qui ajoute quelques options à ta ligne pour faire du sout (stream out)

                          (surtout pour démaré le stream au demarage)

                          quand tu auras trouvé la bonne ligne de VLC, il te faudra faire un script qui lance cette ligne de commande.

                          puis creer un utilisateur (pour eviter que ce soit lancer en root)
                          et enfin copier ce script dans les /etc/init.d/
                          puis faire un lien dans le bon /etc/rcX.d pour qu'il se lance au demarrage.

                          mais la derniere etape depend quand meme pas mal de ta distrib (debian et centos n'ont par exemple pas la meme maniere de gerer les scripts au demarrage de la machine)

                          • [^] # Re: ...

                            Posté par  . Évalué à 1. Dernière modification le 12/09/16 à 20:45.

                            il n'y a pas moyen de négocier un peut plus d'info pour vlc ?

                            sinon voila des info

                            • 2015-09-24-raspbian-jessie

                            • Linux raspberrypi 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux

                            • [^] # Re: ...

                              Posté par  . Évalué à 1.

                              parce que la reponse se trouve vachement loin
                              http://lmgtfy.com/?q=streaming+video+avec+vlc
                              ou bien encore
                              http://lmgtfy.com/?q=streaming+video+avec+vlc+au+travers+du+reseau

                              la dedans il doit bien y avoir 2 ou 3 exemples faciles

                              • [^] # Re: ...

                                Posté par  . Évalué à 1.

                                très drôle :/ tu croie vraiment que je suis le genre de mec qui cherche pas :/

                                je tombe sur quasiment même truc j'ai essayer tout se que j'ai trouver est sa fonctionne pas

                                • [^] # Re: ...

                                  Posté par  . Évalué à 2.

                                  j'ai essayer tout se que j'ai trouver est sa fonctionne pas

                                  lors de tes essais tu aboutis à quelle ligne de commande ?
                                  ca bloque à quel moment ?

                                  par exemple ici
                                  http://www.01net.com/astuces/diffusez-vos-videos-sur-votre-reseau-local-avec-vlc-567385.html
                                  ou
                                  http://www.xanetiz.com/vlc-lecteur-incontournable.html

                                  il est expliqué comment le faire par l'interface graphique,
                                  commence deja par là sur ton PI

                                  de memoire quand tu fais ca, ca remplit une ligne de commande, te montrant comment remplir cette ligne pour faire la diffusion.

                                  quand tu auras la config qui fonctionne, tu reprends cette ligne que tu lanceras en ligne de commande avec cvlc plutot que vlc

                                  • [^] # Re: ...

                                    Posté par  . Évalué à 1.

                                    j'ai essayer justement mais sa fonctionne pas après j'ai réactiver l'interface graphique et sa fonctionne pas non plus sinon la ligne de code est bonne peut être les port alors ?

                                    je t'avoue que je commence a saturé un peut sa fait 6 jours non stop (j'ai du dormir 12H en tout lol )que je cherche que je bosse sur mon projet que se soit sur linux sur unity3D ou arduino sans parler de toute la partie mécanique. je vais bientôt devoir refroidir mon cerveau par whatercoling lol

                                    • [^] # Re: ...

                                      Posté par  . Évalué à 2.

                                      j'ai essayer justement mais sa fonctionne pas après j'ai réactiver l'interface graphique et sa fonctionne pas non plus sinon la ligne de code est bonne peut être les port alors ?

                                      hmm, avec un message "ca ne fonctionne pas, aider moi"
                                      on ne va pas aller loin,
                                      dans nos messages precedents on te demandais ou tu en etais,
                                      donc là je repose la question :

                                      qu'est ce qui fonctionne et qu'est ce qui ne fonctionne pas ?

                                      la partie capture ?
                                      Clef USB-TV => VLC local

                                      la partie Streaming ?
                                      Video locale (depuis un fichier) => reseau

                                      tu as obtenu quelle ligne en utilisant la GUI de ton VLC ?

                                      • [^] # Re: ...

                                        Posté par  . Évalué à 1.

                                        la partie capture est lier a la partie streaming
                                        Clef USB-TV => reseau

                                        sinon j’obtiens

                                        MRL :

                                        v4l2:///dev/video0

                                        Modifier les option :

                                        :file-caching=300

                                        Paramètre généraux du flux de sortit :

                                        :sout=#transcode{vcodec=h264,acodec=mpga,ab=128,channels=2,samplerate=44100}:http{mux=ffmpeg{mux=flv},dst=:8080/} :sout-all :sout-keep
                                        • [^] # Re: ...

                                          Posté par  . Évalué à 2.

                                          j'ai pas de RPI pour tester vraiment mais j'ai fait un essai avec mon PC
                                          j'ai pas de client pour tester (suis au bureau)

                                          avec transcoding :

                                          :sout=#transcode{vcodec=h264,acodec=mpga,ab=128,channels=2,samplerate=44100} :sout-all :sout-keep

                                          sans transcoding

                                          :sout=# :sout-all :sout-keep

                                          c'est peut-etre le transcoding sur le PI qui ne se fait pas bien (pas prevu pour ?)
                                          tu peux essayer sans transcoding

                                          • [^] # Re: ...

                                            Posté par  . Évalué à 1.

                                            vlc
                                            Video locale (depuis un fichier) => reseau sans transcodage fonctionne

                                            Clef USB-TV => reseau sans transcodage fonctionne toujours pas

                                            motion
                                            sa prend seulement des photo aucun stream

                                            • [^] # Re: ...

                                              Posté par  . Évalué à 2.

                                              hmm,
                                              donc TV-USB -> local ca marche
                                              local -> reseau : ca marche

                                              mais TV-USB -> reseau : ca ne marche pas

                                              que fait tu de different hormis la source entre local _> reseau et TV-USB _> reseau ?
                                              les options sont-elles differentes ? dans tous les cas, tu met quoi ?

                                              • [^] # Re: ...

                                                Posté par  . Évalué à 1.

                                                a part la source rien ne change (toujours en mode graphique)

                                                Modifier les option :

                                                :file-caching=300

                                                Paramètre généraux du flux de sortit :
                                                :sout=# :sout-all :sout-keep

                                                question:
                                                file-caching trop bas ?
                                                bande passante des port usb pas asser grand pour l’acquisition et le wifi ?

  • # re

    Posté par  . Évalué à 1.

    peut plus modifier ma réponse donc

    Clef USB-TV => VLC local fonctionne

    Video locale (depuis un fichier) => reseau fonctionne pas

    Clef USB-TV => reseau fonctionne pas

    • [^] # Re: re

      Posté par  . Évalué à 1.

      Video locale (depuis un fichier) => reseau sans transcodage fonctionne

      Clef USB-TV => reseau sans transcodage fonctionne toujours pas

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.