Forum Linux.général (Résolu) Kodi et lecture vidéo très lente

Posté par (page perso) . Licence CC by-sa.
Tags : aucun
0
17
fév.
2015

Salut, je viens demander de l'aide car je sature depuis quelques heures. J'ai remarqué que la lecture de films en HD avec Kodi est vraiment très lente, saccade puis le son fini par se désynchronisé, les images sautes, le son se coupe, bref…

J'ai essayé pleins de réglages, mais rien n'y fait ça rame. J'ai un processeur AMD 4 core cadencé à 1.333 mhz, 2Go de mémoire vive et dès que je lance KODI, le vois déjà que KODI bouffe entre 20 ~ 60% du processeur. En lecture, ça dépasse facile les 115%. J'ai installé les pilotes libre pour voir si y a un mieux, c'est pire, l'interface rame comme pas possible.

Bizarrement, le son bug parfois dans l'interface. Y a une sorte de décalage et ça fait pleins d'échos. J'ai réinstallé KODI, j'ai supprimer le dossier userdata, j'ai tenté pleins de manipulations mais rien n'y fait. Par contre, certains films en 720p passe plus ou moins très bien, mais je vois que l'usage CPU est anormalement élevée. Je suis en train de compiler la version GIT pour voir si y a un mieux, mais toute aide serait fortement apprécié.

J'utilise ArchLinux, y a t-il des chances que ça marche mieux si j'installe Debian ?!

Merci

Le problème en image

  • # Source du contenu

    Posté par . Évalué à 1.

    Salut !
    Effectivement, il y a un problème. Je le fais tourner sur un Rasp B et ça roule d'enfer.
    Tu peux nous détailler un peu ton réseau local ? La source du film vient du réseau ? D'un SFTP en bulgarie tournant sur un vieux groupe électrogène russe ^ ?

    Tu as vérifier les fichiers xml de Kodi, je crois que le fichier s'appelle advancedsettings.xml dans le dossier userdata ? Cela permettra de supprimer les flux RSS par exemple. Ils sont très gourmands. (http://kodi.wiki/view/Advancedsettings.xml[http://kodi.wiki/view/Advancedsettings.xml]
    Tu as tenté avec OpenElec (qui se base sur Kodi) ?

    • [^] # Re: Source du contenu

      Posté par (page perso) . Évalué à 1.

      Eh bien les vidéos sont présentes sur le disque dur de la machine (1TO). Donc ça devrait aller très vite. Je vais tenté de supprimer le flux RSS pour voir si y a une différence. Le plus étrange, c'est que lorsque je sors du mode plein écran pour revenir à la page d'accueil avec le film en arrière, la vidéo est fluide et le framerate de l'interface est de l'ordre de plus de 100 fps.

      Pas testé OpenElec, si vraiment je trouve rien comme solution, je tenterais le coup.

  • # Acceleration graphique

    Posté par . Évalué à 4.

    Salut.

    L'accélération matérielle par la carte graphique ne doit pas etre activée, ce qui fait que le CPU doit tout décoder, au lieu de la carte graphique.

    Quel est le modèle de la carte graphique avec quels drivers (libre/prorio) ?

    Avec une recherche sur le wiki d'Archlinux sur ta carte graphique et VDPAU tu doit pouvoir l'activer.

    • [^] # Re: Acceleration graphique

      Posté par . Évalué à 2.

      Vu l'age du bousin, c'est pas dit que l’accélération existe.

      Please do not feed the trolls

      • [^] # Re: Acceleration graphique

        Posté par (page perso) . Évalué à 1.

        Vu l'âge ?! C'est une machine récente équipée de 4 cores et repose sur la technologie APU. On peut pas faire plus récent pour le moment même si c'est pas un foudre de guerre :

        cpu:
        AMD Sempron(tm) 3850 APU with Radeon(tm) R3, 1300 MHz
        AMD Sempron(tm) 3850 APU with Radeon(tm) R3 , 1000 MHz
        AMD Sempron(tm) 3850 APU with Radeon(tm) R3 , 800 MHz
        AMD Sempron(tm) 3850 APU with Radeon(tm) R3 , 1000 MHz
        keyboard:
        /dev/input/event0 AT Translated Set 2 keyboard
        graphics card:
        ATI VGA compatible controller
        sound:
        ATI Audio device
        AMD FCH Azalia Controller
        storage:
        AMD FCH SATA Controller [AHCI mode]
        network:
        enp1s0 Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller
        network interface:
        lo Loopback network interface
        enp1s0 Ethernet network interface
        disk:
        /dev/sda SAMSUNG HD103SI
        partition:
        /dev/sda1 Partition
        /dev/sda2 Partition
        /dev/sda3 Partition
        /dev/sda4 Partition
        /dev/sda5 Partition
        usb controller:
        AMD FCH USB XHCI Controller
        AMD FCH USB OHCI Controller
        AMD FCH USB EHCI Controller
        AMD FCH USB OHCI Controller
        AMD FCH USB EHCI Controller
        bios:
        BIOS
        bridge:
        AMD Family 16h Processor Root Complex
        AMD Family 16h Processor Function 0
        AMD Family 16h Processor Functions 5:1
        AMD FCH LPC Bridge
        AMD Family 16h Processor Function 0
        AMD Family 16h Processor Function 1
        AMD Family 16h Processor Function 2
        AMD Family 16h Processor Function 3
        AMD Family 16h Processor Function 4
        AMD Family 16h Processor Function 5
        hub:
        Linux 3.18.6-1-ARCH xhci-hcd xHCI Host Controller
        Linux 3.18.6-1-ARCH xhci-hcd xHCI Host Controller
        Linux 3.18.6-1-ARCH ohci_hcd OHCI PCI host controller
        Linux 3.18.6-1-ARCH ohci_hcd OHCI PCI host controller
        Linux 3.18.6-1-ARCH ehci_hcd EHCI Host Controller
        Linux 3.18.6-1-ARCH ehci_hcd EHCI Host Controller
        memory:
        Main Memory
        unknown:
        FPU
        DMA controller
        PIC
        Timer
        Keyboard controller
        AMD FCH SMBus Controller
        Serial controller

    • [^] # Re: Acceleration graphique

      Posté par (page perso) . Évalué à 1.

      J'utilise le pilote propriétaire, j'ai bien installé le paquet libvdpau-va-gl et fait un export VDPAU_DRIVER=va_gl mais c'est pareil, j'ai vu aucun changement au niveau des performance…

  • # J'ai trouvé la solution au problème !

    Posté par (page perso) . Évalué à 1.

    Bon bah j'ai trouvé la solution au problème, c'était évident ! J'ai désactivé l'accélération matérielle par logiciel, le GPU, et ça tourne au poil, j'ai vu aucune différence au niveau de la charge CPU. Sûrement un bug ? Ah je suis trop content, je vais enfin pouvoir regarder mes films :)

    • [^] # Re: J'ai trouvé la solution au problème !

      Posté par . Évalué à 2.

      Tu as fais quoi stp ? J'ai rien compris…

      "Quand certains râlent contre systemd, d'autres s'attaquent aux vrais problèmes." (merci Sinma !)

      • [^] # Re: J'ai trouvé la solution au problème !

        Posté par (page perso) . Évalué à 2.

        Dans les options vidéos, j'ai tout simplement réglé l'accélération sur logiciel plutôt que matériel. Je ne sais pas si c'est un bug ou par le fait que l GPU est dans le processeur, mais cette manipulation permet d'avoir une image constante à 24 fps.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.