Forum Linux.général sudo : problème de password

Posté par  .
Étiquettes : aucune
0
16
mai
2005
Bonjour,
je viens de configurer le fichier /etc/sudoers afin de pouvoir lancer les commandes startadsl et stopadsl (j'utilise un sagem fast800 avec eagle-usb) en tant qu'utilisateur normal ...

çà marche bien, mais seul problème c'est que je veux qu'il me demande mon mot de passe utilisateur avant de se connecter ou de couper la connexion quand je lance la commande :
sudo /usr/sbin/startadsl (ou stopadsl)

et non pas que la commande s'execute directement comme c'est le cas, à signaler que j'ai pas mis l'option NOPASSWD dans le fichier de config, le voici :

....
# User alias specification
User_Alias USER_1=amine
# Cmnd alias specification
Cmnd_Alias ADSL=/usr/sbin/startadsl,/usr/sbin/stopadsl

# Defaults specification

# User privilege specification
root ALL=(ALL) ALL
USER_1 ALL=(ALL) ADSL

# Uncomment to allow people in group wheel to run all commands
# %wheel ALL=(ALL) ALL

# Same thing without a password
# %wheel ALL=(ALL) NOPASSWD: ALL

# Samples
# %users ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
# %users localhost=/sbin/shutdown -h now

#FIN

quelqu'un saurait-il comment faire çà ?
  • # timestamp_timeout

    Posté par  . Évalué à 1.

    Essaye avec l'option timestamp_timeout mise à 0 peut-être. Probablement que tu as tapé une fois ton password et que lors de tes autres éssais le timestamp n'était pas écoulé.
    • [^] # Re: timestamp_timeout

      Posté par  . Évalué à 1.

      Merci, je me suis rendu compte qu'il y'avait un timeout; mais c'est la première fois que j'utilise sudo; je sais pas où faut-il preciser l'option timestamp_timeout dans le fichier de configuration, j'ai essayé
      timestamp_timeout = 0
      et
      Parameter timestamp_timeout = 0

      mais çà n'a pas marché,
      • [^] # Re: timestamp_timeout

        Posté par  . Évalué à 1.

        Defaults timestamp_timeout=0

        Ca te permet de spécifier les options (séparées par des virgules) de sudo. Ici ce sont les options globales, mais tu peux spécifier par user "Defaults:user" ou par host "Defaults@host", ou encore pour un Runas user.

        Tout ça c'est dans le man de sudoers, mais je t'accorde qu'il est pas des plus évidents :)
        • [^] # Re: timestamp_timeout

          Posté par  . Évalué à 1.

          ok, merci pour ton coups de pouce,
          je vais essayer de re regarder le man et de re re essayer de comprendre

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.