Forum Linux.général Xorg+Driver Intel+ Ecran sgi 1600sw

Posté par .
Tags : aucun
0
21
oct.
2008
Bonjour,

J'ai quelques soucis pour faire fonctionner mon écran Sgi [1], avec le chipset graphique intégré [2]de ma carte mère...
L'écran fonctionne très bien si ce n'est qu'il n'est pas a la base compatible avec une carte graphique avec sorti dvi. J'utilise donc une carte pci additionnel [3] qui convertit les signaux.
Tout cela fonctionne plutôt bien sauf que le driver intel ne le détecte pas et bloque le lancement de Xorg.
Par contre si je lance le serveur X en connectant un autre écran sur la carte, et qu'ensuite, une fois X lancé je branche l'écran sgi, et bien ça fonctionne parfaitement....

Donc je sais que l'écran fonctionne, que la carte fonctionne, mais c'est juste l'initialisation qui foire ...

Je cherche donc un option a rajouter dans xorg.conf ou ailleurs qui me permettrais de forcer le lancement de X, même si l'écran n'est pas détecté.

Je joins également mon fichier xorg.conf.

J'espère que vous pourrez m'aider ....

[1]http://en.wikipedia.org/wiki/SGI_1600SW
[2]http://en.wikipedia.org/wiki/Intel_GMA#GMA_X3500
[3]http://en.wikipedia.org/wiki/SGI_1600SW#Adapting_the_1600SW_(...)


Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Configured Mouse" "CorePointer"
InputDevice "Generic Keyboard" "CoreKeyboard"
EndSection


Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "intel"
# Option ""
# Option "ForceEnablePipeA" "true"
BusID "PCI:0:2:0"
Option "monitor-VGA" "dummy"
Option "monitor-TMDS-1" "Configured Monitor"
# Option "DDC" "false"
# Option "IgnoreEDID" "true"
# Option "ExactModeTimingsDVI" "true"
Option "RenderAccel" "true"
EndSection


Section "Monitor"
Identifier "dummy"
Option "Ignore" "true"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Option "Enable" "true"
Option "DPMS"
Option "PreferredMode" "1600x1024"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configure Video Device"
DefaultDepth 24

Subsection "Display"
Depth 24
Modes "1600x1024"
EndSubsection

EndSection
  • # Complément d'information

    Posté par . Évalué à 1.

    Je rajoute qqs infos qui pourrais être utiles à la résolution de mon problème :

    Le résultat de l'appel de startx:
    X.Org X Server 1.4.2
    Release Date: 11 June 2008
    X Protocol Version 11, Revision 0
    Build Operating System: Linux Debian (xorg-server 2:1.4.2-7)
    Current Operating System: Linux darkstar 2.6.26-1-686 #1 SMP Thu Oct 9
    15:18:09 UTC 2008 i686
    Build Date: 30 September 2008 01:48:58AM

    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 21 14:15:36 2008
    (==) Using config file: "/etc/X11/xorg.conf"
    (WW) intel: No matching Device section for instance (BusID PCI:0:2:1)
    found
    (II) Module "ddc" already built-in
    (II) Module "i2c" already built-in
    (EE) intel(0): Output TMDS-1 enabled but has no modes
    (EE) intel(0): No valid modes.
    (EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found
    giving up.
    xinit: Connection reset by peer (errno 104): unable to connect to X
    server
    xinit: No such process (errno 3): Server error.


    Le résultat de l'appel de xrandr une fois l'écran SGI connecté :

    sx@darkstar:~$ xrandr
    Screen 0: minimum 320 x 200, current 1600 x 1024, maximum 1680 x 1680
    TMDS-1 disconnected 1600x1024+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
    1600x1024 (0x4c) 106.9MHz
    h: width 1600 start 1620 end 1640 total 1670 skew 0 clock 64.0KHz
    v: height 1024 start 1027 end 1030 total 1067 clock 60.0Hz



    Xrandr voit très bien que mon écran est déconnecté ...
    • [^] # Re: Complément d'information

      Posté par . Évalué à 2.

      bonjour

      ce qui m'attire l'oeil, c'est la partie:

      (EE) intel(0): Output TMDS-1 enabled but has no modes
      (EE) intel(0): No valid modes.
      (EE) Screen(s) found, but none have a usable configuration.


      ne faudrait-il pas spécifier les fréquences de fonctionnement de l'écran dans la section monitor, avec des options comme HorizSync et/ou VertRefresh, suivant ce que supporte l'écran?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.