Forum Linux.gui dual screen + kde

Posté par .
Tags : aucun
0
4
oct.
2006
Bonjour,

J'ai installé une deuxième carte graphique dans mon pc pour faire du dual-screen. Quand mon KDE se lance, l'interface de l'écran secondaire est à moitié en anglais alors que sur l'écran principal tout est en français (sans compter quelques autres bugs mineurs)... quelqu'un a-t-il déjà eu ce problème? Quels sont les fichiers de configuration qui permettraient de régler ça?
  • # Wow

    Posté par . Évalué à 2.

    Comment tu as fait ça ? Tu as lancé deux KDE ?
    • [^] # Re: Wow

      Posté par . Évalué à 2.

      Bin non, je crois qu'il n'y a qu'un seul serveur X qui tourne (si j'en crois mon xorg.conf), mais il gère un KDE sur chaque écran...
      • [^] # Re: Wow

        Posté par (page perso) . Évalué à 2.

        Regarde dans tes processus si tu as deux kwin (le gestionnaire de fenêtre de kde), cela t'indiquera combien de kde sont lancés.

        Chez moi je fais tourner un seul bureau kde sur deux écrans et ça marche plutôt bien. Mais ce que tu décris ssemble vraiement être deux kde sur un ou deux serveurs X.
      • [^] # Re: Wow

        Posté par . Évalué à 1.

        Bizard comme truc.
        J'ai moi même deux écrans, voici ma config xorg avec une carte nvidia:


        Section "Device"
        Identifier "Graphic Card"
        Driver "nvidia"

        Option "TwinView"
        Option "MetaModes" "DFP-1 : 1280x1024, DFP-2 : 1280x1024
        Option "HorizSync" "DFP-1 : 28-64; DFP-2 : 28-64"
        Option "VertRefresh" "DFP-1 : 60; DFP-2 : 60"
        #Disposition des écrans
        Option "TwinViewOrientation" "DFP-1 LeftOf DFP-2"
        Option "ConnectedMonitor" "DFP-1, DFP-2"

        Option "RenderAccel" "true"
        EndSection

        Section "Monitor"
        Identifier "DFP-1"
        Option "DPMS"
        HorizSync 28-64
        VertRefresh 60
        EndSection
        Section "Monitor"
        Identifier "DFP-2"
        Option "DPMS"
        HorizSync 28-64
        VertRefresh 60
        EndSection
        • [^] # Re: Wow

          Posté par . Évalué à 1.

          Effectivement j'ai deux kwin en route, sur un serveur X.

          spinoza@spinoza:~$ ps aux| grep kwin
          spinoza 18792 0.0 3.2 30144 8240 ? S 16:58 0:17 kwin [kdeinit]
          spinoza 18793 0.0 2.9 28536 7548 ? S 16:58 0:02 kwin [kdeinit]

          Mon xorg.conf donne:

          Section "ServerLayout"
          Identifier "X.org Configured"
          Screen 0 "Screen0" 0 0
          Screen 1 "Screen1" RightOf "Screen0"
          InputDevice "Mouse0" "CorePointer"
          InputDevice "Keyboard0" "CoreKeyboard"
          EndSection

          ...

          Section "Monitor"
          #DisplaySize 310 230 # mm
          Identifier "Monitor0"
          #VendorName "HWP"
          #ModelName "b02"
          Option "DPMS"
          HorizSync 30-65
          VertRefresh 50-75
          EndSection

          Section "Monitor"
          Identifier "Monitor1"
          VendorName "Monitor Vendor"
          ModelName "Monitor Model"
          HorizSync 28-51
          VertRefresh 43-60
          Option "DPMS"
          EndSection

          ...

          Section "Screen"
          Identifier "Screen0"
          Device "Card0"
          Monitor "Monitor0"
          DefaultDepth 24
          SubSection "Display"
          Viewport 0 0
          Depth 24
          Modes "1024x768"
          EndSubSection
          EndSection

          Section "Screen"
          Identifier "Screen1"
          Device "Card1"
          Monitor "Monitor1"
          DefaultDepth 15
          SubSection "Display"
          Viewport 0 0
          Depth 15
          Modes "800x600"
          EndSubSection
          EndSection

          Est-ce que je pourrais avoir un seul bureau, sachant que les résolutions des écrans sont différentes et que la deuxième carte est plutôt une antiquité (cirrus 5446, 2mo de mémoire :-)? Sinon, je ne sais toujours pas pourquoi mon deuxième kwin n'est qu'à moitié en français...
          • [^] # Re: Wow

            Posté par . Évalué à 1.

            Pour les deux écrans avec des résolutions différentes je ne sais pas.

            Par contre dans mon xorg.conf je n'ai qu'un seule section screen, avec le deuxième écran sur la ligne Monitor.
            Je pense que ton problème vient de des deux sections screen.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.