Forum Linux.gui Freeze du systeme

Posté par .
Tags : aucun
0
13
avr.
2006
Depuis que j'ai changé mon hardware j'ai un phénomene tout à fait bloquant : mon système se fige après un temps d'utilisation variable mais assez court. En général de l'ordre de la minute.

Je m'explique un peu plus.
J'ai déplacé un disque de boot d'un P3 450 chipset BX , gfx voodoo 3, vers un duron 1.8 GHz, chipset sis735, gfx nVidia FX 5200 .
Après le deplacement la seule chose que j'ai faite c'est de reparamètrer le serveur X en installant le binaire nVidia.
La distribution est une edubuntu 5.10 à jour.

Le phénomene en détail :
- au boot j'ai l'écran de login et là je peux attendre le temps que je veux ça ne fige pas
- une fois que je me suis loggé le système se fige au bout d'un temps aléatoire entre quelques secondes ( donc je n'arrive même pas jusqu'au bureau ) et quelques minutes ( donc j'ai le temps de lancer une application au minimum ). Il se fige completement. C'est à dire que je ne peux plus rien faire à part bouger la souris et appuyer sur reset ou arret.
- si une fois loggé je bascule rapidement sur une console texte ( ctrl F1 par exemple ) le sysème ne fige pas tant que je reste en mode texte donc je peux par exemple mettre le système à jour ou installer des applications.

J'ai regardé dans les fichiers de log après un freeze et reboot et je ne vois rien d'evident. J'ai essayé d'installer kdm/kde en pensant que ça vennait peut-être de gdm/gnome et j'ai exactement le même problème. Bien sûr j'ai mis à jour le système. Il y a quelque chose à installer pour le chipset SIS 735 ?

Ce que je voudrais c'est des pistes pour arriver à cerner ( ou résoudre eh ;) ) le problème et/ou des indications sur comment instrumenter mon systeme pour arriver à avoir plus d'informations sur son état lors d'un freeze. Si une bonne ame veut m'aider je peux poster des fichiers de log si besoin.
  • # idées en vrac

    Posté par (page perso) . Évalué à 1.

    - essaye de désactiver le support de l'APIC : il ajouter noapic au parametre de lancement du noyau dans le fichier de conf de grub

    - regarde si le noyau répond encore après freeze de X : utilise les combinaisons Ctl+alt+sys+U (umout) puis Ctl+alt+sys+K (kill) puis Ctl+alt+sys+b (boot). Si ça reboot c'est que le noyau n'est pas complétement mort. Donc le pb se situe au niveau de la carte graphique

    - regarde les température avec lm_sensors ou avec les mains ;) : tape sensors dans un shell si il te réponds c'est que ça marche

    - repasse en voodoo3 voie si ça plante

    bon courage
    • [^] # Re: idées en vrac

      Posté par . Évalué à 1.

      Je vais essayer tes suggestions 1 et 2 déja.
      Pour la 3 une fois que c'est figé pas moyen de rien taper.
      Pour la 4 je suis moyennement chaud mais si il n'y a que ça à faire ...

      Par contre quand tu dis Ctl+alt+sys+K qu'est-ce que tu appelles la touche sys ? C'est la touche print screen/sys rq à coté de scroll lock ?
      • [^] # Re: idées en vrac

        Posté par . Évalué à 2.

        Pour le sys c'est effectivement la touche Impr.écran/Syst

        Par contre je rajouterais :

        5. Remplacer nvidia par nv dans le Xorg.conf pour tester sans le pilote nvidia
        • [^] # Re: idées en vrac

          Posté par . Évalué à 1.

          J'ai pas eu le temps de tester !

          Par contre j'ai vérifié la version de mon bios et apparemment mon CPU ( duron 1800 ) n'est pas supporté avec la version du bios que j'utilise donc je vais faire ça en premier.

          Pour le 5, nv est compatible avec les Geforce FX ?
          • [^] # Le bilan

            Posté par . Évalué à 0.

            1 - marche pas
            2 - ne marche pas non plus
            3 - rien à signaler
            4 - j'ai peur de flinguer mon port AGP avec la voodoo 3 ( voltage )
            5 - les performances vont être castrophiques et plus de 3d

            6 - j'ai mis à jour mon bios pour supporter le duron 1.8 GHz ---> ça ne change rien

            Bilan : j'ai reinstallé edubuntu et ça marche bien avec les drivers nvidia fourni par la distribution.
            Donc j'ai toujours pas compris le problème mais maintenant tout marche.

            Ca commence à me gaver linux. Si je n'avais pas eu besoin des applications qui sont sur la edubuntu je serais passé à freeBSD ...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.