Forum Linux.mandriva mise à jour Xorg

Posté par .
Tags : aucun
0
6
jan.
2005
bonjour,
j'ai cherché à mettre à jour Xorg-X11 avec un rpm.
Parce que MDK 10.1 official n'installe que la version 6.7 et j'ai besoin de la 6.8.
Seulement à l'installation du paquet 6.8 , il se fache et me dit que :
'X11libs est non satisfait (6.8.2)'
je ne comprend pas bien ce qu'il se passe...
quelqu'un a t-il une idée?
  • # Attention

    Posté par (page perso) . Évalué à 1.

    Tu ne pourras pas installer le paquet uniquement, il te faut toutes les dependances.

    Tu peux les telecharger puis rpm -Uvh --nodeps --force *.rpm
    , mais c'est crade et risqué.

    Essaye plutôt les sources cooker (xorg 6.8.1 est dans cooker) et
    ensuite urpmi xorg.
    • [^] # Re: Attention

      Posté par (page perso) . Évalué à 0.

      Jxorg 6.8.1 est dans cooker

      Oups je voulais dire 6.8.2 ->

      xorg-x11-100dpi-fonts-6.8.2-0.1mdk.i586.rpm
      xorg-x11-6.8.2-0.1mdk.i586.rpm
      xorg-x11-75dpi-fonts-6.8.2-0.1mdk.i586.rpm
      xorg-x11-cyrillic-fonts-6.8.2-0.1mdk.i586.rpm
      xorg-x11-doc-6.8.2-0.1mdk.i586.rpm
      xorg-x11-glide-module-6.8.2-0.1mdk.i586.rpm
      xorg-x11-server-6.8.2-0.1mdk.i586.rpm
      xorg-x11-xfs-6.8.2-0.1mdk.i586.rpm
      xorg-x11-Xnest-6.8.2-0.1mdk.i586.rpm
      xorg-x11-Xvfb-6.8.2-0.1mdk.i586.rpm
  • # methode

    Posté par . Évalué à 1.

    Merci de tes conseils.
    Mais je ne comprend pas bien la méthode à suivre pour mener à bien cette mise à jour;
    j'ai téléchargé les dépendances sur cooker. Mais quand je les lance, il y a encore les mêmes problèmes de dépendances. Il me dit toujours que X11libs manque, ou même d'autres pour cetains paquets....
    • [^] # Re: methode

      Posté par (page perso) . Évalué à 0.

      Pour cooker utilise les sources

      http://easyurpmi.zarb.org/(...)

      Par exemple:

      Supprime main
      urpmi.removemedia main

      Puis

      urpmi.addmedia main ftp://ftp.proxad.net/pub/Distributions_Linux/Mandrakelinux/devel/c(...) with media_info/hdlist.cz
    • [^] # Re: methode

      Posté par (page perso) . Évalué à 2.

      Une fois les dépendances téléchargées, il faut les installer AVANT les trucs qui en dépendent.
      Forcément.
      Mais ça veut aussi dire que xlibs 6.8.2 peut aussi dépendre de frozen-bubble-network-enabled.
      Là, ça craint, t'es pas prêt d'avoir un truc qui tourne.

      Et puis de manière généralé, j'ai tendance à croire que si tu ne sais pas ce qu'est une dépendance, tu n'as PAS besoin de mettre à jour (particulièrement pour les kernels).
      • [^] # Re: methode

        Posté par . Évalué à 1.

        VOilà,
        j'ai reussi à mettre à jour, avec tes consignes.
        Mais au redemarrage, j'obtiens ce message;

        " Fatal server error:
        could not open default font 'fixed'
        "
        Est-ce que c'est un rpm que j'aurais oublié ?
        ou le problème viendrait d'ailleurs ?
        • [^] # Fonte "fixed"

          Posté par . Évalué à 1.

          Dans mon fichier de config (/etc/X11/Xorg.conf) dans la "section Files" et identificateur "FontPath" j'ai:
          FontPath "unix/:-1"

          c'est normal ?
          Parce que je n'ai rien touché lors de ma mise à niveau, et que c'est ça qui devait marcher avec xorg 6.7...
          • [^] # Re: Fonte "fixed"

            Posté par . Évalué à 1.

            Dites j'ai téléchargez tout le bazare du Xorg 6.8.2-03 de mdk 10.1 mais une chose me décourage c'est si j'instale le tout est-ce que je peux le faire à partir du mode graphique?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.