Forum Linux.mandriva Problème boot windows suite à Partition magic

Posté par  .
Étiquettes : aucune
0
29
juin
2005
Voilà je vous expose mon problème :

Je viens de passer de mandrake 10.0 Community vers mandrake 10.1 Official.

Après la mise à jour, problème pour lancer KDE car pas assez de place sur la partition linux. par contre je pouvais booter sur windows.

Donc je me dis : "Essayons d'agrandir la partition linux pour pouvoir booter KDE !" , j'essaye d'utiliser Partition magic mais pas moyen d'agrandir la partition. par contre il me dis qu'il y a des erreurs et essaye de les corriger ??

Entre temps je supprime de la partition linux des fichiers inutiles et j'arrive finalement à booter sur KDE !

Problème : maintenant quand je veux booter sur windows, j'obtiens un écran noir avec un curseur clignaotant en haut à gauche !!!

Je suppose que partition magic a mis un peu le bazar mais je ne sais pas comment corriger ça ?

J'ai aussi essayer de booter avec l'utilistaire GAG mais j'arrive sur le même écran noir...
  • # Une piste

    Posté par  . Évalué à 2.

    Problème : maintenant quand je veux booter sur windows, j'obtiens un écran noir avec un curseur clignaotant en haut à gauche !!!

    Ca pourrait venir de ton "boot loader", un programme qui charge les OS au démarrage de la machine, qui ne sait plus ou trouver win. Je ne sais pas se que tu entends par: "Entre temps je supprime de la partition linux des fichiers inutiles", mais ça peut venir de là.

    Suivant ce que tu as supprimer, le mieux serait peut être de tout réinstaller comme suit:
    - fait la première phase d'install de ton win (je me rappelle plus de la manip exacte, je crois qu'il est question de F11 à un moment, mais pas sur)
    - redimensionne correctement tes disques
    - reinstalle mandrake

    Sinon tu peux toujours essayer de reinstaller ton boot loader (lilo ou grub). Voir les pages de man correspondantes.

    Hope it helps
    • [^] # Re: Une piste

      Posté par  . Évalué à 1.

      lilo est bien installé et fonctionne bien : je peux bien choisir entre linux, floppy, windows..., seulement quand je choisi windows j'arrive sur l'écran noir .

      j'ai même essayé avec GAG un boot loader (sur disquette) et c'est la même chose lorsque j'essaye de lancer windows

      j'ai essayé de réinstaller lilo en bootant avec le DVD linux, F1 rescue
      mais j'ai une erreur "kernel panic" !
      • [^] # Re: Une piste

        Posté par  . Évalué à 1.

        Au risque de répéter : Ca peut venir du boot loader...

        Si entre le momment où tu as installé Nux (et donc Lilo) et maintenant la structure de ton disque a changé (genre une partition crée ou supprimée) alors, Lilo ne trouve plus Windows a son emplacement initial.

        Il faut recionfigurer Lilo mais là demande à qq1 d'autre...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.