Forum Linux.mandriva Retour à un modem 56k (10.0)

Posté par  .
Étiquettes : aucune
0
24
mai
2005
Bonjour,
J'avais l'ADSL sur une Freebox avec Ethernet (eth1). Tout allait bien jusqu'au jour ou ma Freebox m'énerva à ne plus vouloir se synchroniser ...

J'ai mis un modem RTC 56K sur un port série.
Je configure la liaison avec les outils de configuration graphique, installe les packages kppp à partir des CD d'installation 10.0.

Je n'arrive pas a faire marcher Internet (je suis actuellemnt sur un portable professionnel avec W...).

Je lance Kppp qui ouvre la connexion mais c'est comme si cette connection n'était pas vu pour l'accès Internet.
Ifconfig me donne bien ppp0 avec des paramètres d'adresse IP qui semblent corrects.

Je ne vois pas bien ce qu'il faut faire.

J'ai essayé un CD Kaella qui me permet d'accèder à Internet par ce modem après configuration de kppp.

Une idée ?
  • # Couper Samba et/ou Ethernet

    Posté par  . Évalué à 2.

    Salut Didier,

    As tu Samba et/ou un réseau installé sur ta machine (ou as tu laissé la carte ethernet dans ton ordinateur) ? Non parce que moi j'ai eu le même problème que toi mais avec une ADSL : le ppp0 marchait bien mais impossible de surfer. J'ai découvert que c'était samba et ma carte réseau qui interféraient. Coupe samba et dans les connexions réseau supprime celle basée sur le port ethernet, puis lance ta connexion ca marchera peut être.

    Morigane
  • # Pas très clair...

    Posté par  . Évalué à 2.

    J'ai pas trop compris ta phrase c'est comme si cette connection n'était pas vue pour l'accès Internet.
    Si je résume: tu as donc une adresse IP sur le net (ifconfig te renvoie un ppp0 avec une adresse IP).
    Arrives-tu à pinger des adresses du net ? Arrives-tu à pinger des IP du net ? (car cela pourrait provenir du DNS mal reconnu si ça marche qu'avec les adresses IP)

    As-tu les bons paramètres de routage ? (route -v pour afficher la liste...) Il est possible qu'il essaie de passer en fait par l'interface eth0 en croyant qu'il peut toujours passer par ton modem adsl...
    • [^] # Re: Pas très clair...

      Posté par  . Évalué à 1.

      par "accès Internet" je veux dire firefox et les outils de configuration du centre de contrôle.

      Je ne peux pas pinger des url. Je n'ai pas essayé des IP.

      J'essairai de regarder les paramètres de routage dès que je rentre chez moi (vendredi soir).

      En tout cas merci pour ces pistes.
    • [^] # Complément sur ma configuration

      Posté par  . Évalué à 2.

      J'utilise Kppp pour configurer le compte et connecter au fournisseur (Free en l'occurence).

      J'ai créé le lien symbolique /dev/modem sur /dev/ttyS1 sur lequel est mon modem.

      Voici ce que ça donne (en root) :

      [root@Lucius didier]# ifconfig
      lo Lien encap:Boucle locale
      inet adr:127.0.0.1 Masque:255.0.0.0
      adr inet6: ::1/128 Scope:Hôte
      UP LOOPBACK RUNNING MTU:16436 Metric:1
      RX packets:729 errors:0 dropped:0 overruns:0 frame:0
      TX packets:729 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:0
      RX bytes:530362 (517.9 Kb) TX bytes:530362 (517.9 Kb)

      ppp0 Lien encap:Protocole Point-à-Point
      inet adr:62.147.85.112 P-t-P:192.168.254.254 Masque:255.255.255.255
      UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
      RX packets:6 errors:0 dropped:0 overruns:0 frame:0
      TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:3
      RX bytes:160 (160.0 b) TX bytes:97 (97.0 b)

      [root@Lucius didier]# route -v
      Table de routage IP du noyau
      Destination Passerelle Genmask Indic Metric Ref Use Iface
      192.168.254.254 * 255.255.255.255 UH 0 0 0 ppp0
      127.0.0.0 * 255.0.0.0 U 0 0 0 lo
      default 192.168.254.254 0.0.0.0 UG 0 0 0 ppp0
      [root@Lucius didier]# ping 213.228.0.42
      PING 213.228.0.42 (213.228.0.42) 56(84) bytes of data.
      From 62.147.85.112 icmp_seq=1 Destination Host Unreachable
      From 62.147.85.112 icmp_seq=1 Destination Host Unreachable
      From 62.147.85.112 icmp_seq=1 Destination Host Unreachable
      From 62.147.85.112 icmp_seq=1 Destination Host Unreachable
      From 62.147.85.112 icmp_seq=1 Destination Host Unreachable
      From 62.147.85.112 icmp_seq=1 Destination Host Unreachable
      ping: sendmsg: Operation not permitted
      From 62.147.85.112 icmp_seq=2 Destination Host Unreachable
      ping: sendmsg: Operation not permitted
      From 62.147.85.112 icmp_seq=3 Destination Host Unreachable
      ping: sendmsg: Operation not permitted

      --- 213.228.0.42 ping statistics ---
      3 packets transmitted, 0 received, +8 errors, 100% packet loss, time 2076ms

      [root@Lucius didier]# ls -l /dev/modem
      lr-xr-xr-x 1 root root 10 mai 27 23:19 /dev/modem -> /dev/ttyS1
      [root@Lucius didier]#

      Je ne sais pas quoi faire, le compteur de temps Kppp décompte et la ligne est bien occupée par le modem.
      • [^] # Re: Complément sur ma configuration

        Posté par  . Évalué à 1.

        Essaie voir un traceroute sur une adresse IP dont on est sûr qu'elle marche... genre linuxfr.org (212.27.33.225 au moment où j'écris ces lignes)
        C'est bizarre, ta table de routage semble correcte, mais ensuite ton ping devrait fonctionner... à condition que la machine 213.228.0.42 soit joignable !! Es-tu sûr qu'elle est allumée et disponible au moment de ton ping ?
        Un traceroute pourra te permettre de vérifier si ça essaie de passer par ailleurs...

        En revanche, ton ifconfig me semble tout-à-fait incohérent (et ce n'est pas de ta faute, rassure-toi !). J'ai du mal à comprendre comment il peut t'indiquer qu'il a réalisé une connexion P-t-P entre ton adresse WAN (62.147.85.112) et une adresse privée (192.168.254.254)... A mon avis, le pb viendrait donc d'abord de Kppp...

        Essaie un programme tout simple du genre pppconfig (dans une console, tu tapes ppp-config ou pppconfig je sais plus, et tu as ensuite des menus bien faits en ncurses) pour configurer une connexion PPP, puis tu n'as qu'à taper ensuite pon maconnexion (maconnexion est le nom que tu auras donné à ta connexion dans pppconfig) pour initialiser la connexion, puis poff pour stopper la connexion ou poff -a pour stopper toutes les connexions ppp actives. Personnellement, j'utilise ce moyen pour me connecter en PPP sous Debian, et ça fonctionne nickel ! (mieux que Kppp à mon goût)
        • [^] # Re: Complément sur ma configuration

          Posté par  . Évalué à 1.

          Merci.
          C'était une régle d'iptables (par shorewall) qu'il fallait changer.
          La définition de l'environnement net qui pointait sur eth1 au lieu de ppp0.
  • # Résolu: Pb son

    Posté par  . Évalué à 1.

    Shorewall stop ... et tout est rentré dans l'ordre.

    Il faut que je regarde les règles du pare feu.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.