Forum Linux.noyau chargement du modules cls_u32 ?

Posté par .
Tags : aucun
0
29
jan.
2005
bonjour,

Pour contrôler ma bande passante j'ai voulu essayer le script wondershaper version htb ( http://www.lartc.org(...) ). le problème c'est que j'obtiens plein d'erreurs lors de son exécution...

Unknown qdisc "htb", hence option "default" is unparsable
Error: Qdisc "htb" is classless.
Error: Qdisc "htb" is classless.
Error: Qdisc "htb" is classless.
Error: Qdisc "htb" is classless.
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument
RTNETLINK answers: Invalid argument

Et j'obtiens seulement les "RTNETLINK ..." avec la version cbq.
En fait je pense que c'est du au fait que le module cls_u32 n'est pas chargé ...
Mais lorsque je veut charger cls_u32 j'obtiens ça :

/lib/modules/2.4.27/kernel/net/sched/cls_u32.o: unresolved symbol tcf_police_dump
/lib/modules/2.4.27/kernel/net/sched/cls_u32.o: unresolved symbol tcf_police
/lib/modules/2.4.27/kernel/net/sched/cls_u32.o: unresolved symbol tcf_police_destroy
/lib/modules/2.4.27/kernel/net/sched/cls_u32.o: unresolved symbol tcf_police_locate
/lib/modules/2.4.27/kernel/net/sched/cls_u32.o: insmod /lib/modules/2.4.27/kernel/net/sched/cls_u32.o failed
/lib/modules/2.4.27/kernel/net/sched/cls_u32.o: insmod cls_u32 failed

De plus aucun des classifiers (cls_* ) ne se charge et j'obtiens le même type d'erreurs.
Je n'ai aucune idée de ce que peut être "tcf_police", et google ne m'a pas beaucoup aidé sur ce problème ...

Voila si vous avez une idée , une piste , un conseil ... toute aide est la bienvenue ;)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.