Forum Linux.redhat gestion du touchpad

Posté par (page perso) .
Tags : aucun
2
2
déc.
2011

Je travaille sur un portable sur lequel j'ai installé plusieurs distributions linux (fedora, ubuntu, debian, mandriva). Le touchpad marche bien de base sur toutes ces distributions, sauf la fedora : je n'arrivais pas à activer la fonction "tap" :(

Après avoir fouillé les forum et essayé plein de clickodromes inutiles, j'ai fini par par me plonger dans la ligne de commande.

Sachant que c'est un driver synaptics, je recherche le package rpm : rpm -qa | grep synaptics

je regarde le contenu du package : rpm -qil xorg-x11-drv-synaptics

je lis les man pages du package : man synclient

je dump la configuration du touchpad : synclient -l

je compare avec une autre distribution et hop, ça devient évident : les paramètres TapButton1 TapButton2 TapButton3 sont indéfinis

une dernière commande : synclient TapButton1=1 et ça marche !!!

Il ne reste qu'à automatiser la chose, le plus simple est d'ajouter une ligne
Option "TapButton1" "1" dans le fichier /usr/share/X11/xorg.conf.d/50-synaptics.conf.

  • # etc !

    Posté par . Évalué à 2.

    dans le fichier /usr/share/X11/xorg.conf.d/50-synaptics.conf.

    Si tu ne veux pas que ça risque de sauter à la mise à jour, mieux vaudrait mettre ta version modifiée dans /etc/X11/xorg.conf.d .

    Sinon, ça n’est pas courant un article de forum qui donne une solution plutôt que de poser une question. Il est vrai que ça peut servir à d’autres.

    Théorie du pot-au-feu : « Tout milieu où existe une notion de hauteur (notamment les milieux économique, politique, professionnels) se comporte comme un pot-au-feu : les mauvaises graisses remontent. »

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.