Forum Linux.suse Configuration carte réseau full duplex

Posté par  .
Étiquettes : aucune
0
20
avr.
2005
Bonjour, petit problème avec SLES9, au boulot, nous sommes occupés à installer des serveurs avec SLES9, toutefois, les cartes réseaux se mettent en half duplex au lieu de full duplex car le switch ne fait pas d'autonégociation.

Sous RH3, il suffit de faire des aliases dans /etc/modules.conf, mais dans SLES9, le fichier n'existe même pas, et créer un modules.conf similaire à celui de RH3 ne change rien.

Y a-t-il quelqu'un qui sache comment régler ce problème de manière simple et répliquable facilement.
  • # .... une piste...

    Posté par  . Évalué à 1.

    Je ne connais pas Suze mais sous Debian tu peux le configurer avec mii-tool. Peut etre que la commande existe aussi sous suze
    • [^] # Re: .... une piste...

      Posté par  . Évalué à 2.

      Merci, mais malheureusement, ça ne configure pas l'interface de manière durable.... en cas de reboot ou de redémarrage de l'interface, c'est retour à la case départ...

      ce que je cherche, c'est la manière "officielle" de configurer le full duplex et la vitesse par interface explicitement dans suse... et à pouvoir facilement pousser cette modif sur une cinquantaine de serveurs...

      Merci d'avoir essayé en tout cas!
  • # sysconfig

    Posté par  . Évalué à 2.

    si tu vas dans /etc/sysconfig/hardware/ tu dois avoir un fichier qui sert à identifier ton périphérique réseau et lui associer un module, tu dois pouvoir lui indiquer des options pour qu'il passe en full-duplex je pense.
  • # kernel 2.6 -> /etc/modprobe.conf

    Posté par  . Évalué à 2.

    Si je ne m'abuse, la SLES 9 utilise un noyau linux 2.6. Donc c'est normal de pas trouver de fichier modules.conf, puisque depuis le noyau 2.6 c'est le fichier modprobe.conf qui est utilisé.
    • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

      Posté par  . Évalué à 2.

      Un bon point... effectivement, ce "détail" m'était passé au dessus de la tête. (honte sur moi).

      Sinon, y a t'il une méthode préconisée pour ce type de modifs dans modprobe.conf?
      • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

        Posté par  . Évalué à 1.

        Je suis pas sur, mais je pense que ça dépend du module de ta carte réseau. Si ça dépend bien du module noyau (par exemple 8139too pour ma RTL8139) tu devrai trouver toutes les options possible à passer au module concerné dans la doc du noyau linux fournit dans le paquetage kernel-source que tu peux installer avec yast.
        • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

          Posté par  . Évalué à 2.

          intéressant...

          mais le problème c'est de pouvoir appliquer ce changement sur une grosse vingtaine de machines (plus si la direction est convaincue par linux) et d'intégrer celà dans le script d'installation automatique.

          il s'agit de machines type HP blade avec interfaces réseau (module bcm5700).
    • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

      Posté par  . Évalué à 2.

      Après avoir un peu fouillé, il apparaît que chez SuSE, les module des cartes réseau sont configurées dans /etc/sysconfig/hardware/ au moyen de fichiers comme hwcfg-bus-pci-0000:02:01.0 .
      C'est d'ailleurs ce fichier qui est utilisé par yast pour la config des modules des cartes réseau.

      Malheureusement, une config comme

      MODULE='bcm5700'
      MODULE_OPTIONS='line_speed=0 full_duplex=1 auto_speed=0'
      STARTMODE='auto'



      ne donne rien comme amélioration au niveau du duplex. Ai-je fait quelque-chose de travert?

      En passant, avec coldplug, il semble bien que le compteur d'instances affiché par lsmod reporte 0 utilisations du module bcm5700, mais si je fais un rmmod bcm5700, le réseau s'arrète... étonnant cette situation où lsmod dit "on ne l'utilise pas" alors que c'est utilisé.
      • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

        Posté par  . Évalué à 1.

        Et si tu mettais la ligne suivante dans modprobe.conf :

        options bcm5700 full_duplex=1
        • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

          Posté par  . Évalué à 2.

          je peux toujours voir ça demain... mais à priori, c'est pour le hotplug modprobe.conf, non? Le truc c'est que les cartes réseau sont en coldplug...
          • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

            Posté par  . Évalué à 1.

            Je pense pas que se soit uniquement pour le hotplug.
            Normalement, les options que contient modprobe.conf seront passées aux modules concernés quel que soit la manière dont ils sont chargés (hotplug, coldplug ou bien encore avec la commande modprode).

            Donc à mon avis, essayes quand meme, fais la modif, tapes depmod -a et reboot.
        • [^] # Re: kernel 2.6 -> /etc/modprobe.conf

          Posté par  . Évalué à 2.

          ... effectivement, ça marche!

          A noter, dans le cas où des serveurs dont je m'occupe, il y a 4 interfaces réseau et dans ce cas, il faut mettre la ligne comme ceci (la 1è carte est sur un switch gigabit):

          options bcm5700 auto_speed=0,0,0,0 line_speed=1000,100,100,100 full_duplex=1,1,1,1

          Un grand merci à tous!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.